none
Extremely slow SMB network speed Server 2012 R2

    Question

  • I have absolutely horrible transfer speed on a new gigabit switch with DC Server 2012 R2 running Essentials.  I made the following change and rebooted after even forcing a GP update:  
    Open up Group Policy Editor, and right-click-and-edit Default Domain Controller Policy.  Go to Computer Configuration/Policies/Windows Settings/Security Settings/Local Policies/Security Options, and set Domain member: Digitally encrypt or sign secure channel data (always) and Microsoft network server: Digitally sign communications (always) to Disabled.  

    The server has two GB Nics in bridge mode in the switch, and the lan speeds are horrible: a 95 MB folder is transferring at less than 89 KB, and even slows.  

    All clients are Windows 7 Pro.  

    Any other ideas than just this change?  Maybe a difference with Server 2012 R2?

    One clue: I can pull a 16 GB PST file from a client experiencing this issue with no delay, but if I attempt to send the file it fails.  I am using the c$ share on the client.  Could this just be wiring in the cable and bad receive pairs?  
    • Edited by wosully Monday, February 17, 2014 2:13 PM
    Monday, February 17, 2014 12:48 PM

Answers

  • Thanks, I was reading that!  Just resolved it: it was an issue with the Broadcom Extreme Network cards.  They are onboard the board and installed with the OS when I installed it, but had to change the default settings as follows, under the advanced tab of the drivers:

    Under the advanced tab, offloading features that needed to be disabled:

    Ipv4 checksum offload
    largesend offload V2(ipv4)
    largesend offload V2(ipv6)
    Vm queues
    TCP Checksum offload (ipv4)
    TCP checksum offload (ipv6)
    Udp checksum offload (ipv4)
    Udp checksum offload (ipv6)

     

    • Marked as answer by wosully Tuesday, February 18, 2014 2:37 PM
    Tuesday, February 18, 2014 2:37 PM

All replies

  • Hello,

    The following KB is worth a try:

    Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008

    http://support.microsoft.com/kb/951037

    Similar thread:

    Slow Network Write Speeds via SMB & CIFS

    http://social.technet.microsoft.com/Forums/en-US/46898c7f-92e0-4c99-98d2-18a7458a7d2d/slow-network-write-speeds-via-smb-cifs?forum=winserverfiles

    Hope this helps.

    Tuesday, February 18, 2014 6:13 AM
    Moderator
  • Thanks, I was reading that!  Just resolved it: it was an issue with the Broadcom Extreme Network cards.  They are onboard the board and installed with the OS when I installed it, but had to change the default settings as follows, under the advanced tab of the drivers:

    Under the advanced tab, offloading features that needed to be disabled:

    Ipv4 checksum offload
    largesend offload V2(ipv4)
    largesend offload V2(ipv6)
    Vm queues
    TCP Checksum offload (ipv4)
    TCP checksum offload (ipv6)
    Udp checksum offload (ipv4)
    Udp checksum offload (ipv6)

     

    • Marked as answer by wosully Tuesday, February 18, 2014 2:37 PM
    Tuesday, February 18, 2014 2:37 PM
  • Thanks! This helped for Dell PowerEdge running Windows Server 2012 R2 with Broadcom cards.

    • Proposed as answer by abc.com Wednesday, July 16, 2014 10:35 AM
    Friday, March 21, 2014 1:23 PM
  • Dell PowerEdge with 2012 R2 here as well, but I don't have ipv4 checksum offload.. I do have all the others.

    I also have ARP Offload and NS Offload, but it's correct to leave those two enabled, yes?

    Monday, June 9, 2014 6:00 PM
  • Thanks for the answer wosully. You saved our life here extremely frustrated what did not we troubleshoot PC, switch, Router.
    Friday, April 10, 2015 3:41 PM
  • You are welcome.  I know how frustrating this can be.  Glad I could help.  
    Friday, April 10, 2015 3:46 PM
  • Hi wosully

    im doinng exactly instruction u given by disable gpo & offloading features, but the issue still presist :(

    it's anything that i must do with?

    Please advise.

    Thank you

    Tuesday, May 5, 2015 7:29 AM
  • You certain you configured this for all NICs on the system:

    Change the default settings as follows, under the advanced tab of the drivers:

    Under the advanced tab, offloading features that needed to be disabled:

    Ipv4 checksum offload
    largesend offload V2(ipv4)
    largesend offload V2(ipv6)
    Vm queues
    TCP Checksum offload (ipv4)
    TCP checksum offload (ipv6)
    Udp checksum offload (ipv4)
    Udp checksum offload (ipv6)

    Tuesday, May 5, 2015 12:07 PM
  • Perfect !!

    Also works with a HP StorageWorks X1600TO running Windows Server 2012 R2 Standard with two Intel 82576 Gigabit Adapter on Teaming (had to change parameters on both cards but not on the teaming driver).

    Thank you very much

    Monday, August 17, 2015 1:21 PM
  • Same issue, and I could actually see the difference since I had file transferring at about 30 kbps, after making the change went to 10 mbps
    • Edited by Matt_1689 Monday, November 23, 2015 3:47 AM
    Monday, November 23, 2015 3:47 AM
  • Updating the NetXtreme Broadcom Drivers from Dell's website solve the VM Queues

    To fix the slow upload, had to disabled only those two:

    largesend offload V2(ipv4)
    largesend offload V2(ipv6)


    • Edited by Matt_1689 Monday, December 7, 2015 12:44 AM
    • Proposed as answer by MauroR1 Friday, October 6, 2017 12:32 PM
    Monday, December 7, 2015 12:43 AM
  • Same goes for a INtel LMI218 NIC on a Asus Z97A MObo

    I think it is independent of the NIC brand it is just the options that need to be disabled.

    Thanx for the info it solved my problem :)

    Monday, May 2, 2016 3:17 PM
  • Thanks very much, this worked great for me, it was very frustrating with the slow speeds and such a simple fix :) 
    Saturday, September 17, 2016 2:26 AM
  • The offloading features vary a bit, but solution also worked for Windows Server 2016 x64
    Wednesday, July 26, 2017 7:27 PM
  • My problem was a WD NAS device and copying from C: to a NAS folder the speed was around 20mb/s.

    My on-board LAN is a RealTek Gigabit device, but I decided to try the above disabled settings anyway and the speed instantly shot up to 95mb/s.

    I didn't quite believe it so reverted to original settings and it slowed way down again. 

    So, thank you; fantastic job.

    Regards,

    Mike


    Mike


    • Edited by mlhifi Wednesday, September 27, 2017 3:13 PM
    Wednesday, September 27, 2017 3:13 PM