none
Can repair-bde recover contents of an encrypted drive that failed during decryption but paused? RRS feed

  • Question

  • Hi,<o:p></o:p>

    According to the MS website the Repair-bde tool cannot be used to repair disks that became corrupted during decryption. Does this statement also apply to a disk that has become damaged while the decryption was paused?

    (I paused the cmd line decryption, turned off the machine with the button and then on restarting via repair mode opened a cmd prompt and tried to resume decryption with manage-bde, but it no longer recognizes the password or recovery key.  I want to see if i can at least save my data).

    Thanks

    Adrian



    Thursday, April 11, 2019 8:32 PM

All replies

  • Hi Adrian,

    The Repair-bde command-line tool is intended for use when the operating system does not start or when you cannot start the BitLocker Recovery Console. You should use Repair-bde if the following conditions are true:

    You have encrypted the drive by using BitLocker Drive Encryption.

    Windows does not start, or you cannot start the BitLocker recovery console.

    You do not have a copy of the data that is contained on the encrypted drive.

    The following limitations exist for Repair-bde:

    The Repair-bde command-line tool cannot repair a drive that failed during the encryption or decryption process.

    The Repair-bde command-line tool assumes that if the drive has any encryption, then the drive has been fully encrypted.

    More information here

    repair-bde

    https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/repair-bde

    For your scenario, I think you could have a try, good luck.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 12, 2019 1:41 AM
    Moderator
  • Hi Teemo,

    Yes all the conditions you stated are true. Here is the long version of what happened to me:

    =========================

    I have a Samsung laptop (Np550p7c) running Windows 10 Pro. It is protected with Bitlocker.

    Up until two days ago I have been using it pretty much daily for the last 9 or so years without any issues.

    Yesterday, I switched it on and entered my password in the Bit Locker startup screen. Instead of booting into Windows it went to the BitLocker recovery window showing the msg saying the recovery password was needed. I located that recovery key in my MS Account and entered it but the machine would not still not start up.

    So then I looked at the other repair options via the link at the bottom of the same window where I had entered the recovery key. I noticed there were several repair options including one allowing me to reset the pc without losing my personal files. However, I hoped to still get the whole machine running again so I did not choose any other options. Instead I turned to Google and found several sites recommending to create a bootable DVD or USB, boot from that and then access repair options that way.

    So I created a bootable USB. However, I then had to adjust the BIOS so that it would boot from it. When i first looked at the Boot Priority settings in the BIOS there was nothing listed there at all. I added the USB drive as the first boot option. Then I booted up the machine and, as expected, it showed me the Win10 install dialog. I accepted the defaults and clicked Next and then clicked the "Repair" link at the bottom. The Repair options appeared but actually they were the same as the ones I had already seen when booting as usual from the hard drive except this time there was no option to reset the drive.

    One of the options was a cmd prompt. I ran that and at first was unable to access the C drive as it said it was bit locked. However, I then used manage-bde to unlock it and was able to see my files via the cmd window.  At this point I did something very stupid. I thought it might be easier to recover the machine if I decrypted it completely, so I started the decryption. After about 8 hours it seemed to be stuck on 83% encryption (meaning it had only decrypted about 17%). I thought it might be quicker if I used the bootable USB stick in my USB 3.0 port rather than the USB 2.0 port. So I decided to pause the encryption and then turn the machine off (pressing the button as there was no other way to do it). This was stupid thing to do number two.

    After turning the machine back on again I first tried booting from the hard drive hoping all the issues might have gone away. However, I was no longer presented with the bitlocker window, it just showed the Samsung logo and that's it. So I booted from the USB again with the intention of returning to the CMD window and resuming the decryption. However, this time when running manage-bde it did not accept either the password or the recovery key. That’s when I realized my bodged attempt at decrypting had just made things worse.

    In desperation I turned to the repair-bde tool. However I am not sure if it will work because according to the Microsoft documentation it does not work for disks damaged during decryption. I am not sure if this means actively decrypting at that time of the corruption or it also applies to a paused decryption process. 

    As you are telling me it might be worth a try I will go and buy the 2TB external hard drive that I will need for the repair-bde fix.

    Thanks,

    Adrian


    Friday, April 12, 2019 6:43 AM