Failed to resolve the Replica Server- Hyper V 2012


  • Hi,

    In my environment I have 2 Hyper V Hosts, with 2 VM's on Hyper V1, we have configured replication to Hyp V2 Server. Currently both Servers from V1 are replicated to V2 with replication health showing as normal.
    We have checked and tested the failover and confirmed as successful. The planned failover is working fine for the Server. But when I try to perform the  'reverse replication direction after failover' its getting failed at the step 'reverse replication direction'. 

    As a troubleshooting method we performed the below:
    -The replication and planned failover is working fine
    -Changed the SPN in AD under machine attributes, so as to communicate with Hyper V hosts
    -Confirmed proper communications/ping as available  
    -Confirmed the port 80 as opened on both Hyper V hosts
    -Port 443 currently closed (do we need to open?)
    -Modified the hosts file and added the information of both Hyper V hosts on both Servers

    -We have also turned off the Firewall on both Hyper V host Servers and tried the same but still the issue persists

    Our previous scenario was like the below:

    Initially both Hyper V Host Servers were in workgroup and we faced similar issue while configuring replication.
    Hence we have added the same to our domain that is domain.local. Also checked and confirmed that "Primary DNS suffix of this computer" check box as checked.

    A quick response is much appreciated, Thank you !!!!!!

    Wednesday, August 20, 2014 5:14 PM


All replies

  • What's the OS on the 2 Hyper-V hosts?

    Sam Boutros, Senior Consultant, Software Logic, KOP, PA (Please take a moment to Vote as Helpful and/or Mark as Answer, where applicable)

    Wednesday, August 20, 2014 6:47 PM
  • Hi Sam,

    We have Windows 2012 R2 Standard on both Servers.

    Wednesday, August 20, 2014 7:24 PM
  • Do the 2 hosts' replication and firewall settings look like this:


    They have to be domain members, with access to domain controllers.

    If settings are different than this, can you post screen shots?

    Sam Boutros, Senior Consultant, Software Logic, KOP, PA (Please take a moment to Vote as Helpful and/or Mark as Answer, where applicable)

    Wednesday, August 20, 2014 7:34 PM
  • Hi Sam,

    The above settings are similar to the configs in our Hyper-V servers. We are receiving the below error when performing failover with reverse replication enabled :

    Hyper-V failed to resolve the Replica server 'HYPERV1.domain' name. Verify that the Replica server name provided is correct

    Even though the correct FQDN is HYPERV1.domain.local, the server is trying to resolve to HYPERV1.domain and hence is getting failed. The failover gets completed if you go to the Reverse replication option in the replication menu of the replica server and manually modify the FQDN to HYPERV1.domain.local.

    We have also tried adding entries in the host file of both Hyper-V servers for 'hyperv.domain' to point to the corresponding hyperv servers.

    Other than this we constantly receive error logs in both the servers that 'Failed to register SPN' for hyperv services even though the SPNs were configured correctly.

    Appreciate a quick response

    Wednesday, August 20, 2014 10:25 PM
  • sounds like a name resolution problem. I would use a tool like this to query "authoritative", then specific dns servers. Also, I will make sure both hosts have a single DNS server entry (for testing) to point to the same DNS server. Then from host-A query that DNS Server for Host-B and vice versa. Try 

    ipconfig /registerdns
    on both servers, examine the DNS records manually to make sure each server has accurate dns A records. Last resort disjoin and rejoin the domain..

    Sam Boutros, Senior Consultant, Software Logic, KOP, PA (Please take a moment to Vote as Helpful and/or Mark as Answer, where applicable)

    Wednesday, August 20, 2014 10:38 PM
  • Hi Sam,

    We have checked the DNS settings of both servers and confirmed that both are pointing to AD DNS Server.

    Currently when we try to perform a planned failover with both options checked

    -Reverse the replication direciton after failover
    -Start the replica virtual machine after failover

    We are getting a error "Hyper-V failed to enable replication for virtual machine'Hyperv1'.The connection with the server was terminated abnormally."

    Also in our scenario we have squid proxy server, we have added *.domain.local and intrantet ip address to by pass the traffic.After that also we are receiving the same error.But if we try to manually reverse replicate then it is working.

    Thursday, August 21, 2014 9:59 PM
  • Hi Noc_server,

    Please allow me to state my understanding for this behavior .

    Reverse replica used for "unplained failover" .

    It means that when the primary server is offline we need to set the VM online in replica server (in replica server right click that VM --> replication --> failover --> select a recovery point  --> then the replica VM will online ), if the primary server online again (the VM in primary server is off ) we may use "reverse replication" .

    In reverse replication wizard we need to give a correct FQDN of primary server , this FQDN is also used for Kerberos authentication not only for DNS query (the primary server will be replica server after finishing the wizard ) .

    Best Regards

    Elton Ji

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, August 22, 2014 2:05 PM