locked
Full Screen DOS Apps display no longer work and just display as black screen. RRS feed

  • Question

  • We have a Dell Optiplex Quad Core running Windows XP SP3.

    For the past year we have been running 4 DOS Apps in full screen mode with no problem.  Then one morning all of a sudden we just see a black screen (sometimes there is a bit of greenish looking garbage across the horizontal top of the screen.  I have found that the program is still responding to keystrokes so if I know what keys to hit I can exit the program.  I can also hit ALT-ENTER and get windowed mode and displays and works properly.  If I hit ALT-ENTER again it goes black, but still allows keystrokes.

    I did remote control the unit later with LogMeIn and it does the same thing accept with LogMeIn when I ALT-ENTER back and forth I can see the last screen the full windowed mode should have been displaying after the last keystroke.

    Since we do imaging every night I simply said lets restore the full image and don't worry about what caused the corruption.  The image restored and all was good.  BUT the next morning after an hour of working in other programs I went to fire up one of the DOS apps and it was doing the same thing again.

    So my initial reaction is something is updating.  So I examined the microsoft update logs and nothing updated according to the logs.  I examined the Trend Micro update logs and the pattern file did update.  I examined LogMeIn and nothing had updated.  I checked to see what else autoupdates and didn't really see anything else.

    So after this I started uninstalling uneccessary programs and little utilities.  I also completely disabled Trend and turned off LogMeIn.  Nothing made a difference.  So at this point I don't know what is causing it.

    I ran the CMD in a full DOS screen (no application) and it does load and I can type dir and stuff.

    I also downloaded DOSBOX (Dos Emulation program) and I can run the apps in full screen mode using this.

    So at this point I am at a loss.  Has anyone ever experienced such a thing and have any ideas.

    My next step if I don't get any responses is to restore back again, take a snapshot of the system with one of several tools, play with system until it fails again and take another snapshot so I can compare what actually changed.

    Thanks for your time.

    Tuesday, December 7, 2010 9:54 PM

All replies

  • Since you do complete image backups of your system.

    Have you compared system image files? Certain updates may have happened that changed your settings. Video card driver may have been updated also. 

    Have you checked the underlying system files like dot net. visual studio runtime.

    When certain things have been updated like .net some things have been broken.

    I am guessing you have ran the usual suspects. Chkdsk /f. defrag.exe Tried turning off indexing. or checked latest version windows search 4. I dont always keep up with this. But sometimes mal ware protection programs may be competing with some search versions.

    Keith 

    Saturday, January 8, 2011 1:31 PM
  • I am also having this problem running a dos program. Computer is Dell lattitude D820 with XP pro. Hoping someone comes back with the cause and cure.

    thx,

    Monday, March 14, 2011 7:31 PM
  • I am also having this problem running a dos program. Computer is Dell lattitude D820 with XP pro. Hoping someone comes back with the cause and cure.

    thx,


    I had forgot about this post so let me pass my findings on... sorry for not doing this before.

    This problem was due to a startup program from Intuit ProSeries accounting software.  I can't remember if it was in the startup program folder or the HKLM\Software\Microsoft\Windows\CurrentVersion\Run or the HKCU\Software\Microsoft\Windows\CurrentVersion\Run location, but it was in one of them.

    I am sorry I don't remember which actual startup program it was, but as soon as I removed it the full DOS screens started working again.  It wasn't a required startup so it didn't hurt anything.

    What I would do is perhaps use the MSCONFIG to edit your startup items and disable everything (unless you do have ProSeries then you can isolate quickly) and then work you way back until it starts working.  You don't have to reboot each time... just block them all, reboot, test, if DOS full screen works then start manually running each startup item and test after each one and see if one is causing the problem.

    Of course you could have something completely different.

    Best of luck.

    Greg

    • Proposed as answer by firststknight Thursday, March 17, 2011 11:08 PM
    Monday, March 14, 2011 8:23 PM