none
Single Monitor, Windows 7 Detects 2!

    Question

  • Currently I have a single monitor connected to an ATI Radeon X850 Pro (yes, its an older desktop computer).  Whenever the computer shuts down or goes into sleep, when it starts back up it has an extended desktop.  

    In other words, when I right click on the desktop and select screen resolution, it shows two monitors connected.  I only have one plugged in, and I have never plugged a second one in either.  I have to click detect, it goes to one monitor (the right one) and then OK. 

    As soon as the computer goes to sleep or hibernate, whatever....the 'ghost' monitor comes back! 

    Any help would be appreciated.  BTW, standard Windows 7 display driver for the graphics card.
    Saturday, August 8, 2009 9:15 PM

Answers

  • open up display's (right click desktop background and select screen resolution). Click on the #2 display (it has a 2 on it) until it has a blue border to ensure it is selected. Under "multiple Displays" drop down menu select "Remove this display". Click OK or Apply. You should now see only one Display at the top near "detect" and Identify" buttons.
    Tuesday, September 3, 2013 3:14 AM

All replies

  • A ATI x850 should have 2 monitor outputs, and win7 sometimes does weird things when resuming from sleep.

    win7 may just be detecting that a 2nd output is available, so I wouldn't worry about this.
    Hello! Please try every solution given to your problem...and reply back, promptly if possible with its results...

    Click here for my thread on Win7 min. system requirements
    - JoelbX
    Saturday, August 8, 2009 9:23 PM
  • Well considering my mouse will go off the right side of my screen and take awhile to come back, it is annoying.  Win7 thinks there are two and extends the desktop that the mouse can traverse. 

    Its a bug which shouldn't happen.
    Sunday, August 9, 2009 6:06 PM
  • Well considering my mouse will go off the right side of my screen and take awhile to come back, it is annoying.  Win7 thinks there are two and extends the desktop that the mouse can traverse. 

    Its a bug which shouldn't happen.

    Hi

    Are you using the RC or RTM version of Windows 7?

    What is the computer make and model?

    In Control Panel / Device Manager, what do you see under Monitors?
    What do you see under Display Adapters?

    Let us know.

    Thank You for testing Windows 7


    Ronnie Vernon MVP

    Sunday, August 9, 2009 8:52 PM
    Moderator
  • Well considering my mouse will go off the right side of my screen and take awhile to come back, it is annoying.  Win7 thinks there are two and extends the desktop that the mouse can traverse. 

    Its a bug which shouldn't happen.

    Hi

    Are you using the RC or RTM version of Windows 7?

    What is the computer make and model?

    In Control Panel / Device Manager, what do you see under Monitors?
    What do you see under Display Adapters?

    Let us know.

    Thank You for testing Windows 7


    Ronnie Vernon MVP

    Ronnie,

    Using the RC version of Windows 7 on a Dell Dimension 8200 with 2GB ram, 2.4Ghz single core processor, ATI x850 Pro.

    Under the Device manager, Monitors: Dell 1702FP(Digital) and Generic Non-PnP Monitor (which I have tried to remove before and actually shows disabled right now)
    Under Display Adapters: ATI RADEON X850 PRO (Microsoft Corporation - WDDM)

    Under Screen Resolution from right click on the desktop, I have two displays showing: 1. Other, Landscape, Extend these displays, and 2. Dell 1702FP, Landscape, Extended these displays.  The Dell display shows it being the main display. 

    I can obviously hit detect, and it selects the Dell and the other 'ghost' display is gone.  But after every sleep or hibernation, it goes back to the settings described above.

    Thanks for any help you can give me.

    Monday, August 10, 2009 12:44 PM
  • I have the same problem. :-(
    Friday, December 18, 2009 4:04 PM
  • Any solutions to this problem?  Still haven't been able to fix it! 
    Monday, December 21, 2009 8:55 PM
  • Any solutions to this problem?  Still haven't been able to fix it! 

    Hi,

    Seem like this problem is not restricted to ATI cards alone. I have a core i7 920 with a GTX 275. single lcd monitor, Windows 7 64 bit setup.
    The Gigabyte GTX 275 card works fine as I pulled it from my old PC, a Windows VISTA 32-bit system which never exibhited this problem.

    The card has a HDMI, vga and a DVI interface.

    On reboot, it flashes the windows desktop and the boot up sequence completes, it displays a blank screen. Initially, I thought the system was resetting the monitor because the "Windows hardware remove" sounds at that point. Further investigation indicate the system was detecting a 2nd monitor thru the Display->screen resolution program and the system was displaying the 2nd monitor even though it doesn't exist. To see my desktop, I had to resort to unplugging and re-plugging the DVI connector - not something I want to do everytime I boot up my computer.

    I have tried a number of fixes/work arounds including
    1) re-installing the Windows 7 64-bit a few times which did not work.
    2) Not installing the latest driver
    3) Installing the latest driver
    4) Uninstalling the latest driver
    5) Using Device Manager to disable the "Generic non PnP Monitor" which worked for a while but the system is back to booting a blank screen again.
    6) Switching the monitor on only after I hear the "Windows hardware remove" sound each time I reboot sometimes work.


    After all that investigation, I inititially thought it may be a Nvidia driver problem but if it is occuring with an ATI card/driver also, it may be a Windows 7 problem.

    Any suggestions/help to this problem would be most appreciated.

    Thanks
    Thursday, December 31, 2009 3:32 PM
  • I'm having the same basic problem.  I'm running W7 x64 home premium with a NVIDIA Geforce 7300 SE driver.  Every time my computer goes to sleep, the system loses my monitor settings and resets it to a default monitor (and it also creates a ghost monitor, like eriddler ( the original poster says).  As a result, the color calibration and resolution are both off.  To solve the problem, I need to go to the Scree Resolution control panel and click on Detect.  After that, the computer returns to the correct monitor settings (until the next time it goes to sleep).

    Any solutions?
    Thursday, January 21, 2010 3:28 PM
  • Have the same problem as Kesda. I have Windows 7 x64 and Gigabyte GTX260 with same ports (HDMIx1, DVIx1, VGAx1). In my case the only thing that I've been able to do is connect my monitor to HDMI connector and select in "Screen Resolution menu" under "Multiple Display:" option "Show desktop only on 1" (which is HDMI in my case). I still hear that annoying sound about "new" hardware on every ghostly detection of "Generic Non-PnP Monitor", but at least there is no image blinking, disappearance or mouse cursor go off my "real" screen.

    I hope that my experience will help to someone:).
    Cheers!
    • Proposed as answer by Maxim Luppov Wednesday, February 24, 2010 10:40 AM
    Monday, February 8, 2010 3:20 PM
  • Unfortunately i have the same problem.....

     

    i am currently using a ATI Radeon x600 series graphics card and my screen is "spilling" over to the right... very very far right.

    When I am in Display --> Screen Resolution it detects a duplicate of my monitor (Dell 1704FPT). When I click "Detect" this monitor still shows up and a small box appears next to second monitor saying "Another Display Not Detected."

    How do i get rid of the duplicate non-existing monitor???

     

    Here is some additional info:

    Orientation: Landscape

    Multiple Displays: Extend these displays (other options include: Duplicate these displays, Only show desktop on screen 1, and only show desktop on screen 2)

    Thanks in advance,

    Robby D

     

    Wednesday, April 28, 2010 9:16 PM
  • Disregard my message! I WAS ABLE TO FIX!

     

    Here is how:

    go to Display --> Screen Resolution

    Select "Show Desktop Only on 1"

    Click "Keep Changes" on screen that pops up

     

    Easy as that!!!!

    Hope that helps,

    Robby D

    Wednesday, April 28, 2010 9:21 PM
  • You rock Robby D!  Just what I was looking for!  <3
    Saturday, July 16, 2011 5:23 AM
  • I tried this fix on my computer.

    It did not work.

    It still show two monitors and my pointer still disappear.


    • Edited by b2rtch Monday, April 16, 2012 11:12 AM
    Monday, April 16, 2012 11:11 AM
  • Where Robby D says to select "Show Desktop Only on 1" you can "Remove Display" as well.

    Helped me with the problem that I only have one display, but windows was saying there were two. The other device was showing up as "Display device on: VGA". In device manager, the only driver listed was for my actual display of course. I was also not able to see the properties or configure the 'Display Device'.

    You may need to disable or delete the unwanted display from the display manager that came with your graphics card. Mine was In AMD Vision Engine Control Center ->Desktop Management->Creating and Arranging Displays. You should see both displays in the 'detect displays' section. Clicking on the little triangle should allow you to 'disable' the display.

    Thursday, June 7, 2012 5:37 AM
  • open up display's (right click desktop background and select screen resolution). Click on the #2 display (it has a 2 on it) until it has a blue border to ensure it is selected. Under "multiple Displays" drop down menu select "Remove this display". Click OK or Apply. You should now see only one Display at the top near "detect" and Identify" buttons.
    Tuesday, September 3, 2013 3:14 AM
  • Thanks :) worked like a charm !
    Wednesday, December 16, 2015 9:08 AM
  • Disregard my message! I WAS ABLE TO FIX!

     

    Here is how:

    go to Display --> Screen Resolution

    Select "Show Desktop Only on 1"

    Click "Keep Changes" on screen that pops up

     

    Easy as that!!!!

    Hope that helps,

    Robby D

    THANK YOU!!!!!
    Thursday, October 6, 2016 12:21 AM
  • Thank you Robby,
    it worked like a charm also in Windows 10

    Tuesday, February 14, 2017 10:00 AM
  • Solution is Simple:
    In Win7, Go to Device manager
    1. Right Click on Available Display Adapters and Select "Scan for hardware changes" 
    2. Right Click on Available Monitors and Select "Scan for hardware changes"

    Tuesday, May 30, 2017 4:28 PM