locked
Auto rebbot after automatic updates RRS feed

  • Question

  • Hi everyone,

    We have a problem with the auto update feature of our Windows Servers. We use WSUS and group policy for configuring automatic updates, and the relevant GPO which is applied on the OU for our servers has been configured as follows:

    3 - Auto download and notify for install.

    However, almost every time I log on to a WSUS managed server after Windows Updates have arrived to our WSUS server, I realize that the managed server has been restarted automatically while no user was logged on, and I see the well known balloon tip on the system tray, which says "Your computer was recently updated!".

    Do you have any ideas why this happens? There is no other software updating solution implemented in our infrastructure, and I have checked and rechecked the group policy settings which are applied on our servers for any relevant misconfiguration. This problem did not exist some time ago, but I don't know for sure when we saw it for first time. It happens with all of our Windows servers...

    Thank you in advance...

    Wednesday, February 19, 2014 3:43 PM

Answers

All replies

  • However, almost every time I log on to a WSUS managed server after Windows Updates have arrived to our WSUS server, I realize that the managed server has been restarted automatically while no user was logged on, and I see the well known balloon tip on the system tray, which says "Your computer was recently updated!".

    The answer is simple: when you configure Windows Update settings via group policy, the option that is given is restart the PC when all the users are logged off or no user is logged on. This is the only option that prevents Windows from automatically restarting after installation of updates. But, if no user is logged on, you can't prevent Windows from automatically restarting itself.


    Balaji Kundalam

    Wednesday, February 19, 2014 4:05 PM
  • Hello, The best to avoid that kind of problem would be to think about the GPO Settings on 3 - Auto download and notify for install by maybe put it on another level to have the install be planned during working hours (4th option) or to not automatic download (2nd option) Thanks. Brice.
    Wednesday, February 19, 2014 4:27 PM
  • We have the following settings and client doesn't reboot automatically

    Wednesday, February 19, 2014 4:51 PM
  • Interesting as if you do not configure the "no auto-restart with logged on user for scheduled automatic updates" option, you'll have this :

    And as far as your screenshot shows that you use the 3rd otpion with scheduled install every day at 3:00 this will affect automatic restart on clients.

    TiGrOu.

    Thursday, February 20, 2014 9:57 AM
  • What I don't understand is why the servers automatically restart since there should be no automatic installation.

    Before the scheduled install day and time settings there is a comment saying:

    "The following settings are only required and applicable if 4 is selected."

    We use the option 3.

    Moreover, there is a note in the "No auto-restart with logged on users for scheduled automatic updates installations" setting, saying"

    "Note: This policy applies only when Automatic Updates is configured to perform scheduled installations of updates."

    This setting has a clear target: To give you the option to forcefully restart a computer even when a user is logged on, or not.

    So we keep it not configured.

    Any more ideas?

    Thanks...

    Friday, February 21, 2014 9:02 AM
  • Any more ideas?

    What is the OS version?

    WS2012 has an "automatic maintenance" behaviour, which by default does not honour the "legacy" WUAgent settings.

    http://blogs.technet.com/b/wsus/archive/2013/10/08/enabling-a-more-predictable-windows-update-experience-for-windows-8-and-windows-server-2012-kb-2885694.aspx


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Marked as answer by Daniel JiSun Tuesday, March 4, 2014 6:11 AM
    Friday, February 21, 2014 9:10 AM