Can't enable integration features. help! RRS feed

  • General discussion

  • My Dell Studio with Windows 7 pro came loaded with Windows XP Mode. When I setup it asked me for a username and password which I created and then checked "save credentials". I successfully got into XP Mode loaded Avast and DVD 43 restarted the virtual machine and it took forever to boot back up. when it did I got a dialog box that said "cannot enable integration features" when I hit continue another dialog box came up that asked for username & password with XPM User as the username. I put in the username and password I created on setup which was denied and then I got into a black screen with no XP mode and Enable Integration Settings grayed out. All the other menus have no function. I tried disabling/enabling integration in the settings menu (the only one that works) I also went into logon credentials and deleted my profile and now I cant do anything. If I start XP Mode with integration enabled it takes forever to load up and I get the dialog box about unable to enable integration features which depending on the choice either leads to a black screen in XP Mode (continue) or the same process (retry) I'm at a loss. Help!

    OK After much trial & error I am back in. I powered down the VM and then started the VM backup which had the effect of a cold shutdown of Win XP. While powering up I selected Tools/Enable integration and then it asked me for the username and password and to save the credentials. I did and Voila! back in business. Went into settings and the logon credentials are saved. I did a restart and it did indeed log be back in without asking for a password. Dont know why these settings were not saved during startup but after 2 hours of trial & error they seem to be now.
    • Changed type Nicholas Li Friday, March 5, 2010 11:40 AM
    Tuesday, March 2, 2010 12:47 AM

All replies

  • Hi,


    Thank you for your post.


    I am glad to know it works. Your efforts are highly appreciated.

    In the future, if you experience any issues regarding our products or if you have some feedbacks, you are welcome to post a new thread in our forum. It is always our pleasure to be of assistance.


    Thanks again. Have a great day!

    Nicholas Li - MSFT
    Friday, March 5, 2010 11:37 AM
  • I think I may have more issues than the one mentioned (integration features).. not sure if my virtual machine is running.. however.. since the answer would help me on more than 1 level.. how did you power down the virtual machine?  any insights would be appreciated.
    Tuesday, July 20, 2010 10:01 PM
  • Hope my explanatio here helps


    ahh here I will cut and paste it for those others


    OK After getting this error I also was stumped, I have a Win 7 Ultimate 64bit Core 2 Quad system with 8GB RAM. Without warning my Virtual XP was like a turtle loading and then gave the same error.

    This morning I tried again and same error, and nothing I did helped. After pressing continue I get the same box that looks like XP mode but black and a blinking cursor like DOS mode. I also could not increase the size of the box and even Ctrl+Alt+Del did nothing to kill the VXP..

    I did have at the top of the VXP ineterface the 'Action, USB, Tools, etc.. So when ever I tried to kill it the VPC would just go into hibernation and then when I tried to reboot it took ages and did the same. Here is how I fixed it finally.

    I went to Tools, Settings and 5th from the bottom on the left side was Intergration Features. When I clicked on these Integration Features all the boxes were checked with the exception of the most important "Enable at startup" So I checked it clicked OK. Now I had the issiue of not being able to STOP V XP (as I said it would only hibernate) I went to Win7 and typed Ctrl+Alt+Del and selected start task manager, then the 2nd tab Processes, and clicked on the column Image name so they would be alphabetical (also you must tick the box on bottom left first in some instances "Show processes from all users.

    Anyway I clicked to end vpc.exe and suddenly the box that was only black in Virtual XP went white, then I went one tab over and selected the Windows XP mode and clicked end process. Without rebooting my Win 7, I booted Virtual XP again and it came up first time and the Integration feature was enabled.

    I hope this helps someone

    Good luck

    Saturday, July 31, 2010 9:33 AM
  • This is very helpful. thanks
    Saturday, March 19, 2011 11:32 PM
  • I did the delete and restart sequences as you stated, and it worked!! Thank you so much for posting this.  Maybe MS will find a way to smooth it out for those who are stuck.
    Sunday, October 16, 2011 12:33 PM
  • I had to futz a little more, but after rebooting it worked. In my case "enable integration" was already properly checked.   From doing this it would seem that one of these processes is getting "hung up" in shutting down when you exit so it can't properly restart again.  So forcing the virtual pc -- vpc.exe -- to close by ending it under Processes in Task Manager and then forcing Windows XP mode to close in applications does the trick.  If Microsoft is looking to fix this -- I would think it shouldn't be that hard.  I gotta hand it to you though Bob -- you've saved all of us a lot of time but getting where you got!  Thank you!
    Monday, October 17, 2011 8:47 PM
  • I had to create a new Administrator user account and login as that user in order to get the integration tool enabled. Even though I had an administrator account myself, it would not allow me to enable. I created an administrator account Vista2007 with the same password and likewise for my Windows7 VPC and was successful....
    Monday, March 12, 2012 2:46 PM
  • Excellent!  shuttingdown vpc.exe did the trick for me too!  Thank you

    Wednesday, April 4, 2012 3:39 PM
  • Thank you so much for this. I thought I was going to have to delete the machine image and start from a blank one
    Wednesday, May 16, 2012 1:08 PM
  • That did the trick! Thanks.

    Thursday, June 28, 2012 5:02 PM
  • This fixed my problem, THANKS!
    Tuesday, January 29, 2013 3:39 PM
  • Perfect! Much you have helped me!
    Tuesday, August 20, 2013 6:06 PM