none
MRO 3.3.2 hanging/freezing on Mac OS x 10.12 RRS feed

  • Question

  • 

    Hi,

    R MRO 3.3.2 (Mac OS x 10.12) keeps hanging/freezing when I try to use the console or Rstudio or the R-GUI .   See below, right after "Type 'q()' to quit R." is hanging, with a blinking cursor and never reaching the console shell.

    R version 3.3.2 (2016-10-31) -- "Sincere Pumpkin Patch"
    Copyright (C) 2016 The R Foundation for Statistical Computing
    Platform: x86_64-apple-darwin15.6.0 (64-bit)

    R is free software and comes with ABSOLUTELY NO WARRANTY.
    You are welcome to redistribute it under certain conditions.
    Type 'license()' or 'licence()' for distribution details.

      Natural language support but running in an English locale

    R is a collaborative project with many contributors.
    Type 'contributors()' for more information and
    'citation()' on how to cite R or R packages in publications.

    Type 'demo()' for some demos, 'help()' for on-line help, or
    'help.start()' for an HTML browser interface to help.
    Type 'q()' to quit R.

    *** HERE IS HANGING ****  I have to do kill the process with ctrl+z

    I already remove all my R installations by following CRAN and Microsoft Uninstallation steps.  Any idea what's going on? Also deleted all my user files related to R from the user trying to run R e.g. .Rprofile, etc... still the same behavior, already restarted my Mac and reinstalled everything.  One thing that I noticed is that when I run the installer Microsoft...3.3.2.pkg the "Action" always says "Upgrade", is this correct. It's confusing since I've uninstalled everything I'd expect to see "Installation" instead of upgrade action, right?

    Any hint?


    Saturday, February 11, 2017 10:20 PM

All replies

  • Thanks for raising this. We are investigating this. We are not able to repro this and here is something that you can try.

    Launching MRO, either from the console or from the GUI on Mac starts XQuartz. I believe R waits for XQuartz to launch before completing startup. Try removing and reinstalling the latest available version of XQuartz.


    Also, try completely removing the R.Framework folder in /Library/Frameworks and reinstalling MRO.

     

    If that doesn’t work, please let me know if XQuartz is starting successfully when R is launched. You should see it in the dock and as a process.

    Bharath

    Tuesday, February 14, 2017 4:15 PM
  • I'm having a similar issue where XQuartz keeps popping up when using Microsoft R GUI or RStudio pointed to Microsoft R on OS X 10.13.3 with Microsoft R 3.4.3. I have the latest version of XQuartz installed, so I'm not sure what could be causing this.
    Thursday, March 29, 2018 10:26 PM