locked
windows 7 graphics card RRS feed

  • Question

  • Please delete other threads Ok i have a NIVIDA card i got the xp driver in xp but in 7 it says standard VGA graphics adapter so i got the xp driver and ran it in combatibillity mode for xp but i get a blue screen after i refresh so i tried the vista driver same thing it said in windows update there is an driver uppdate for nvidia cards but i diddnt get the update is there any way i can download the driver for 7 manually? or can someone give me a driver for NVIDIA geforce4 Mx 420 with WDDM

    Thanks! 
    Sunday, February 1, 2009 9:41 AM

Answers

  • Hello,

     

    I'd suggest installing the device drivers in the Compatibility Wizard. Remove that hardware device in Device Manager, right-click on the driver executable/installer file and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver. In addition, you can use the Windows XP driver for testing.

     

    If the problem still persists, please understand that Windows 7 is a new operating system (only the beta version) and whole driverstore has been reprogrammed; some old driver is not compatible with new OS. I suggest that you should wait for another period of time till the retail version is released and push the vendor company to upgrade their device driver. Thanks for your time and understanding!

     

    Good Luck!

    • Marked as answer by Andy Song Friday, February 20, 2009 7:19 AM
    Tuesday, February 3, 2009 9:11 AM

All replies

  • As far as i am aware, there is no WDDM Driver for the MX 420, the Forceware 93.71 appear to be the most up to date drivers released for XP. So it might be worth trying those.Also there appears to have never been a Vista driver released for this card.
    Sunday, February 1, 2009 1:49 PM
  • Andrew, no offense, but you're getting on my nerves. I've told you three times in your original thread to get the VISTA drivers and install them under VISTA compatibility mode. Stop double posting if you can't read!

    Frop said:

    Go to NVIDIA and download the latest Vista 32-bits/64-bits drivers for your graphics card. Execute the installer under Vista compatibility and as an administrator. Right mouse click on the executable -> Properties -> Compatibility (tab) -> Check both 'Run this program in compatibility mode for: Windows Vista' and 'Run this program as an administrator'.

    • Proposed as answer by Frop Sunday, February 1, 2009 2:15 PM
    Sunday, February 1, 2009 2:15 PM
  • Hello,

     

    I'd suggest installing the device drivers in the Compatibility Wizard. Remove that hardware device in Device Manager, right-click on the driver executable/installer file and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver. In addition, you can use the Windows XP driver for testing.

     

    If the problem still persists, please understand that Windows 7 is a new operating system (only the beta version) and whole driverstore has been reprogrammed; some old driver is not compatible with new OS. I suggest that you should wait for another period of time till the retail version is released and push the vendor company to upgrade their device driver. Thanks for your time and understanding!

     

    Good Luck!

    • Marked as answer by Andy Song Friday, February 20, 2009 7:19 AM
    Tuesday, February 3, 2009 9:11 AM