none
Clear, Reset or Reinitialize Offline Files Cache in Windows 8

    General discussion

  • I have scoured for a complete fix for this issue since I had 3 laptops using the Offline Files to keep all my documents, pictures, music, etc. in sync between them and a server that moved on to a more peaceful existence without bits and bytes.

    There is a Mr Fixit for XP, and Windows 7 but not Windows 8. A Mr FixIt for windows 8 would be appreciated, but even better would be a button or hotkey to allow the Offline Files cache to be completely wiped, in case anyone is listening. Note that the registry key location for Offline Files in Windows 7 & 8 is completely different even though the same FormatDatabase DWORD is used. 

    I found another post that told to do the following to reset the cache:

    To reset Offline file in Windows 8, We have to reinitialize the offline files cache all together:

    1.        Open up registry editor (WARNING: Only for Advanced Users)
    2.        Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc
    3.        Add a new key (folder) called Parameters
    4.        Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters, add a new DWORD called FormatDatabase and set its value to 1
    5. Save, Close, Reboot (added by me)

    However, this did not fix it for me. After some tinkering I learned that the Offline Files registry change did not format the cache unless the Offline Files were turned on first. So be sure you turn on the offline files before setting the above registry settting and rebooting your machine.

    One last thing, on my machine at least, much of the space was not released until I

    * changed the space allocation for Offline Files to 0 using "Manage Offline Files" (not sure if this is required)

    * rebooted 

    * emptied the Recycle bin.

    Hope this helps!

    Friday, April 11, 2014 6:42 PM

All replies

  • Great!!
    Friday, April 18, 2014 1:49 AM
  • Doesn't work for for me on 8.1 pro. 

    A couple of notes:

    1. in 8.1 pro (don't know about 8 or home), there is already a folder named parameters.

    2. Adding FormatDatabase with value 1 to the folder and rebooting has only a half effect. 

    3. The half effect is that the "phantom" servers no longer show up in the network browser, but the files are still stored in windows\csc. You can still manually type "\\<servername> and see the offline files still there.

    4. It's not possible to set the limit to 0. The limit on temporary files can be set to 0, but the maxmimum space for offline files cannot be set lower than the amount of offline files you already have.

    I REALLY wish this had worked. I really need to clean this up and get my 160GB of space back, but unfortunately it's not working. 

    Any other ideas anyone? 

    EDIT: OK, in my case, I had to do this:

    1. Boot into SAFE MODE. 

    2. Navigate to C:\windows\csc

    3. Painstakingly change the owner and security on all the files in the tree of the missing server. C:\windows\csc\v2.0.6\cache\<\\servername>

    4. Delete everything in that folder and down. 

    5. Then set the registry key above and reboot.

    This did the trick. 

    NOTE: I tried doing this in normal not safe mode and I was able ot change some permissions but not all, so safe mode was necessary. I did not change any permissions in the file tree of servers that still existed. They reset on their own after the key.

    My guess is that it had screwy permissions in the folders for the missing server and couldn't complete the reset. 


    Sunday, June 22, 2014 12:01 AM
  • Im using Windows 8.1 Pro x64 as well and had same issue, and the solution suggested by Gregger44, unfortunately didn’t work for me as well. Then I tried to solution recommended by Brian Richards and it worked very well. For reboot in safety mode I would like to added, that you can use the command “msconfig.exe” to set the reboot to safety mode – and remember it stay on until you again run the command and set the boot to “normal”.


    Jesper Kenborg


    Saturday, July 5, 2014 4:57 PM
  • Worked great for me, but here's a shortcut to avoid booting into Safe Mode and changing ownership settings, just use the built-in robocopy command to wipe out the directory.

    1. First create a temp directory that's empty. For this example, just put it at the root level of the C drive (we'll delete it later, so that's fine). Let's call it "wipe_csc" (the name only matters to match the name used for step #3)

    2. Open an administrative command prompt.

    3. Type: robocopy c:\wipe_csc c:\windows\csc\v2.0.6\cache /mir

    That's it. Folder cleared. Unlike Windows Explorer, robocopy will write over the permission settings.


    Colin

    Friday, January 9, 2015 2:46 AM
  • haha...nice idea !

    Worked great for me - i also had the Problem with Win 8.1
    Thursday, January 21, 2016 3:32 PM