none
wsus 2012R2 not sycing

    Question

  • Hello

    2012R2 isnt syncing and giving me an error about cookies

    SoapException: Fault occurred
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Microsoft.UpdateServices.ServerSyncWebServices.ServerSync.ServerSyncProxy.GetUpdateData(Cookie cookie, UpdateIdentity[] updateIds)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.WebserviceGetUpdateData(UpdateIdentity[] updateIds, List`1 allMetadata, List`1 allFileUrls, List`1& updatesWithSecureFileData, Boolean isForConfig)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.GetUpdateDataInChunksAndImport(List`1 neededUpdates, List`1 allMetadata, List`1 allFileUrls, Boolean isConfigData)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ExecuteSyncProtocol(Boolean allowRedirect)

    

    oddly the two syncs on the 4th that succeeded only worked if i turned off the "updates" classification.

    If i turn this off the sync works, turn it back on and sync again and it works fine. But then on the 3rd time it fails

    Wednesday, December 5, 2018 9:09 AM

Answers

  • Hello,
     
    Microsoft has fixed it and the sync works now. However, it is not the first time that one product causes the synchronizing failure. In my memory, it is office 2016 last time.
     
    Glad to hear that your issues are all solved.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by ryan190 Friday, December 7, 2018 11:31 AM
    Friday, December 7, 2018 8:53 AM

All replies

  • Hello,
     

    1> On your WSUS Server, launch the IIS Manager.

    2> Open Application Pools.

    3> Right click 'WsusPool' and select 'Advanced Settings...'

    4> Increase the WsusPool Private Memory limit x4 times, or set to 0 (unlimited).

    5> Change 'Queue Length' from the default 1,000 to 25,000.
    6> Then run server cleanup wizard and wait till it is done.
     
    Then check if it works.
     
    Hope my answer could help you and look forward to your feedback.
     
    Best Regards,
    Ray


    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 5, 2018 10:17 AM
  • Hello, 
     
    If the issue persists, it may be caused by one of the selected product. Try to un-select one product each time and then check if synchronization could work.
      
    Hope my answer could help you and look forward to your feedback.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 5, 2018 10:25 AM
  • Noticed the same behavior on 2 seperate environments since 2 days, nothing changed in either environment (one is my personal test environment). Saw a topic on Reddit with other people reporting the same issue. Some people reported that unchecking Windows 10 product 'solves' it, but that is offcourse not a solution :)

    I suspect something is wrong on Microsoft side. Unfortunately I am not in a position currently that I can open a support ticket to Microsoft for it.

    Wednesday, December 5, 2018 11:09 AM
  • Hello,
     
    Thanks for your feedback. Based on your report, and my experience, it is very likely that the problem is on the Microsoft side. However, this is not the first time that one product or classification caused the synchronizing failure. If it is on the Microsoft side, usually it would be solved soon.
     
    So just unselect windows 10 and check if it works and wait for the fix.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 5, 2018 11:34 AM
  • Thanks Ray i have changed the settings you spoke about but i still cant sync.

    I have turned off "updates" but the sync still fails.

    Turning off everything windows 10 related also fails the sync

    Is there a way you can check with MS to see if they know about the issue? i dont have a way to open a ticket with them.

    Wednesday, December 5, 2018 12:52 PM
  • Hello All.

    It's the first time that I write on this forum.

    I have created a WSUS infrastructure (1 upstream and 4 downstream). I noticed that since the 3rd I have had syncining errors with upstream since December 3rd.

    I made the IIS changes (memory and other settings). Ditto Error.
    I have recreated the master server right now and I also have errors from the first synchronization. 

    I went by activating step by step. At the classification level, by default, the following are activated: Critical Updates / Security Updates / Service Packs.
    The selected products: Windows 7 & Windows 10. Syncho OK.

    If I add the Updates class = synchro = KO
    Rewind by unchecking the'Updates' classification. Synchro = OK

    Addition of Office 2013 products. Synchro = KO

    The problem is more on the Microsoft side. Pending a correction from them.

    Wednesday, December 5, 2018 3:10 PM
  • Thanks for the comment dcuoq

    Its good to know its not just me!

    Im going to run that same settings you did to see if it office 2013

    EDIT

    Yep that does it, turning off office 2013 and updates

    • Edited by ryan190 Wednesday, December 5, 2018 4:05 PM
    Wednesday, December 5, 2018 3:46 PM
  • Having the exact same issue, I posted on this before I noticed your post, but I linked to your post in mine.

    Hopefully MS will get this resolved ASAP, or some other solution will be presented.

    Wednesday, December 5, 2018 3:58 PM
  • so i just saw =)

    dcuoq is right, turning off office 2013 AND updates does fix the issue for now

    Wednesday, December 5, 2018 4:05 PM
  • I'll just add my obligatory "I'm getting this too" message.  I too can get synchronizations working if I de-select Office 2013 under Products and Updates under Classifications.  My last successful synchronization  was Sunday December 3 at 08:32 MST.  Luckily, this is a new server which I just built to replace our current production WSUS server, so I haven't actually pointed any clients at it as of yet.
    Wednesday, December 5, 2018 7:24 PM
  • Same issue here on a fresh Server 2019 WSUS deployment. App pool's memory limit & queue length were already bumped up, as is tradition. Sounds like Microsoft's end is messed up as the error states.

    If I deselect all of my products, an "empty" sync works. I haven't had the time to play trial & error to see if I can find a specific product causing this issue.

    My error:

    SoapException: Fault occurred
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Microsoft.UpdateServices.ServerSyncWebServices.ServerSync.ServerSyncProxy.GetUpdateData(Cookie cookie, UpdateIdentity[] updateIds)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.WebserviceGetUpdateData(UpdateIdentity[] updateIds, List`1 allMetadata, List`1 allFileUrls, List`1& updatesWithSecureFileData, Boolean isForConfig)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.GetUpdateDataInChunksAndImport(List`1 neededUpdates, List`1 allMetadata, List`1 allFileUrls, Boolean isConfigData)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.GetAndSaveUpdateMetadata(List`1 updates)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ExecuteSyncProtocol(Boolean allowRe

    Wednesday, December 5, 2018 7:26 PM
  • Same error here. 

    New wsus setup, Windows 2016. 

    Finished all settings yesterday. I did a few successful syncs as well.

    Everything was fine, now I cant sync (error SoapException: Fault occurred).

    Looks like a MS issue.

    Wednesday, December 5, 2018 7:58 PM
  • Yes Same since December 3rd at 12:00 PM.

    Looks like you can enable "Updates" class if you do not check Office 2013, Windows 10, and Windows Server 2019.

    Microsoft needs to fix this because what is the point to not update these Products and OS'es.

    Wednesday, December 5, 2018 8:10 PM
  • Can confirm: Fresh 2016 WSUS install with ConfigMgr 1806 gives Soap exceptions when syncing a combination of Windows 10 and the updates class.. Waiting for an upstream fix, over at Microsoft.
    Wednesday, December 5, 2018 10:02 PM
  • I can confirm that one of our three WSUS servers encountered this issue beginning Tuesday when this week's patches were released. With "Updates" enabled, I unchecked "Office 2013" and "Windows 10" to get it to synchronize again. I tested and checking either one caused sync to fail.  We do not sync 2019 products yet.

    Thursday, December 6, 2018 12:19 AM
  • I have exactly the same issue on Windows Server 2016 V1607.

    I did the 2 changes in IIS Manager and I´m now able to select the neccessary classify "updates, upgrades and important uprades" without a sync problem,

    but unfortunately, I have to uncheck the products Office 2013 and Windows 10 to get a successful sync.

    My last succesful syncronication was Sunday December 3 at 08:32 MST, too.

    My hope is that MS is going to fix this asap

    Thursday, December 6, 2018 9:25 AM
  • One of my customers filed a premier support ticket and got a response that Microsoft is aware of the problem and working on it.
    Thursday, December 6, 2018 10:48 AM
  • After updating the MUrl to https://update.microsoft.com/v6 the synchronization seems to be going again. Make sure you save the old value somewhere before updating:

    USE SUSDB;

    SELECT
    MUUrl FROM dbo.tbConfigurationB;

    UPDATE dbo.tbConfigurationB
    SET MUUrl = 'https://update.microsoft.com/v6';






    Thursday, December 6, 2018 2:06 PM
  • Thanks @alexsemi, I just tested that in my test environment and it seems to work. 

    I am a bit reluctant to edit the db of a production environment though, we'll wait and see what premier support says.
    Thursday, December 6, 2018 2:42 PM
  • that is exactly what I was wondering... please keep us posted if there is an "official" solution or patch :)
    Thursday, December 6, 2018 2:45 PM
  • Just tried again and mine resolved itself. Looks like Microsoft is starting to fix their end.
    Thursday, December 6, 2018 7:14 PM
  • I too just initiated an manual sync and it was finally successful.  Here's hoping they've got this resolved permanently.
    Thursday, December 6, 2018 7:34 PM
  • Yes, same result here, finally working, 33 new updates downloaded!
    Thursday, December 6, 2018 8:19 PM
  • Same here, it's looking good on my end.

    Thanks to all you guys who reported the issue here and elsewhere, glad we're all back on track.

    Thursday, December 6, 2018 11:40 PM
  • I can confirm as well that it started working again at my customer, around 20:30 CET last night.
    Friday, December 7, 2018 8:07 AM
  • Hello,
     
    Microsoft has fixed it and the sync works now. However, it is not the first time that one product causes the synchronizing failure. In my memory, it is office 2016 last time.
     
    Glad to hear that your issues are all solved.
     
    Best Regards,
    Ray

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by ryan190 Friday, December 7, 2018 11:31 AM
    Friday, December 7, 2018 8:53 AM
  • yep its working for me aswell!
    Friday, December 7, 2018 11:32 AM