none
windows 2012 server manager refresh failed. RRS feed

  • Question

  • system log:

    the value for smserverid must be a vaild ip address,FQDN,or NetBIOS name.

    thx.

    Monday, June 4, 2012 2:06 PM

All replies

  • Can you share the details from SM+ UI when refresh is triggered? Also, can you describe the environment - how many servers being managed and the roles?

    Monday, June 4, 2012 11:39 PM
  • click add roles and features,show dialog "server manager is collecting inventory data,the wizard will be available after data collection finishes."

    manual refresh ,show this.

    detail:

    single 2012 server rc,build 8400.

    roles:iis

    thx.


    Tuesday, June 5, 2012 4:00 AM
  • Hello trueideal,

    Thx for your update. Can you please provide following details too?

    • Machine name on which the issue is happening
    • Is the machine in a domain or a workgroup?
    • "Properties" tile details from "Local Server" node in Server manager console.
    • "Servers" tile details from "All Servers" in Server manager console.
    • Out of following powershell command

          invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertasks -arguments @{SMServerID='<name used to add this machine to Server manager>'} -cimsession <machine name>

    Please note that -cimSession is not needed if this is happening on local host.

    Tuesday, June 5, 2012 11:09 PM
  • hi.Manish Duggal,thx

    1.machine name, idio-002.

    2.my machine in workgroup

    3.

    4.all server ,"Onlie -Data retrieval failures occurred'

    5.I don't understand powershell command, run this ,system show  error ,i don't know what to  input the Methodname.


    Wednesday, June 6, 2012 1:33 PM
  • Hello trueideal,

    Thx much for the information.

    The powershell command should be

     invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertasks -methodname GetServerInventory -arguments @{SMServerID='<name used to add this machine to Server manager>'} -cimsession <machine name>

    Wednesday, June 6, 2012 8:46 PM
  • hello,

    PS C:\Users\Administrator> invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertas
    ks -methodname GetServerInventory -arguments @{SMServerID='<idio-002>'} -cimsession idio-002
    invoke-cimmethod : The value for SMServerID must be a valid IP address, FQDN, or NetBios name.
    At line:1 char:1
    + invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_ser ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (root\microsoft\...vermanagertasks:String) [Invoke-CimMethod], CimExcep
       tion
        + FullyQualifiedErrorId : MI RESULT 4,Microsoft.Management.Infrastructure.CimCmdlets.InvokeCimMethodCommand
        + PSComputerName        : idio-002

    Wednesday, June 6, 2012 9:24 PM
  • hello trueideal.

    The command should be

    invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertasks -methodname GetServerInventory -arguments @{SMServerID='idio-002'}

    Can you please remove the "<" and ">" and send the result of command?

    Also note that -cimSession is not required if the machine is same as your local server.

    Wednesday, June 6, 2012 10:16 PM
  • hello Manish Duggal

    thx.

    PS C:\Users\Administrator> invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertas
    ks -methodname GetServerInventory -arguments @{SMServerID='idio-002'}
    WARNING: ComputerDescription reported a generic failure, Error: -2147024894, Extended Error: 234
    WARNING: Wer reported a generic failure, Error: 2, Extended Error: 0

    ParameterName                                      ItemType ItemValue                     PSComputerName
    -------------                                      -------- ---------                     --------------
    NetworkAdapters                               InstanceArray {MSFT_ServerNetworkAdapter...
    EventLogs                                     InstanceArray {MSFT_ServerEventLog, MSFT...

    Thursday, June 7, 2012 6:59 AM
  • Hi Manish Duggal,

    I got the same and I did so:

    PS C:\Users\T>  invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_servermanagertasks -methodname GetServerInventory -arguments @{SMServerID='WeVHost02'} -cimsession WeVHost02

    invoke-cimmethod : Der WS-Verwaltungsdienst kann die Anforderung nicht verarbeiten. Die Klasse"msft_servermanagertasks" ist im Namespace "root/microsoft/windows/servermanager" nicht vorhanden.
    In Zeile:1 Zeichen:2
    +  invoke-cimmethod -namespace root\microsoft\windows\servermanager -class msft_se ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (root\microsoft\...vermanagertasks:String) [Invoke-CimMethod], CimException
        + FullyQualifiedErrorId : HRESULT 0x80338000,Microsoft.Management.Infrastructure.CimCmdlets.InvokeCimMethodCommand
        + PSComputerName        : WeVHost02

    Important to say, that the Root cause described here:

    http://social.technet.microsoft.com/Forums/nl-NL/winserverhyperv/thread/6bd6835a-5a7a-428a-aad4-883ec356c742

    Hyper-V installation failed permanently and the computer reverted changes at next reboot.

    I did the things described in thread(Hyper-V seems to be installed now):

    sc config winmgmt start= disabled
    net stop winmgmt /y
    %systemdrive%
    cd %windir%\system32\wbem
    for /f %s in ('dir /b *.dll') do regsvr32 /s %s 
    regsvr32 %windir%\system32\tscfgwmi.dll 
    wmiprvse /regserver 
    Winmgmt /regserver 
    net start winmgmt

    for /f %s in ('dir /b *.mof *.mfl') do mofcomp %s

    Maybe any *mof's from Servermanager are missing?

    Thomas

    Sunday, March 10, 2013 2:05 PM
  • Hello,

    I assume that I found the solution.

    Action:

    1. from current directory (C:\Windows\System32) I did: dir /a /S *.mof then all *.mof's in all subdirs were listet.

    All are some type like "FFA7CB08C2CC2CB2D3973F6214D0CCAF.mof"

    2. cd C:\Windows\System32\wbem\AutoRecover

    3. for /f %s in ('dir /b *.mof *.mfl') do mofcomp %s

    4. goto Servermanager, do Refresh - Ok.

    Like ever in this situation - when the TSC Contract expired - I am so happy.
    And I hope I can help any with this impact.

    Fortunately the server wasn't in live environment yet.

    Thomas

    Sunday, March 10, 2013 2:51 PM
  • This solution worked for me.  Months of this problem.

    My error was slightly different.  It said Invalid Class

    Thanks so much.

    • Proposed as answer by IM-consult Tuesday, October 8, 2013 10:06 AM
    • Unproposed as answer by IM-consult Tuesday, October 8, 2013 10:06 AM
    Monday, April 8, 2013 11:41 PM
  • Thomas,

    great ! Just found your solution proposal. Works like a charm :-)

    Thanks for sharing this.

    Martin

    Tuesday, October 8, 2013 10:07 AM
  • This also fixed my problem.
    Friday, November 15, 2013 3:51 PM
  • Thanks! It worked for me too!

    Robert W. Kirchhof

    • Proposed as answer by RKirchhof Friday, August 29, 2014 5:55 PM
    • Unproposed as answer by RKirchhof Friday, August 29, 2014 5:55 PM
    Sunday, December 15, 2013 8:07 PM
  • Thanks Thomas.

    This solutions worked for me.  

    Monday, May 26, 2014 6:06 PM
  • my issue resolved by using below command.

    http://social.technet.microsoft.com/wiki/contents/articles/13444.windows-server-2012-server-manager-troubleshooting-guide-part-ii-troubleshoot-manageability-status-errors-in-server-manager.aspx

    C:\Windows\System32\wbem

    mofcomp mgmtprovider.mof


    My self Kaliyan from India I have 10 Yeas of extensive experience in IT Infrastructure implementation

    Monday, December 8, 2014 3:48 AM
  • This worked! Thanks!
    Sunday, July 12, 2015 12:05 PM
  • Works like a charm !
    Friday, January 29, 2016 12:10 PM
  • Brilliant - not only has this fixed a persistent issue with an SCCM hardware inventory cycle not reporting back to SCCM/bizarre boot time reporting, it's also fixed a long standing 2008 R2 server that absolutely refused to install SP1.

    Many thanks. I'm delighted.

    Wednesday, April 20, 2016 1:46 AM
  • Thomas,

    I believe I have this same issue on a server in a live environment.  If I run these commands will it cause any downtime to the server?

    Thanks,

    Tim

    Tuesday, May 17, 2016 2:35 PM
  • No downtime.
    Tuesday, May 17, 2016 8:03 PM
  • Amazing.  I've been looking for a solution to this for a while now and this finally worked.  Thanks.
    Wednesday, May 18, 2016 2:00 AM
  • Works like a charm.

    No downtime and no reboot required. Just ran that commandline and Server Manager showed up all again instantly.

    Thanks!


    Friday, July 8, 2016 10:40 AM
  • Be aware that blindly running MOFCOMP on the MOF files under Windows\System32\WBEM might break application functionality as there are UNINSTALL MOF files in the same folder. So what you'll end up doing is registering classes within WMI then removing those classes.

    As an example, On Server 2012 R2 Datacenter - mgmtprovideruninstall.mof


    -Edit Didn't see the path was actually Windows\System32\Wbem\AutoRecover
    • Edited by MaxFLipz Sunday, April 23, 2017 9:54 PM
    Sunday, April 23, 2017 9:26 PM
  • amigo tengo el mismo problema en un servidor  cual es la solución  por favor su ayuda 

    configuration refresh failed with the following error:the value for SMServerID must be a valid  IP addres, FQDN ,or Netbios name

    Tuesday, August 29, 2017 6:44 PM
  • THANKS. This solution worked for me.
    Tuesday, November 12, 2019 7:37 AM