none
[Solved] - DPM 2019 - Exchange DB Online Recovery Point Creation Failed RRS feed

  • Question

  • Hi all,

    i'm implementing a backup policy with DPM 2019 on dedicated NAS + Azure Online for our exchange 2016 Server.

    I've created a Protection group that backup the 4 DB we have all configured for "Full Backup", the short term protection on the NAS is configured like the following

    and the following configuration is online:

    But I receive the following message for the DBs:

    "Recovery Point Creation Failed"

    Does anybody have any suggestion?

    Thanks


    • Edited by Marf1 Thursday, July 4, 2019 2:04 PM
    Wednesday, June 26, 2019 8:18 AM

Answers

All replies

  • Hello,

    What is the exact error message and error ID that you are receiving? Go to the Monitoring pane and check the errors there.

    Can you give us more details about your DPM 2019 and Exchange 2016 environment?

    • Operating system version
    • Physical / Virtual
    • Cluster / Standalone

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, June 26, 2019 8:29 AM
  • Hello,

    Thanks for the reply.

    from monitoring pane i don't see any error, just Informational alerts for each database:

    "Online recovery point creation jobs for Exchange Mailbox Database dbxx on exchange.domain.local have failed 1 times (ID 3188)

    DPM Skipped cloud backup for Exchange Mailbox Database dbxx on exchange.domain.local because the latest disk backup is already backed up to cloud (ID 33344)"

    DPM and Exchange 2016 Standard, Both installed on Windows Server 2016 Std, DPM is on physical Machine and Exchange is on a Hyper-V Cluster enviroment. no cluster for Exchange, just Hybrid with O365 where we just have online archiving where we archive mail older of 2 years.

    Regards

    Daniele

    Friday, June 28, 2019 9:09 AM
  • Thanks for the information!

    Have you first of all made sure that you have followed the official documentation and checked the prerequisites and limitations?

    Back up Exchange with DPM

    Prerequisites and limitations

    As for the error 3188, it can be caused by many different things.

    You can look at the cbengine*.errlog files in the C:\Program Files\Microsoft Azure Recovery Services Agent\Temp folder and look for the real error.  


    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, July 1, 2019 8:38 AM
  • Hello,

    thanks for the suggestion. 

    i've found that i forgot to copy the ese.dll and eseutil.exe to the DPM setup path. additionally i moved the exchange server to dedicated PG. i'll check in next days how it will work

    on the CBenginexx.errlog i found the following:

    18 metadatawriteriterator.cpp(225) [000000007E3390A0] 5FB731C3-E8EA-4A9B-81F8-5DBE8982FF34 NORMAL Unable to get path from frn for file: [\\?\Volume{e508cd92-f509-422d-abe9-3e6a526aaad5}\16b91251-a47a-4c9b-a19c-10d5e6f072c2\Incremental\ff36d4bb-ae9c-4771-9cdb-c46c740b1816\F-Vol\Exchange\Database\db01\]

    i will check if after modification it will work



    Tuesday, July 2, 2019 12:16 PM
  • Yes the ese.dll and eseutil.exe are essential, let us know how everything turns out, you "might" have to re-create the protection group (delete -> create new).


    Blog: https://thesystemcenterblog.com LinkedIn:

    • Marked as answer by Marf1 Thursday, July 4, 2019 2:04 PM
    Tuesday, July 2, 2019 11:33 PM
  • Hi Leon,

    thanks this seems that has solved the issue.

    i already moved the exchange to dedicated PG when i copied the Ese and Eseutil components.

    Regards


    Daniele

    Thursday, July 4, 2019 2:04 PM
  • Thist is great to hear Daniele! I’m happy to hear that it worked out for you!

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, July 4, 2019 2:14 PM