none
how to close the PCA in Windows Server 2012?

    Question

  • I tried the Group Policy enable close PCA, the services(but no PCA service is seen), anyone could help??

    the server is with 64 bit SRV2012 R2

    it is really annoying with applicaiton imcompatitity all the time.

    Tuesday, October 13, 2015 9:00 AM

Answers

  • Hi Amy,

    Please also check

    Please also check registry value: HKLM_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppCompat!DisablePCA. You could try to make sure the value is 1.

    Note: Please backup the registry before you change in case you need to change back.Normally, the changes will disable the PCA. However, in your case, I suggest you check whether the new group policy apply to your computer. 

    Click Start, type rsop.msc and press Enter  
    Please check Computer Configuration -> Administrative Templates -> Windows Components -> Application Compatibility. Does it exist?

    Your server has joined the domain, right? And sometimes the local policy could have been overriden by the domain policy. Please also do a check.

    Here is the article about GPresult

    https://technet.microsoft.com/en-us/magazine/ff812646.aspx

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 15, 2015 9:41 AM
    Moderator

All replies

  • Hi Amy,

    Thanks for your post.

    Do your want to colse PCA on your server 2012?

    PCA monitors programs for known compatibility issues and can be very beneficial for end users. In fact, it is not recommend the average home user disable PCA as it might cause conflicts and system instability.

    And if you want to close the service, you may try to the following steps.

    a)Enter gpedit.msc into the start menu and hit Enter.

    b)Now navigate to User Configuration\Administrative Templates\Windows Components\Application Compatibility. Then on the left side under Setting double click on Turn off Compatibility Assistant

    c)Now click on Enabled then click on Apply and OK then close out of Local Group Policy Editor.

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 14, 2015 2:57 AM
    Moderator
  • Hi, Mary,

    I tried the GP policy method and turn off the Compatibility Assistant in both User Configuration and Computer Configuration. But I was trying to run Symantec Endpoint Protection 12.16, the PCA will still come out to report a "applicaiton compitiblity problem", make me unable to run SEP.

    which means the PCA is still not disabled on the windows server 2008 R2.

    Do you have other workaround?

    Thursday, October 15, 2015 9:06 AM
  • Hi Amy,

    Please also check

    Please also check registry value: HKLM_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppCompat!DisablePCA. You could try to make sure the value is 1.

    Note: Please backup the registry before you change in case you need to change back.Normally, the changes will disable the PCA. However, in your case, I suggest you check whether the new group policy apply to your computer. 

    Click Start, type rsop.msc and press Enter  
    Please check Computer Configuration -> Administrative Templates -> Windows Components -> Application Compatibility. Does it exist?

    Your server has joined the domain, right? And sometimes the local policy could have been overriden by the domain policy. Please also do a check.

    Here is the article about GPresult

    https://technet.microsoft.com/en-us/magazine/ff812646.aspx

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 15, 2015 9:41 AM
    Moderator