none
Task Scheduler Service Stopping

    Question

  • Hello techies,

    Thanks in advance..

    Having a windows server 2016 Standard Edition hosted on Hyperv.Since few weeks that server started problem of  stop Task Scheduler service,because of that scheduled task stopped working.

    Not getting any event related with that.

    Please help.

    Thank You

    Monday, July 2, 2018 7:34 AM

Answers

  • Hi,

    Thanks for your question.

    1.Check if other services in the Task Scheduler service dependencies have started normally.

            

    2.Try to restart the Task Scheduler service. Three methods are provided here for reference.

    • Start/Stop Task Scheduler from Services.msc.

       From General tab you can Start/Stop and change the Startup type of Task Scheduler.

    •  change Startup type of Task Scheduler from Registry Editor.

       Please navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Schedule and locate Start registry key

    Double click on Start and edit the value:

    Change Startup type :Automatic – 2,Manual – 3,Disabled – 4,Automatic (Delayed Start) – 2.

    Warning :Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by

    using another method. These problems might require that you reinstall the operating system. Microsoft

    cannot guarantee that these problems can be solved. Modify the registry at your own risk.

    •  Start/Stop and change Task Scheduler from Command Prompt.

    To Start Task Scheduler:  >net start Schedule

    To change Startup Type:

    Automatic:

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 2 /f

    Manual:

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 3 /f

    Disabled:

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 4 /f

    Automatic (Delayed Start):

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 2 /f

    Refer to the following link:

    https://computerstepbystep.com/task_scheduler_service.html

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. 

    3.Change the Task conditions

    Control panel> System and Security> Administrative Tools> Task Scheduler>Properties>Conditions tab

    Check mark “Start only if the following network connection is available.“

    Refer to the following link:

    http://troubleshooter.xyz/wiki/fix-task-scheduler-service-is-not-available-error/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. 

    Hope you have a nice day!

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Tuesday, July 3, 2018 10:08 AM
    Moderator
  • I'd check the Task Scheduler service is Automatic start and starts with Local System account. If that looks correct then there may be some corruption in existing tasks. I'd export them to XML, then delete them all and check the service status after reboot.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Proposed as answer by Dave PatrickMVP Thursday, August 23, 2018 12:49 PM
    • Marked as answer by activetech Thursday, January 17, 2019 9:17 AM
    Wednesday, July 4, 2018 1:21 PM

All replies

  • Hi,

    Thanks for your question.

    1.Check if other services in the Task Scheduler service dependencies have started normally.

            

    2.Try to restart the Task Scheduler service. Three methods are provided here for reference.

    • Start/Stop Task Scheduler from Services.msc.

       From General tab you can Start/Stop and change the Startup type of Task Scheduler.

    •  change Startup type of Task Scheduler from Registry Editor.

       Please navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Schedule and locate Start registry key

    Double click on Start and edit the value:

    Change Startup type :Automatic – 2,Manual – 3,Disabled – 4,Automatic (Delayed Start) – 2.

    Warning :Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by

    using another method. These problems might require that you reinstall the operating system. Microsoft

    cannot guarantee that these problems can be solved. Modify the registry at your own risk.

    •  Start/Stop and change Task Scheduler from Command Prompt.

    To Start Task Scheduler:  >net start Schedule

    To change Startup Type:

    Automatic:

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 2 /f

    Manual:

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 3 /f

    Disabled:

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 4 /f

    Automatic (Delayed Start):

    REG add "HKLM\SYSTEM\CurrentControlSet\services\Schedule" /v Start /t REG_DWORD /d 2 /f

    Refer to the following link:

    https://computerstepbystep.com/task_scheduler_service.html

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. 

    3.Change the Task conditions

    Control panel> System and Security> Administrative Tools> Task Scheduler>Properties>Conditions tab

    Check mark “Start only if the following network connection is available.“

    Refer to the following link:

    http://troubleshooter.xyz/wiki/fix-task-scheduler-service-is-not-available-error/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. 

    Hope you have a nice day!

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Tuesday, July 3, 2018 10:08 AM
    Moderator
  • Thank you for answer.

    Dependence service are running fine.In registry Start type is Automatic.

    Got access is denied while tried to stop task scheduler through command line.


    Wednesday, July 4, 2018 12:44 PM
  • I'd check the Task Scheduler service is Automatic start and starts with Local System account. If that looks correct then there may be some corruption in existing tasks. I'd export them to XML, then delete them all and check the service status after reboot.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Proposed as answer by Dave PatrickMVP Thursday, August 23, 2018 12:49 PM
    • Marked as answer by activetech Thursday, January 17, 2019 9:17 AM
    Wednesday, July 4, 2018 1:21 PM
  • Thank you So much David.

    A scheduled task of volume shadow copy service was the culprit.I tried to export,delete,reboot server recreate by import.Which does not worked.

    I have to delete the task,remove from registry reboot server and create the fresh one.

    Now its looking fine.

    Thank You 


    Thursday, August 23, 2018 1:00 PM
  • Glad to hear of success.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Thursday, August 23, 2018 1:23 PM