none
Unable to re-add rebuild Primary server to PG on Secondary RRS feed

  • Question

  • Hi, I hope someone can help.

    DPM 2012 R2 UR6 on Windows Server 2012 R2 (VM)

    We had a problem with our Primary DPM Server, which meant we had to rebuild it. We created a new VM, installed SQL and other pre-requisites and then installed DPM, to the correct UR. I then recovered the DPMDB from a backup and rand dpmsync -sync. All seemed to go well. All the data came back, and consistency checks are running. All appears to be well. So far so good!

    The problem
    started when I tried to run consistency checks on the Secondary Server. The
    Secondary had 8 or 9 PGs that were replicating SQL Server databases
    backups from the Primary to the Secondary. They had been working fine until the
    Primary crashed. They wouldn't run, I was getting errors that said: 

    DPM failed to
    communicate with the protection agent on 11V-DPM-01.mentecplus.local because
    access is denied. (ID 42 Details: Access is denied (0x80070005))

    In the
    management node on the Secondary, the agent of the Primary server showed up as
    unavailable. So I uninstalled it and re-installed it successfully. I had remove
    all the PGs holding the SQL Database replication jobs so that I could remove
    and re-install the agent on the Primary. I kept the data, so its in the
    inactive protection node. I restarted the Primary, just in case, and tried to
    re-add the Protection Groups for the Database replication, but when I expand
    the agent on the primary (within the New Protection Group Wizard), I cannot see
    the Protected Servers entry (under the DPM Server Name. I can see the DPM SQL
    Instance, so I tried to set up a PG to protect that Instance – but it goes
    through to the capacity page and then errors with a message that says

    DPM cannot
    access the Path C:\ because part of the path has been deleted or renamed (ID:
    36)

    If I select
    the C:\ drive of the Primary, under volumes, I cannot see anything under it,
    and again, I get the ID 36 error.

     

    Can only
    think that the rebuild Primary has a different ServerID or something similar in
    the database, which is causing the problem.

    The new
    Primary appears to be running OK, although a little slow, but it is doing a
    bunch of consistency checks, so I believe that is why it’s so slow. Trying to
    locate help on ID 36 hasn’t helped much – can anyone advise at all please?

    Many Thanks

    Regards

    John


    Regards, John

    Tuesday, October 6, 2015 10:55 AM

All replies