locked
New software packages automatically approved for all computers RRS feed

  • Question

  •  

    I've noticed that since upgrading to SP1 our SCE server automatically approves any new software packages for all computers.

     

    We ran into an issue when packaging a large application over lunch, and came back to find it had been pushed out to all of our clients and servers without being manually approved. This was just a test package which we were only going to deploy to a test computer, and then to a handfull of clients after we worked out the kinks and made sure it was configured correctly. Because of this, we now have to constantly monitor any new packages we create to catch it before it automatically deploys to the whole company... and when you have to package something that is 2.4 GB, it is not very user friendly to have to babysit the SCE console for 3 hours waiting to catch it when it finishes.

     

    So, is there a setting to stop this behavior and have new packages start unapproved for all groups?

     

     

    Tuesday, July 8, 2008 2:21 PM

Answers

  • Hi,

    Sounds like someone has created a Auto-approval rule that affect everything:-(. Can you open the SCE console, click on the administration space->Select Settings and on the right side double-click on Auto-approvals. By default, it should only be one rule for auto-approval of security and important updates here.

     

     

    Please post your result back here.

     

    Björn Axéll MVP - Advisec AB

    http://blog.advisec.com

     

     

     

    Tuesday, July 15, 2008 11:05 AM

All replies

  • Hi,

    Did you try to deploy another software later?

    I'd like to suggest you create a small software package, don't choose "show deployment option when this wizard finish" during the creating process, then check whether the problem still exists.
    --------------------
    Regards,
    Eric Zhang




    Thursday, July 10, 2008 9:18 AM
  • I've made over 20 packages since the upgrade and all have done the same thing.

     

    Unchecking that box only hides the options when it finishes. I checked the package after it was done and it is still approved for all computers.

     

    Thursday, July 10, 2008 8:44 PM
  • Hi,

    If you select
    "show deployment option when this wizard finish" during the creating process, after the software was created, did "Approve groups for deployment" appear?

    If this option appeared, please do not select any groups and choose OK, then check whether it will be automatically approved.

    --------------------
    Regards,
    Eric Zhang



    Friday, July 11, 2008 9:52 AM
  • The window appears when the option is selected. The problem is that the window pops up with 'all computers' group already selected, and the software will deploy to all of our computers when they check in even if I don't push 'OK'

     

    So when I make a large package, and it finishes creating while I am out of the area, it can deploy to all computers before I get back and approve/unapprove any of the groups.

     

    Is there anyway to make it so packages are not automatically approved for 'all computers' when the package is finished, so I don't have to manually unapprove it hoping that our clients didn't get software not intended for their machines?

    Friday, July 11, 2008 3:39 PM
  • Hi,

    Sounds like someone has created a Auto-approval rule that affect everything:-(. Can you open the SCE console, click on the administration space->Select Settings and on the right side double-click on Auto-approvals. By default, it should only be one rule for auto-approval of security and important updates here.

     

     

    Please post your result back here.

     

    Björn Axéll MVP - Advisec AB

    http://blog.advisec.com

     

     

     

    Tuesday, July 15, 2008 11:05 AM
  • That seemed to work.

    Thanks

     

    Wednesday, July 16, 2008 7:44 PM