none
MDT 2013 Update 2 is not splitting .wim RRS feed

  • Question

  • Hello all,

    I'm Trying to make an UEFI offline media USB with MDT 2013 Update 2

    The .wim size that I want to deploy is 4.32GB although I've set "SkipWimSplit" to False in :

    •  %DeployRoot%\Controls\Settings.xml
    •  %MediaRoot%\Content\Deploy\Controls\Settings.xml

    MDT just copy my .wim file without splitting it but I can't copy it after on a FAT32 USB drive.

    What should I do to make it work ?


    • Edited by _Skyy_ Monday, December 28, 2015 12:14 PM
    Monday, December 28, 2015 1:41 AM

Answers

All replies

  • So if SkipSplitWim is true then you will skip splitting the wim. So SkipSplitWim should be False and it is only necessary in the share settings.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.


    Monday, December 28, 2015 3:00 AM
    Moderator
  • Sorry what I've said is wrong I set it to False ... My bad.
    I edit my post
    • Edited by _Skyy_ Monday, December 28, 2015 12:30 PM
    Monday, December 28, 2015 12:14 PM
  • Post the output of update media. Also remove the setting from the media's settings.XML

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Monday, December 28, 2015 7:35 PM
    Moderator
  • I have created a new media with a selection profile that only include my 4.32GB, Only the deployment share have SkipWimSplit set to False.

    Below the output of the first Update media : 

    Starting MDT Media Update

    Opened the media deployment share.

    Folders to be copied to the media deployment share: 2

    Copied: DS001:\Operating Systems\Windows 10\Custom

    Copied: DS001:\Selection Profiles

    Copied: DS001:\Operating Systems\Windows 10\Custom with Replace option

    Copied: DS001:\Selection Profiles with Replace option

    Copied standard folders.

    Boot images updated.

    Setting up dual x86/x64 boot image.

    Not adding x86 boot entry to UEFI BCD because dual boot UEFI media is not supported.

    Not modifying display order for dual boot UEFI.Boot configuration editing completed.

    Reset read-only attributes.Successfully created media ISO.

    And the wim file hadn't been splitted.

    Tuesday, December 29, 2015 5:50 PM
  • Did you try this with an older MDT version before?
    There were some changes regarding splitting wim's in Update 2, a regression could be the problem.

    Tuesday, December 29, 2015 7:39 PM
  • No, but I will try it now, I prepare an other VM with MDT update 1 and I tell you
    Tuesday, December 29, 2015 8:14 PM
  • You have your media set to dual boot although that shouldn't block split it will block uefi.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Tuesday, December 29, 2015 9:13 PM
    Moderator
  • @Ty Glander : Sorry forgot to disable x86, I only prepare a x64 image. But it still doesn't change anything.

    @oriooff : MDT Update 1 do the split same configuration as before I end with 2 swm file (3.99GB + 335MB), I will revert my main VM to MDT update 1 for the moment, but yes update 2 have a regression on this part.

    Tuesday, December 29, 2015 11:05 PM
  • From the output above no split was requested. If you have settings.XML configured and this doesn't split do you have the OS referenced in a task sequence that is copied to your media?

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.


    Friday, January 1, 2016 12:40 AM
    Moderator
  • Hello Ty,

    I am having the same issue using MDT 2013 Update 2. My WIM file is ~4.2gb and there is no split done when I create the USB media, even if the SkipWimSplit is set to 'False'. Is there any known workaround?

    Friday, January 29, 2016 6:21 PM
  • There isn't a known issue (that I am aware of) other than if there are multiple WIMs to split.  You could try Rufus and not split at all.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.


    Friday, January 29, 2016 11:11 PM
    Moderator
  • I tried building a stick with rufus - NTFS and GPT for UEFI to hold my 11 GB wim.  My Surface Pro 4 does not appear to be able to boot from it.

    I'm still running update 1 so i'll try creating media with the wim split.

    Saturday, February 27, 2016 11:34 PM
  • No luck - the iso was created with the full 11gb iso instead of the split wim.  I set settings.xml in the control folder to False fro skipwimsplit.  Is there anything else I need to do?  This should be working with update 1, correct?
    Sunday, February 28, 2016 12:53 AM
  • I am having the same issue. I setup up MDT 2013 u1 on a different machine temporarily to create my offline media.

    Monday, February 29, 2016 3:27 PM
  • How are you guys getting it to work with u1? Mine never splits despite setting skipwimsplit to false
    Monday, February 29, 2016 6:23 PM
  • I did a fresh install of MDT 2013 U1, created a new deployment share and TS. I then set the Skipwimsplit to false on my deployment share and offline media.

    If you get it to work don't forget to modify the LTIapply.wsf file (split wim won't apply): http://blogs.technet.com/b/msdeployment/archive/2015/08/25/mdt-2013-update-1-release-notes-and-known-issues.aspx

    Monday, February 29, 2016 6:48 PM
  • Can you tell me the exact two places you change skipwimsplit? I changed it only in my deployment share control folder's settings.xml I haven't been able to find any documentation that clearly explains another location to set it in. Thanks!
    Monday, February 29, 2016 6:52 PM
  • .\Control\Settings.xml

    .\Deploy\Control\Settings.xml in your offline media folder

    Tuesday, March 1, 2016 3:30 PM
  • Thanks!  Unfortunately it still doesn't work.  I updated settings.xml in my offline media folder (d:\dump\content\deploy...) and performed an Update Media Content but the full wim is still written to the ISO.

    Is there another step I'm missing here? Do I have to start over and re-import my wim into the main deployment share to have it split?

    Tuesday, March 1, 2016 8:03 PM
  • I have the same problem with MDT 2013 Update 2. My Windows 10 wim-file is just under 7Gb. But even though <SkipWimSplit> is set to False MDT just ignores it when I update the Offline Media content. No error messages or anything. The ISO-file is created but it just doesnt perform the splitwim part.

    I've tried to edit Settings-xml in both the deploy root and the media root and even created a brand new deployment share. But it makes no difference.

    Thursday, March 31, 2016 10:05 AM
  • Thursday, March 31, 2016 1:16 PM
  • Thank you! :)
    That workaround worked just fine for me.
    Friday, April 1, 2016 6:33 AM
  • Glad to hear it worked for you!

    What exactly did you do because I can't get it to work.

    Thanks

    Wednesday, April 6, 2016 4:50 PM
  • Worked fine for me, too. Here's what I did.

    1) On my source deployment share (the one I'm creating the offline media from), edit the .\Control\settings.ini file to enable WIM splitting (set SkipWimSplit to False).

    2) Renamed my WIM title in the MDT console to JUST my_custom_image_name_format.wim. (I changed it from "WIN10-64-REF-IDDDrive in 20161107-WIN10-ID10 20161107-WIN10-ID10.wim" to just "20161107-WIN10-ID10.wim".) -- This is the workaround given in the link posted above.

    3) Then hit Update Media Content on my USB Media, and it split the WIM immediately. Curiously, though, it split the WIM on the source deployment share, too -- and deleted the original WIM from the deployment point's Operating Systems folder (!) -- so make sure you make a copy of the original WIM first if you don't have a readily accessible copy should something go wrong, or you wish to revert.

    EDIT: After some additional testing and letting the USB build complete, I have some additional information, as my statement in "3" above is wrong.

    The original WIM file is returned to the deployment share when the offline media build is complete. If you look while the media is compiling, you'll only see the SWIM files, but once my compile was done and I went back, the original WIM is back with the same date/time stamp and the SWIMs are deleted.

    I did find, though, that if I manually cancel the offline media build (I found an error that I wanted to correct and restart the compile), that WIM isn't copied back and only the SWIMs remain on the original share, so the next time you hit "Update Media Content" you get an error because the WIM file isn't available anymore. So I would still recommend making a backup copy, just in case. In my case, I had to delete the SWIMs from my source share, recopy in the original WIM file from a backup, and restart the USB build and they everything went just fine again.

    Good luck and happy building!

    • Edited by brass6332 Friday, December 16, 2016 7:00 PM Additional information
    Thursday, December 15, 2016 4:42 PM