locked
Specify intranet Microsoft update service location keeps changing RRS feed

  • Question

  • I have a WSUS server with the sole purpose of providing Windows 7/10 and Office updates to my SCCM Software Update Point. 

    I have a large number of servers with local policies configured to look to this WSUS server for updates.  My GPO is set so Specify intranet Microsoft update service location is Disabled.  The GPO settings have been verified via RSOP.  I've changed the local policy on a few of these servers so the Specify intranet Microsoft update service location is set to Non Configured (I've also tried Disabled), but the local setting keeps changing back to my local WSUS server.  The servers are mostly (if not all) 2012 R2 and 2016.

    Why is this happening, and what can I do to stop it?

    Monday, November 13, 2017 7:05 PM

All replies

  • I'm a bit confused. What's the end goal? Having the servers point to your WSUS that handles Windows 7/10/Office or a WSUS that handles only Servers or go directly to MS for updates?


    Adam Marshall, MCSE: Security
    http://www.adamj.org

    Tuesday, November 14, 2017 5:13 AM
  • Hi,

    I'd suggest you  try to "remove SCCM agent" from that server if it exists , then try again .

     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 14, 2017 5:50 AM
  • Sorry, I could have been much more clear.  I want my servers to go directly to Microsoft.
    Tuesday, November 14, 2017 1:23 PM
  • The suggestion of removing the SCCM client was a great one.  I normally don't have it installed on servers (I absentmindedly deployed IE 4 or 5 to all systems, forgetting that it included servers.  When the servers all started randomly rebooting, my boss told me "no more SMS on servers"), but I've been working on changing that. 

    This server that I'm using as a representative of group of servers having this problem DID have the SCCM client installed.  I have removed it.  Now I'll have to wait and see what happens.  In the meantime, I'll to check the rest of the servers.

    Tuesday, November 14, 2017 1:40 PM
  • 1. In the WSUS GPO assigned to this server, DISABLE the policy "Specify intranet Microsoft update service location".

    or

    2. If the policy has already been removed, or the machine is in a container with no policy applied for WSUS:
            Reset the registry value UseWUServer = dword:0x0 (DISABLED), or
            Delete the entire registry key HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate
                 which will revert the WUAgent to the original installed behavior of Automatic Updates
                 and then set the desired behavior using the Control Panel | Windows Update dialog.


    Adam Marshall, MCSE: Security
    http://www.adamj.org

    Tuesday, November 14, 2017 2:25 PM
  • The suggestion of removing the SCCM client was a great one.  I normally don't have it installed on servers (I absentmindedly deployed IE 4 or 5 to all systems, forgetting that it included servers.  When the servers all started randomly rebooting, my boss told me "no more SMS on servers"), but I've been working on changing that. 

    This server that I'm using as a representative of group of servers having this problem DID have the SCCM client installed.  I have removed it.  Now I'll have to wait and see what happens.  In the meantime, I'll to check the rest of the servers.

    Hi,

    Any updates ?

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Elton_Ji Wednesday, November 29, 2017 9:32 AM
    Wednesday, November 29, 2017 9:32 AM