none
MDT 2012 ScanState and USMT RRS feed

  • Question

  • Q. When I start migration from xp to Win7 on some machines ia have troubles, on the step Capture User State through mdt 2012 task fail with error rc = 72

    in error logs - Windows error 4317 description: Invalid ID operation.


    But when on the same workstation launch usmt separately process will go normally with no errors.

    What is the problem?

    My Customsettings.ini

    [Settings]

    Priority=Default
    Properties=MyCustomProperty

    [Default]

    ScanStateArgs=/v:5 /o /c /uel:120
    LoadStateArgs=/v:5 /c /lac

    OSInstall=Y
    SkipCapture=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=NO
    SkipBitLocker=NO

    EventService=http://wsttdeploy:9800

    My USMT parameters

    Where *servername* was servername.

    scanstate \\*servername*\migdata /i:migapp.xml /i:migdocs.xml /o /v:13 /c /uel:120

    Part of log.

    where *username* was the username.

    2015-05-07 11:07:09, Info                  [0x0802c6] Processing GATHER for migration unit: <*username*>\MigDocUser (CMXEAgent)
    2015-05-07 11:07:09, Status                [0x000000] Processing File C:\Documents and Settings\*username*\Application Data\Microsoft\Internet Explorer\Quick Launch
    2015-05-07 11:07:09, Warning               [0x080000] Mig::CTransportDataStore::Create: Failed to add intermediate folder for C:\Documents and Settings\*username*\Application Data\Microsoft\Internet Explorer\Quick Launch: Win32Exception: DoesObjectExist not allowed for a locked context.: Неверный идентификатор операции. [0x000010DD] int __thiscall Mig::CMediaManager::DoesObjectExist(class Mig::CUserContext *,struct Mig::IMigLocation *,struct Mig::IMigLocation **,struct Mig::IMigLocation **)
    2015-05-07 11:07:09, Error                 [0x000000] Read error 4317 for C:\Documents and Settings\*username*\Application Data\Microsoft\Internet Explorer\Quick Launch. Windows error 4317 description: Неверный идентификатор операции.
    2015-05-07 11:07:09, Info                  [0x000000] Terminating due to fatal pattern C:\Documents and Settings\* [*] in config.xml
    2015-05-07 11:07:09, Error                 [0x080000] Error 4317 while gathering object C:\Documents and Settings\*username*\Application Data\Microsoft\Internet Explorer\Quick Launch. Shell application requested abort!


    Friday, May 8, 2015 6:18 AM

All replies

  • The problem that the Scan state could not take a copy of the Quick Launch ( internet explorer) Files.
    I had the same problem,.



     


    The solution is to disable the Quick launch backup.

    You must go to  \\"servername"\"deployement share name "\Tools\x64\USMT5\MigUser.xml

    Then delete the ' Quick Launch Component' 

    <component type="System" context="User">
            <displayName _locID="miguser.quicklaunch">Quick Launch</displayName>
            <paths>
                <path type="File">%CSIDL_APPDATA%\Microsoft\Internet Explorer\Quick Launch</path>
            </paths>
            <role role="Settings">
                <detects>
                    <detect>
                        <condition>MigXmlHelper.DoesObjectExist("File","%CSIDL_APPDATA%\Microsoft\Internet Explorer\Quick Launch")</condition>
                    </detect>
                </detects>
                <rules>
                    <include filter='MigXmlHelper.IgnoreIrrelevantLinks()'>
                        <objectSet>
                            <pattern type="File">%CSIDL_APPDATA%\Microsoft\Internet Explorer\Quick Launch\* [*]</pattern>
                        </objectSet>
                    </include>
                    <merge script="MigXmlHelper.DestinationPriority()">
                        <objectSet>
                            <pattern type="File">%CSIDL_APPDATA%\Microsoft\Internet Explorer\Quick Launch [desktop.ini]</pattern>
                            <pattern type="File">%CSIDL_APPDATA%\Microsoft\Internet Explorer\Quick Launch\* [*]</pattern>
                        </objectSet>
                    </merge>
                </rules>
            </role>
        </component>

    Do the same thing for the \\"servername"\"deployement share name "\Tools\x86\USMT5\MigUser.xml File.


    • Edited by Zili nidhal Friday, October 5, 2018 8:03 AM
    • Proposed as answer by slimyaakoubi Wednesday, November 6, 2019 7:33 PM
    Monday, October 1, 2018 8:25 AM
  • thank you, that solves the problem
    Wednesday, November 6, 2019 7:28 PM