locked
Sharepoint alerts not working on Production RRS feed

  • Question

  • Hi all,

    When i am intitating an alert, a mail is sent to the user that alert has been created to this list/library. But when i change anything in the item then no mail is sent to user who is configured to that alert.

    Note: I have configured alert for all the changes and immediate alerts.

    I have checked the timer job in central admin, they also are present in the timer job definitions.

    Do i need to do anything else to get the alert message. Please advice....

    Thanks


    Success is not to be pursued; it is to be attracted by the person we become.
    Thursday, May 19, 2011 2:14 PM

Answers

  • Thank you for your responses.

    My issue has been resolved by adding all the web front end server IP's to relay settings in Exchange Server.


    Success is not to be pursued; it is to be attracted by the person we become.
    • Marked as answer by Shailu123 Wednesday, May 25, 2011 4:30 PM
    Wednesday, May 25, 2011 4:30 PM

All replies

  • I would check your recieve connectors in Exchange. You can either enable anonymous access in the defult recieve connector (not recommended because of security), or you can put the IPs for all of your web front end servers in the "Recieve mail from remote server" section.

     

    To explain, the inital email is sent out from a specific email related to your SharePoint site. The change alerts are sent out as anonymous. Also, the timer job that sends out these change alert emails switches servers from time to time. So, if you dont enable the recieve connector to recieve email from all of your web front end servers, there is a possibility of the immidiate alerts not to be sent.

     

    Hope this helps!

     

    Edit: You can test this by temporarily enableing anonymous access on the default recieve connector, then turning it back off when you confirm. Leaving this on is not recommended because of security, but it is a good test.

    Thursday, May 19, 2011 3:34 PM
  • Thank you Rick. Can you tell how can i enable receive connector...?
    Success is not to be pursued; it is to be attracted by the person we become.
    Thursday, May 19, 2011 3:45 PM
  • What version of exchange are you working with? Your recieve connector is enabled already, it just needs to be edited to correctly accept anonymous email.

    Thursday, May 19, 2011 3:48 PM
  • I do not have idea about version of Exchange but please tell me where(which path) i can edit to accept anonymous mails. 
    Success is not to be pursued; it is to be attracted by the person we become.
    Thursday, May 19, 2011 4:04 PM
  • I will give the path for Exchange 2010 and hopefuly you can determine where to go from this example. Without an exact version, these steps may be a bit off.

    1. Open up the Exchange Management Console

    2. Expand the "Server Configuration" Category in the left category menu.

    3. Click "Hub Transport"

    4. In the center section on the bottom box there should be a "Recieve Connectors" tab. Find the connector named "Default <Exchange Server Name>", Right click and select properties.

    5. To test the theory, Click Permission Groups and tick the Anonymous users check box, click apply, and then re-test the issue. (Remember to turn this back off if the test is successful as it is a security risk.)

    6. If the test works, you can click on the "Network" tab and under the "Recieve mail from remote servers that have these IP Addresses:" heading, click add.

    7. Add the IP addresses of all of the servers in the farm, Click Apply, then retest the issue.



    Edit: Keep in mind that the timer job that sends out immediate alerts runs about every 5 minutes. When you test, it may take some time for the user to get the alert.
    Thursday, May 19, 2011 5:19 PM
  • This SharePoint alert troubleshooting flowchart may help.

    http://sharepointalert.info/troubleshooting-sharepoint-alerts/


    Pentalogic Technology - Web Parts for Microsoft SharePoint www.pentalogic.net
    Friday, May 20, 2011 7:51 AM
  • Thank you for your responses.

    My issue has been resolved by adding all the web front end server IP's to relay settings in Exchange Server.


    Success is not to be pursued; it is to be attracted by the person we become.
    • Marked as answer by Shailu123 Wednesday, May 25, 2011 4:30 PM
    Wednesday, May 25, 2011 4:30 PM
  • This article covers it better: SharePoint Alert Notifications Not Working - Checklist for Troubleshooting

    http://www.sharepointdiary.com/2012/02/sharepoint-alerts-not-working-troubleshooting-checklist.html#ixzz2aSeccWhe
    Monday, July 29, 2013 6:49 PM