none
Since upgrade to Windows 8, cannot save .rdp files under the Remote Desktop Connection application on the Desktop

    General discussion

  • Since I upgraded to Windows 8, I am no longer able to save individual Remote Desktop Connection files as .rdp files. I am talking about the traditional Remote Desktop Connection application on the Desktop that was in previous Windows versions, not the Remote Desktop App from the Windows 8 store.

    When I try to click on the Save button I get "An error occurred while saving to file"

    When I try to click on the Save As button I get "Unable to open connection file" with the file address being where I tried to save it with the file name at the end.

    Also when I upgraded to Windows 8, my .rdp files disappeared from my Documents folder.

     I need to create different .rdp files for different programs that my employees get into on my server. Now I have to hand type all the info each time into the Programs tap on the Remote Desktop Connection window, because I can't save to an .rdp file.

     I like the Remote Desktop App from the Windows store but it won't let me designate specific programs to use using standard dos notation (ie c:\program files\ etc..). It just goes to my server desktop.

     I want to promote Windows 8 to my employees but I need either .rdp files for the traditional Remote Desktop Connection or the ability to open specific programs using dos notation in the Windows Store Remote Desktop App.

    Thursday, November 1, 2012 4:43 AM

All replies

  • Hi,


    I can save the .rdp file into desktop in my environment.


    You may go to Event Viewer to check if there is any related log.



    Kim Zhou

    TechNet Community Support

    Saturday, November 3, 2012 5:58 PM
  • exactly my experience.  I also get the "Unable to open connection file"; which is odd as we aren't trying to open the file, but to save it.  I upgraded from win7.

    let me know if you get anywhere with it!  I prefer to continue to use my existing RDC application too.

    Thursday, December 13, 2012 5:21 PM
  • Hi,

    Also for me, do you find a solution ?

    Sunday, January 20, 2013 12:05 PM
  • I know this is an old post but others might still be having the problem. Here's what I did.

    Create a new text file and open it in notepad. Copy the below into it and edit for your environment. (IP, screen size).

    screen mode id:i:2
    desktopwidth:i:1920
    desktopheight:i:1080
    session bpp:i:24
    auto connect:i:0
    full address:s:192.168.x.x
    compression:i:0
    keyboardhook:i:2
    audiomode:i:2
    redirectdrives:i:1
    redirectprinters:i:1
    redirectcomports:i:1
    redirectsmartcards:i:1
    displayconnectionbar:i:1
    username:s:USERNAME
    domain:s:DOMAIN
    alternate shell:s:
    shell working directory:s:
    disable wallpaper:i:1
    disable full window drag:i:1
    disable menu anims:i:1
    disable themes:i:1
    bitmapcachepersistenable:i:1
    use multimon:i:0
    winposstr:s:0,3,0,0,800,600
    audiocapturemode:i:1
    videoplaybackmode:i:1
    connection type:i:7
    networkautodetect:i:1
    bandwidthautodetect:i:1
    enableworkspacereconnect:i:0
    allow font smoothing:i:0
    allow desktop com:0
    disable cursor setting:i:0
    redirectclipboard:i:1
    redirectposdevices:i:0
    drivestoredirect:s:*
    autoreconnection enabled:i:1
    authentication level:i:2
    prompt for credentials:i:0
    negotiate security layer:i:1
    remoteapplicationmode:i:0
    gatewayhostname:s:
    gatewayusagemethod:i:4
    gatewaycredentialssource:i:4
    gatewayprofileusagemethod:i:0
    promptcredentialonce:i:0
    gatewaybrokeringtype:i:0
    use redirection server name:i:0
    rdgiskdcproxy:i:0
    kdcproxyname:s:

    You don't need to worry too much about what's in here. Save the text file as filename.rdp then rightclick on the file and select edit. The familiar GUI rdp session editor will open. You can make changes in the GUI and save or save as a different session.

     Hope this helps.


    • Edited by Jimdwa Friday, February 21, 2014 3:11 PM
    Friday, February 21, 2014 3:11 PM
  • I wanted to add my experience here.  I had the same problem, and I would receive either "An error occurred while saving to file" or "Cannot open connection file".  For work I move between my virtual machine, my Surface Pro, and my home PC a lot.  To keep this all together I used OneDrive, and I have redirected my "Documents" folder into my OneDrive location.  This allows anything saved in to my "Documents" folder to automatically be uploaded to my OneDrive.  I looked in my "Documents" folder and found that "Default.rdp" had a status of "Online Only" in the "Availability" column.  I believe "Default.rdp" may be hidden by default if you do not see it in yours.  I double-clicked the file which downloaded a copy, and changed the status to "Available Offline".  Once the "Default.rdp" was downloaded I did not have any further issues. 
    Tuesday, July 29, 2014 1:19 PM
  • Just wanted to say thanks!  I have the same setup and this solved the issue.  
    Thursday, September 18, 2014 7:20 PM
  • Worked for me, too.

    I couldn't save the RDP file anywhere from within the RDP program. I could create a file on the desktop (and everywhere else) so I did what Jimdwa suggested and it worked.

    Tuesday, January 17, 2017 2:26 AM