none
CQWP - Not returning results after extensive research

    Question

  • Hi,

    My CQWP does not return any results.
    Question: Why?!

    I configured a single filter: Manager=[Me] (Manager is a person/group site column)
    The source is set to all sites in the site collection
    No sorting.
    ListType: Documentlibrary
    Items of this contenttype: SourceDoc (Custom document content type where all other custom document ct's inherit from)

    That's it. List view throttling is set to the default value of 5.000.

    I've added the Manager column as an indexed column on every documentlibrary. 

    I've done extensive research on:
    -List view throttling;
    -Indexed columns;
    -CQWP Filtering & sorting;

    When I set the LVT to 50.000 (that's fifty thousand) the results are displayed (5 documents for my test user)

    I have approx 30.000 documents, 20 document libraries, 14.000 document sets.

    Interesting fact (per haps) the site column Manager is added to both SourceDoc and SourceDocSet (SourceDocSet is the document set content type where all other custom document set ct's inherit from).

    Any tips are welcome!

    Wednesday, July 31, 2013 12:18 PM

Answers

  • Hi,

    Unfortunatly I received the answer from Microsoft. It turns out:

    The CQWP only uses indexed columns when selecting a single list as source. The CQWP ignores the indexed columns when the source is anything else than a single list!

    This results in exceeding the list view throttling and this stops the CQWP from returning any results.

    Read about it in this blog:
    http://groundhog667.blogspot.nl/

    • Marked as answer by sander_d Wednesday, August 14, 2013 9:44 AM
    Wednesday, August 14, 2013 9:44 AM

All replies

  • Hi,

    I really need help in getting the CQWP to work!

    I just created 2(!) new environments (Dutch & English) and CQWP doesn't seem to work! On both env I added a CQWP with source = 'Show items from all sites in this site collection' and 'Additional filter=Show items when: Manager is equal to [Me] (first option)' .

    Added approx 6.000 documents to Shared Documents doc lib. After that I added a new site column called 'Manager' to the content type 'Document'. I edited 1 document and set Manager=Johndoe (a user in my env). I promoted the column Manager as an indexed column on the doc lib. I logged in with Johndoe and the CQWP did not return any results "The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator". But according to the article (and more like it) this should not be the case because the filter should return only 1 document - and it does when I set the source to the single library.

    I read the following article:

    http://social.technet.microsoft.com/Forums/sharepoint/en-US/a68a8997-0cad-44e1-97ea-f3b7a8990803/list-view-threshold-error

    08/06/2013 10:46:29.19  w3wp.exe (0x0C98)                        0x16F0 Web Content Management         Publishing                     7352 Warning  Error occured while processing a Content Query Web Part. Performing the following query '<ViewFields><FieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Nullable="True" Type="Text"/><FieldRef ID="{94f89715-e097-4e8b-ba79-ea02aa8b7adb}" Nullable="True" Type="Lookup"/><FieldRef ID="{1d22ea11-1e32-424e-89ab-9fedbadb6ce1}" Nullable="True" Type="Counter"/><FieldRef ID="{28cf69c5-fa48-462a-b5cd-27b6f9d2bd5f}" Nullable="True" Type="DateTime"/><FieldRef ID="{1df5e554-ec7e-46a6-901d-d85a3881cb18}" Nullable="True" Type="User"/><FieldRef ID="{d31655d1-1d5b-4511-95a1-7a09e9b75bf2}" Nullable="True" Type="User"/><FieldRef ID="{8c06beca-0777-48f7-91c7-6da68bc07b69}" Nullable="True" Type="DateTime"/><FieldRef ID="{30bb605f-5bae-48fe-b4e3-1f81d9772af9}" Nullable="True" Type="Lookup"/><FieldRef ID="{ba3c2... b8210847-657f-40f3-80af-22bf444ad8f8
    08/06/2013 10:46:29.19* w3wp.exe (0x0C98)                        0x16F0 Web Content Management         Publishing                     7352 Warning  ...7ee-4791-4867-8821-ff99000bac98}" Nullable="True" Type="Text"/><FieldRef ID="{c5c4b81c-f1d9-4b43-a6a2-090df32ebb68}" Nullable="True" Type="Lookup"/><FieldRef ID="{8fca95c0-9b7d-456f-8dae-b41ee2728b85}" Nullable="True" Type="Lookup"/><FieldRef ID="{39360f11-34cf-4356-9945-25c44e68dade}" Nullable="True" Type="Text"/><FieldRef ID="{543bc2cf-1f30-488e-8f25-6fe3b689d9ac}" Nullable="True" Type="Image"/><FieldRef ID="{43bdd51b-3c5b-4e78-90a8-fb2087f71e70}" Nullable="True" Type="Number"/><FieldRef ID="{9da97a8a-1da5-4a77-98d3-4bc10456e700}" Nullable="True" Type="Note"/><FieldRef ID="{f366697d-21a6-493e-af7d-9b3cf5410ea4}" Nullable="True" Type="User"/></ViewFields><Lists ServerTemplate="101"></Lists><Webs Scope="Recursive" /><RowLimit>15</RowLimit><Query><Where><And><BeginsWith><FieldRef Name="Cont... b8210847-657f-40f3-80af-22bf444ad8f8
    08/06/2013 10:46:29.19* w3wp.exe (0x0C98)                        0x16F0 Web Content Management         Publishing                     7352 Warning  ...entTypeId" Nullable="True" Type="ContentTypeId"/><Value Type="ContentTypeId">0x0101</Value></BeginsWith><Eq><FieldRef ID="{f366697d-21a6-493e-af7d-9b3cf5410ea4}" Nullable="True" Type="User"/><Value Type="User"><UserID/></Value></Eq></And></Where><OrderBy></OrderBy></Query>' generated the following error: The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator. at the following url: /sites/HugeList. Web Part title: Content Query b8210847-657f-40f3-80af-22bf444ad8f8

    Tuesday, August 06, 2013 8:55 AM
  • Hi,

      The maximum LVT available in SP 2010 is 5000. Please find the link below for more reference,

    http://technet.microsoft.com/en-us/library/cc262787%28office.14%29.aspx#ListLibrary. I think you've given more than value as supported by SharePoint. That's what the error reporting that it exceeds the value. 


    Balaji -Please click mark as answer if my reply solves your problem.

    Tuesday, August 06, 2013 9:08 AM
  • Hi,

    Thank you for the response.

    The LVT is indeed 5.000 BUT as stated in the link the LVT should only kick in when the result of the query including the filter is higher then the LVT. This is not the case. Only 1 document should be returned (if I set the source to the list itself it only returns 1 document).

    So why does the CQWP return results when I set the source to a list and not when I select a site collection or site?

    THNX!

    Tuesday, August 06, 2013 9:33 AM
  • Hi,

    Unfortunatly I received the answer from Microsoft. It turns out:

    The CQWP only uses indexed columns when selecting a single list as source. The CQWP ignores the indexed columns when the source is anything else than a single list!

    This results in exceeding the list view throttling and this stops the CQWP from returning any results.

    Read about it in this blog:
    http://groundhog667.blogspot.nl/

    • Marked as answer by sander_d Wednesday, August 14, 2013 9:44 AM
    Wednesday, August 14, 2013 9:44 AM