locked
Linux Integration Services and Slackware RRS feed

  • Question

  • Hello I am trying to install Linux Integration Services on Slackware 13.37 but the process is failing.

    This is the error:

    Can someone help?



    • Edited by Vasil Dimov Wednesday, April 4, 2012 12:34 PM
    Wednesday, April 4, 2012 12:32 PM

Answers

  • The latest LIS provied by MS are only made for RHEL6 and CentOS6 (and are likely to work with other EL clones). Forget them on Slackware :-)

    That said you should check out your distribution kernel - if it's at least 2.6.39 (since then they are pretty stable) you can consider trying the in-kernel Hyper-V driver modules. - Some distribution have actually not enabled them in their default builds.

    Linux 3.4 will be the first release that has all drivers out of staging area and also contains some interesting bug fixes to the Hyper-V integration. The best thing is to knock on your favourite distributions' bugtracker and give them good arguments to either upgrade the distro kernel to 3.3+ or backport the driver from 3.4-rc1. (Which is what Ubuntu LTS 12 has done and Debian wheezy will do)

    Monday, April 9, 2012 3:36 PM

All replies

  • The latest LIS provied by MS are only made for RHEL6 and CentOS6 (and are likely to work with other EL clones). Forget them on Slackware :-)

    That said you should check out your distribution kernel - if it's at least 2.6.39 (since then they are pretty stable) you can consider trying the in-kernel Hyper-V driver modules. - Some distribution have actually not enabled them in their default builds.

    Linux 3.4 will be the first release that has all drivers out of staging area and also contains some interesting bug fixes to the Hyper-V integration. The best thing is to knock on your favourite distributions' bugtracker and give them good arguments to either upgrade the distro kernel to 3.3+ or backport the driver from 3.4-rc1. (Which is what Ubuntu LTS 12 has done and Debian wheezy will do)

    Monday, April 9, 2012 3:36 PM
  • I am trying to install Linux Integration Services on Slackware 13.37 but the process is failing.

    Can someone help?



    "install Linux Integration Services" not need, use Slackware 14.0  ( but best after rebuild kernel with patches 1b) db63a4c8115a libata 1) cd006086fa5d ata_piix ) 

     Details:

    vvm.blog.tut.by Slackware on Hyper-V 

    ==

     . . .

    ==
    Linux kernel 3.2.27.
    Include the staging/hv modules.
    ==

    *.ko related Hyper-V work as need:
    – LAN
    – SCSI disk
    Tested on:
    slackware*-current (slackware*-14.0 RC2). 2012-08-16

     But need:

    backport to Slackware 14.0 patches 1b) db63a4c8115a libata 1) cd006086fa5d ata_piix

    i.e. in Slackware 14.0 RC2 exist well-known problem "ata_piix and hv_storvsc both claim the (virtual) hard disk"

     . . .

    ==

    Tuesday, September 11, 2012 9:57 AM

    --

    Good morning, when you use legacy network, only 10 MBPS are possible. On version 14 that was corrected?

    ~

    Legacy LANCard is _full_ emulation 100Mb Ethernet card

    Use Syntetic LANCard , supported in Slackware v14.00 and in "v14.1 Current"

    ~


    • Edited by Victor Miasnikov Wednesday, April 24, 2013 2:58 PM re: legacy network, only 10 MBPS
    Tuesday, September 11, 2012 9:57 AM
  • Good morning, when you use legacy network, only 10 MBPS are possible. On version 14 that was corrected?
    Sunday, October 21, 2012 11:56 PM
  • ~

    use Slackware 14.0  ( but best after rebuild kernel with patches 1b) db63a4c8115a libata 1) cd006086fa5d ata_piix )    

    .  . .

    *.ko related Hyper-V work as need:
    – LAN
    – SCSI disk

     . . .

     But need:

    backport to Slackware 14.0 patches 1b) db63a4c8115a libata 1) cd006086fa5d ata_piix

    i.e. in Slackware 14.0 RC2 [ and in 14.0 RTM ] exist well-known problem "ata_piix and hv_storvsc both claim the (virtual) hard disk"

     . . .

    ==

    ~

    FIXed:

    ----- Original Message -----
    From: "Victor Miasnikov"
    To: "Patrick J. Volkerding"
    Sent: Wednesday, April 24, 2013 4:43 PM
    Subject: Thanks! FIXed in SlackWare v14.01 _Current 2013-04-19 . . .

     Tested with

    SlackWare v14.01 _Current 2013-04-19 x64

    http://taper.alienbase.nl/mirrors/slackware/slackware64-current-iso/
    ===
    slackware64-current-install-dvd.iso  19-Apr-2013 16:27 2.3G
    ===

    This file has been downloaded 23.04.2013, 18:26 ( GMT+3)


     This
    VVM>> Thanks for hid_hyperv ( mouse for Hyper-V)
     and this
    VVM>> Problem "1b) db63a4c8115a libata 1) cd006086fa5d ata_piix IDE" -- FIXed , thanks!

    worked as need on SlackWare v14.01 _Current 2013-04-19

     Thanks again!

    Best regards, Victor Miasnikov

    --

    ~

    Wednesday, April 24, 2013 2:47 PM
  • 2013-10-17:

    Slackware 14.1 new features:

    CONFIG_HYPERV_BALLOON=m
    CONFIG_HID_HYPERV_MOUSE=m

    Friday, October 18, 2013 2:38 PM