locked
Document Template section is not available when creating a new Document or Form Library RRS feed

  • Question

  • When I attempt to create a new document or form library by clicking View All Site Content, then click Create, then select Document Library, the Document Template section at the bottom is not available - it doesn't even show on the page.

     How do I get that section to show up?

    Thursday, May 19, 2011 4:03 PM

Answers

  • Alright, Since we are working in an unknown(which was configured by an unknown person) environment, lets start debugging by looking at the feature folder inside 12 hive.

    Navigate to the Document Library folder located at C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\

    Make sure the folder exists. If it does, open command prompt and navigate to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN and execute the following command.

    stsadm -o installfeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library"

    This should install the feature.

    You might want to activate this feature with this command.

    stsadm -o activatefeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library" -url "<site collection url>".

    When you create a site in a site collection, SharePoint works in similar way. There are handlers/ scripts which create site and activate the out of the box features. Let us know if you were able to activate it.

    The other option you might want to try is creating a new web application and site collection to verify if the document libraries and other lists do show up by default. We will be able to narrow it down based on the results.

    Also, do let us know the SharePoint version number by navigating to Central Administration and click on Servers in Server farm.

     

     


    V

    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:38 AM
    Friday, May 20, 2011 2:37 PM
  • Are you using name or filename in the command. You would need to send "name" parameter in the command line.

    stsadm -o installfeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library"

    You could pass either name or filename. If you wish to send filename as a parameter, you would need to execute the following command line.

    stsadm -o installfeature -filename "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library\feature.xml"


    V
    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:38 AM
    Friday, May 20, 2011 2:58 PM
  • Ah My bad!

    Can you execute the following commands

    stsadm -o installfeature -name DocumentLibrary

    stsadm -o activatefeature -name DocumentLibrary -url <sitecollectionurl>


    V
    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:38 AM
    Friday, May 20, 2011 3:40 PM

All replies

  • Can you make sure you have the Team Collaboration Lists feature activated?

    Navigate to Site collection -> Click on Site Actions -> Click on site settings -> Click on site Features under Site Administration -> Activate Team Collaboration Lists feature.

     


    V
    Thursday, May 19, 2011 4:44 PM
  • Yes, the Team Collaboration Lists feature is active.
    Thursday, May 19, 2011 4:46 PM
  • Hi,

    did you link / delete document content type to any other content type ?

     


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Friday, May 20, 2011 7:39 AM
  • I'm not sure I totally understand your question.  I inherited this development site - I was not the one to set it up.  I have not linked or deleted any document content types to anything.  My initial question is referring to creating a new document library, not trying to edit/change an existing one.  Thank you for your help.
    Friday, May 20, 2011 12:53 PM
  • Alright, Since we are working in an unknown(which was configured by an unknown person) environment, lets start debugging by looking at the feature folder inside 12 hive.

    Navigate to the Document Library folder located at C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\

    Make sure the folder exists. If it does, open command prompt and navigate to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN and execute the following command.

    stsadm -o installfeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library"

    This should install the feature.

    You might want to activate this feature with this command.

    stsadm -o activatefeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library" -url "<site collection url>".

    When you create a site in a site collection, SharePoint works in similar way. There are handlers/ scripts which create site and activate the out of the box features. Let us know if you were able to activate it.

    The other option you might want to try is creating a new web application and site collection to verify if the document libraries and other lists do show up by default. We will be able to narrow it down based on the results.

    Also, do let us know the SharePoint version number by navigating to Central Administration and click on Servers in Server farm.

     

     


    V

    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:38 AM
    Friday, May 20, 2011 2:37 PM
  • When executing the stsadm -o installfeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library" command I get the following response:

    The feature path 'C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library\feature.xml' must be of the form 'directory\feature.xml'

    Thank you.

    Friday, May 20, 2011 2:55 PM
  • Are you using name or filename in the command. You would need to send "name" parameter in the command line.

    stsadm -o installfeature -name "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library"

    You could pass either name or filename. If you wish to send filename as a parameter, you would need to execute the following command line.

    stsadm -o installfeature -filename "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Document Library\feature.xml"


    V
    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:38 AM
    Friday, May 20, 2011 2:58 PM
  • I copied it exactly how you posted it - using -name.
    Friday, May 20, 2011 3:05 PM
  • Can you verify if the folder "Document library" exists inside 12\Features folder?Also, can you create a new team site and verify if all the document libraries exist?

    V
    Friday, May 20, 2011 3:20 PM
  • Yes, the document library folder exists.  I created a new team site and I have the same issue.  Also, if it helps, when I create a new doc library, then click the 'New' to add a new doc to the library, it defaults to an Excel file.
    Friday, May 20, 2011 3:27 PM
  • Ah My bad!

    Can you execute the following commands

    stsadm -o installfeature -name DocumentLibrary

    stsadm -o activatefeature -name DocumentLibrary -url <sitecollectionurl>


    V
    • Marked as answer by Leoyi Sun Thursday, May 26, 2011 9:38 AM
    Friday, May 20, 2011 3:40 PM
  • I executed the above commands.  I had to add the -force option to the first command to re-install the feature.  The second command said the feature was already activated, so I added the -force option to that too.  Both returned Operation completed successfully.  Unfortunately, this did not fix the issue.
    Friday, May 20, 2011 4:03 PM
  • How were you able to create a new document library in the team site? The problem was "you could create one" ,right?

    V
    Friday, May 20, 2011 5:18 PM
  • I can create document libraries, but I cannot choose/assign/edit the document template/content types.  Every document library I create defaults to Excel and I am not able to select a different type as the document template section does not show as an option on the create screen - even if I am logged in as the Admin.
    Friday, May 20, 2011 5:23 PM