locked
why the Upload form is not like the New Form in Document Library !!!! RRS feed

  • Question

  • I added a new content type and i set my document library to use and display this content type.

    However, when i click on --> New --> myContentType ... i get the template document ... and when i save i can fill all the properties !! which come from the content Type columns ! that is fine.

    but .. when i click upload ... i only get 1 property to fill which is the "name" !!!!!!!
    How can i apply my Content Type properties to appear in "UPLOAD" Form as well ?

    Please ... reply ASAP !!!!
    thanx a lot !


    Monday, December 10, 2007 9:17 AM

All replies

  • Even during upload you'd get set of meta-data to be filled for the document.

    In upload form, choose the document and click 'OK'.

     

    In next screen you should get set of meta-data to be filled for the document

     

    Monday, December 10, 2007 10:57 AM
  • I know ... !
    I'm talking about this screen .. with the name: EditForm.aspx !!!!
    It only shows 1 property ... that can be edited !!!!

    although ... i've added a content Type to this document library and this contentType have multiple columns !!!

    can any of the microsoft Sharepoint experts help me ... !!!?
    How can i display the properties of my ContentType in the EditForm.aspx ... (in upload and Edit Items)
    Tuesday, December 11, 2007 5:07 AM
  • Is it really a very diffecult problem !? MSDN .. forum .. + no answer !

    Where should we post such sharepoint questions ?!!!


    Please Help Sad
    Tuesday, December 11, 2007 7:59 AM
  • This is working as designed.   When you click on the upload, SharePoint does not know what type of document you are uploading.   First it needs to get the document (hence the first form) and then it will ask for the content type and all the metadata.

     

    Based on my understanding of how SharePoint's upload works I am not sure if you can easily change this.

    Tuesday, December 11, 2007 12:00 PM
  • ... but ..even when i upload a document ... !!
    it doesn't give me the metadata form !! ... instead it only allows me to enter 1 metadata which is the Name !!!

    i specified only 1 content type for my document library !!

    How can i show the same metadata form in both Upload and Add New document form ???

    Wednesday, December 12, 2007 5:40 AM
  • Loooool !!!!

    I Solved it !!!!

    It was a stupid BUG !!!! In SharePoint !! ...

    ...


    Thank you guys !
    Wednesday, December 12, 2007 6:09 AM
  • how could he resolve it ???

    thank u for help

    Thursday, April 19, 2012 3:57 PM