locked
SCSM 2012 Self Service Portal RRS feed

All replies

  • Hey

    Do you see the orange "Need help" title?

    regards
    Marcel


    SCSMfaq // Blog --> http://blog.scsmfaq.ch // Twitter --> #scsmfaq // Business --> http://www.itnetx.ch
    Thursday, December 8, 2011 1:00 PM
  • Hi,

         I see a blank sliverlight web part in the location of "Need Help" Title

     

    Thank for your help

     

    Li Liang


    Thursday, December 15, 2011 6:48 AM
  • I have the same issue , please advice?

     

     

    Kareem Behery


    Kareem Behery
    Wednesday, December 28, 2011 9:52 AM
  • Kareem,

    To double check you tried the solution here? Also what happens when you log in as another user I have had problems with domain admin accounts.

    Thursday, January 5, 2012 4:47 PM
  • Hi Ducan,

     

    i never tried user account . i used my admin account.

     

     

    Thanks,

     


    Kareem Behery
    Thursday, January 5, 2012 5:11 PM
  • Kareem,

     

    Did it work when using the other account or is there still an issue?

     

    Duncan

    Thursday, January 5, 2012 6:34 PM
  • the same issue,

     

     


    Kareem Behery
    Tuesday, January 10, 2012 10:59 AM
  • I'm not sure if this helps but it did for me:
    http://www.code4ward.net/main/Blog/tabid/70/EntryId/139/Service-Manager-2012-Self-Service-Portal-not-working-blank.aspx

    cheers,
    Stefan

    http://www.code4ward.net

    Tuesday, February 14, 2012 12:26 PM
  • @Li Liang

    1. SMPortal_WebContentServer_url should be http://<webcontent_server_name>:<portnumber>/ContentHost/ClientBin/

    <webcontent_server_name> : FQDN of the portal web content server (WCS).

    <portnumber>: port number specified during setup of portal WCS.

    2. ContentHostAbsoluteUri should be http://<webcontent_server_name>:<portnumber>/ContentHost

    Most important thing is to make sure that you dont mix http/https between WCS and Sharepoint site. E.g. If WCS was installed with http then Sharepoint site should also use http. Adjust the URls accordingly. Note that if you installed with https and then want to change it WCS you will have to change more settings in the web.config of WCS\ServiceHost. I can provide you with more details about that if needed.

    Thanks,

    Paresh


    Paresh

    Monday, February 20, 2012 7:32 PM
    Answerer
  • If you r using Internet Explorer check the host is in the trusted site list.

    Wednesday, February 29, 2012 10:57 PM
  • @Li Liang

    1. SMPortal_WebContentServer_url should be http://<webcontent_server_name>:<portnumber>/ContentHost/ClientBin/

    <webcontent_server_name> : FQDN of the portal web content server (WCS).

    <portnumber>: port number specified during setup of portal WCS.

    2. ContentHostAbsoluteUri should be http://<webcontent_server_name>:<portnumber>/ContentHost

    Most important thing is to make sure that you dont mix http/https between WCS and Sharepoint site. E.g. If WCS was installed with http then Sharepoint site should also use http. Adjust the URls accordingly. Note that if you installed with https and then want to change it WCS you will have to change more settings in the web.config of WCS\ServiceHost. I can provide you with more details about that if needed.

    Thanks,

    Paresh


    Paresh

    Hi Paresh,

    I'm getting also an empty portal.  I have the WCS and the Sharepoint installed on 2 different servers.  I have changed the webconfig on both servers so that they both refer to the WCS server with https.  What other settings need to be looked at on the WCS server (you mentioned that in your last post)?

    Thanks in advance.

    Edit: I have removed both self-signed certificates, rebooted the 2 servers, recreated the self-signed certificates but still the same portal without the Need help text.

    Edit2: Modified now the web.config to http (instead of https) on both servers, also the same result.

    • Edited by Trail2012 Wednesday, April 11, 2012 6:19 PM
    Monday, April 9, 2012 4:16 PM
  • When opening the portal I still got the blank screen.

    The IE gave me the warning msg below.  Because the Web content server is installed on another server I also now imported the certificate of that server into the trusted root cert of the portal server. Any help would be appreciated.

    Sunday, April 15, 2012 8:31 AM
  • I had the same problem in an environment with restricted access to Windows updates and Sharepoint. Did all necessary updates manually, but when I performed the same procedures in an environment released haven't had the error.

    Your environment is controlled for updates? I suggest uninstalling the WebPortal, Sharepoint ... upgrade Windows Server completely, then reinstall the Sharepoint, updating it and finally install the WebPortal of the Service Manager.

    Just solved this with me. Not yet identified what is this required update, but once you find it I post here.

    Regards,


    Thiago Carvalho Freitas MCP | MCTS

    Thursday, April 19, 2012 6:56 PM
  • I also can confirm that if you install all windows updates the portal will function.  I rebuild my lab from scratch, first install all windows updates on your servers and then the System Center Suite.

    Saturday, April 28, 2012 4:47 PM
  • Use this http://blogs.technet.com/b/servicemanager/archive/2012/05/04/faq-why-is-my-self-service-portal-service-catalog-blank.aspx

    Also, if you're using HTTPS do the following:

    • Navigate to IIS
    • Right-click on Service Manager Portal and click Edit Bindings
    • Highlight the site and click Edit
    • Under SSL certificate, choose the Self-Signed cert and click OK
    • Restart IIS

    My binding port for SCSMWebContentServer is 444 and for Service Manager Portal it's 443.

    Friday, May 11, 2012 4:50 PM
  • I use this guide above, but it only works when you install all Web Portal and Content with SSL, and if you use another cer generated by server install it on end computer
    Monday, May 14, 2012 5:12 AM