none
Receive conector for Internal Printer to send the Scan's to internal Reciepient

    Question

  • Hello Guys,

    I am sorry to ask the same question which was asked many time before already. but i am seriously not finding any info about my Situation and i have almost tried everything to make connection between the exchange server and internal Printer , which are authenticating by Internal Exchange Server account.

    we have exchange 2013 CU 13 server, there are only default connectors are there for all mail flows and everything is working fine,except some printer in my company can not make any connection with Exchange server and give SMTP Server connection error.

    I only need to create a connector which can receive mails from Internal SMTP Devices and Authenticating with Exchange Server account.

    Please Help.

    thank you so much.

    Friday, February 10, 2017 3:49 PM

All replies

  • You should create a relay connector, at the RemoteIPRanges use the IP Address range, where your printers are:

    New-ReceiveConnector -Name 'E2K13Server-01 Relay Connector' -RemoteIPRanges @('10.30.2.0-10.30.2.254') -Bindings @('0.0.0.0:25') -Usage 'Custom' -Server 'E2K13Server-01.contoso.com' -TransportRole 'FrontendTransport'

    Set-ReceiveConnector -RemoteIPRanges @('10.30.3.0-10.30.3.254') -Bindings @('0.0.0.0:25') -PermissionGroups 'AnonymousUsers' -Identity 'E2K13Server-01\E2K13Server-01 Relay Connector'

    Get-ReceiveConnector “E2K13Server-01 Relay Connector” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “Ms-Exch-SMTP-Accept-Any-Recipient”

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -TarpitInterval 00:00:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -ConnectionTimeout 00:30:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -ConnectionInactivityTimeout 00:20:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxAcknowledgementDelay 00:00:00
    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnection 10000

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnectionPercentagePerSource 100

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnectionPerSource unlimited

    Friday, February 10, 2017 4:08 PM
  • You should create a relay connector, at the RemoteIPRanges use the IP Address range, where your printers are:

    New-ReceiveConnector -Name 'E2K13Server-01 Relay Connector' -RemoteIPRanges @('10.30.2.0-10.30.2.254') -Bindings @('0.0.0.0:25') -Usage 'Custom' -Server 'E2K13Server-01.contoso.com' -TransportRole 'FrontendTransport'

    Set-ReceiveConnector -RemoteIPRanges @('10.30.3.0-10.30.3.254') -Bindings @('0.0.0.0:25') -PermissionGroups 'AnonymousUsers' -Identity 'E2K13Server-01\E2K13Server-01 Relay Connector'

    Get-ReceiveConnector “E2K13Server-01 Relay Connector” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “Ms-Exch-SMTP-Accept-Any-Recipient”

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -TarpitInterval 00:00:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -ConnectionTimeout 00:30:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -ConnectionInactivityTimeout 00:20:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxAcknowledgementDelay 00:00:00
    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnection 10000

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnectionPercentagePerSource 100

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnectionPerSource unlimited

    Hey Joerg,
    I do have only three Printers inside the domain only this Devices will be needed to send the scan to internal Exchange users,

    New-ReceiveConnector -Name 'E2K13Server-01 Relay Connector' 
    -RemoteIPRanges @('10.30.2.1-10.30.2.3') -Bindings @('0.0.0.0:25') 
    -Usage 'Custom' -Server 'E2K13Server-01.contoso.com' -TransportRole 
    'FrontendTransport'
    Set-ReceiveConnector -RemoteIPRanges @('10.30.2.1-10.30.2.3') 
    -Bindings @('0.0.0.0:25') -PermissionGroups 'AnonymousUsers' -Identity 
    'E2K13Server-01\E2K13Server-01 Relay Connector'
    

    and rest of the command which you have explained and this is not going to affect any other Mail work flow, ?

    thank you for the help.

    Friday, February 10, 2017 5:13 PM
  • You should create a relay connector, at the RemoteIPRanges use the IP Address range, where your printers are:

    New-ReceiveConnector -Name 'E2K13Server-01 Relay Connector' -RemoteIPRanges @('10.30.2.0-10.30.2.254') -Bindings @('0.0.0.0:25') -Usage 'Custom' -Server 'E2K13Server-01.contoso.com' -TransportRole 'FrontendTransport'

    Set-ReceiveConnector -RemoteIPRanges @('10.30.3.0-10.30.3.254') -Bindings @('0.0.0.0:25') -PermissionGroups 'AnonymousUsers' -Identity 'E2K13Server-01\E2K13Server-01 Relay Connector'

    Get-ReceiveConnector “E2K13Server-01 Relay Connector” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “Ms-Exch-SMTP-Accept-Any-Recipient”

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -TarpitInterval 00:00:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -ConnectionTimeout 00:30:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -ConnectionInactivityTimeout 00:20:00

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxAcknowledgementDelay 00:00:00
    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnection 10000

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnectionPercentagePerSource 100

    Set-ReceiveConnector -identity “E2K13Server-01 Relay Connector” -MaxInboundConnectionPerSource unlimited

    and when i run the command to assign the permission for anonomus user it gives me the warning

    User or group "NT AUTHORITY\ANONYMOUS LOGON" wasn't found. Please make sure you've typed it correctly.

    + CategoryInfo          : InvalidData: (:) [Add-ADPermission], ManagementObjectNotFoundException

    any Help please


    Friday, February 10, 2017 5:33 PM
  • The command you're using doesn't look like it has the correct connector specification.

    Try:

    Get-ReceiveConnector "E2J13SERVER-01\E2K13Server-01 Relay Connector" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, February 11, 2017 2:27 AM
    Moderator
  • Hello,

    If the IP of this printer is 10.30.2.7, then we need add it into RemoteIPRanges.

    Once it down, you can use Telnet to check the communication between printer server and Exchange server. If it failed, post the error for further assistance.

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 13, 2017 9:52 AM
    Moderator