locked
Why does my Windows 7 insist on putting the Taskbar on one monitor and the desktop icons on another? RRS feed

  • Question

  • I am running a Dell 990 with Windows 7 Enterprise (x64), SP1, fully patched.  I have three monitors attached, one on the integrated GMA video on the motherboard, and two on an ATI Radeon HD 5450.  This configuration has worked well for me for about a year.

    Suddenly, for no reason I can determine, Windows decided to move my desktop icons to a different monitor, but the taskbar has remained where it always was.

    I have tried fiddling with the display settings.  The monitors identify properly, but if I select a different monitor and make it my main display, the taskbar and the icons move, all right - but they remain on *different* screens.

    I tried manually moving all my icons onto the same screen as the taskbar.  That lasted until the next time I logged out and logged back in, then the icons shifted back to where they had been.

    Anyone have any idea a) what caused this; b) how to fix it; and c) how to keep it from happening again?

    Monday, March 18, 2013 4:22 PM

Answers

  • Hi Bill,

    Thanks for the information,

    I have a thought, this might be caused by some application, can you please try in the clean boot and see if this issue is still there? Following are the detailed steps about clean boot:

    --------------------------------------



    1. Log on to the computer by
           using an account that has administrator rights.

    2. Click Start, type
           msconfig.exe in the Start Search box, and then press ENTER to start the
           System Configuration Utility.



    1. On the General tab, click
           Selective Startup, and then click to clear the Load startup items check
           box. (The Use Original Boot.ini check box is unavailable.)



    1. On the Services tab, click to
           select the Hide all Microsoft services check box, and then click Disable
           all.



    1. Click OK, Choose Don’t show
           this message again and then click Restart.



    1. Please check if the icons and taskbars are still having the same problem.

     

    If you want to start Windows normally after you do the test, Click Start, type
    msconfig.exe in the Start Search box, and then press ENTER to start the System
    Configuration Utility. On the General tab, click Normal Startup. Click OK,
    Choose Don’t show this message again and then click Restart. Please tell me if
    there is any error message



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by tracycai Friday, May 10, 2013 6:35 AM
    Wednesday, April 17, 2013 3:17 AM

All replies

  • Hi,

    Do you mean the only the taskbar moves to the primary screen but the icons move to another screen?

    Does it display normally when you choose "Show desktop only on 1 or 2"?

    You can unlock the taskbar by right-clicking and try to move it.
    http://windows.microsoft.com/en-us/windows7/work-and-play-better-with-multiple-monitors


    Tracy Cai
    TechNet Community Support

    Tuesday, March 19, 2013 2:27 AM
  • Hi!  Thanks for the reply.  Sorry, but this thing seems to be well and truly possessed by Murphy.  It does not always respond the same way to the same actions.  When I shift to a different screen as my primary monitor, it (usually) moves only the icons, not the taskbar.  Taskbar is *not* locked.  I don't know what you mean by choosing 'Show desktop only on 1 or 2'.  I cannot find such a setting anywhere.

    Example:  Monitors are, from left to right, 3-2-1.  Physical location of monitors and their representation in control panel are in agreement.  Currently, #3 is my main display.  It has the taskbar, #1 has the icons.  If I select #2 and make it my main display, the taskbar and icons both display on #3 - but if I reboot, they move to separate screens again.  Then I select #1 and make *it* my main display.  After I click 'apply', both the taskbar and the icons show up on #3.  Again, they won't stay there through a reboot.  If I select #3 and make it the main display, the icons show up on #1 and the taskbar on #3.

    Now, if I Lock the taskbar, whenever I select either #1 or #2 as the main display, both the icons and the taskbar show up on #3.  If I select #3 as the main display, the icons move to #1 and the taskbar stays on #3.

    A right rousing game of musical chairs, no?  It's starting to put me in mind of Abbott and Costello's 'Who's on First?'

    What I really want is to have both the icons and the taskbar on #2, and to stay there.  That's the way it worked happily for many months, but now I cannot get the icons onto #2 no matter what.  If I could stabilize this thing - icons and taskbar on the same screen, and hold that through a reboot - I would be happy to shuffle my screens by shifting cables.  But this is becoming a bad comedy.

    Tuesday, March 19, 2013 3:44 PM
  • Oh - it gets better.  With the taskbar locked, I got the taskbar and the icons to stabilize on #3.  OK, so far so good.  I powered the machine down, let it sit for a minute and rebooted.  When it came up, taskbar and icons were still on #3.  Hooray!  I swapped the monitor cables for #3 and #2, and adjusted the monitor positions in Control Panel so that my cursor moved correctly between all three screens.

    At that point, I had exactly what I wanted.  At this point, my screen layout was 2-3-1, from left to right.  The taskbar and icons were on #3, but that was now my center screen, just as I wanted.

    But, I just *had* to run one more test.  I powered down again.

    When I booted back up, the taskbar and icons had moved to #2 - now the leftmost screen.  At least they're together.  However, Control Panel tells me that #3 (now the center screen) is my main display.

    I swear, this thing is running the old shell game on me.

    Tuesday, March 19, 2013 4:03 PM
  • Just to clarify, have you tried dragging the taskbar back where you want
    it? You can actually drag it to different places (assuming it's not
    locked).

    Tuesday, March 19, 2013 9:48 PM
  • Yes, I have.  That was one of the first things I tried.  I was able to get the configuration I wanted, but the next time I rebooted, Windows put the icons and the taskbar on different screens again.
    Tuesday, March 19, 2013 11:21 PM
  • OK, now it's just messing with me.  Last night, when I logged out, icons and taskbar were on #2.  (Order is still 2-3-1, left to right.)  All I did was log out.

    This morning, when I logged in, taskbar and icons are on #3, the center screen.  The monitors still identify themselves in Control Panel as 2-3-1; that is, there was no mysterious re-numbering the screens, it's just that the taskbar and icons decided on their own to go walkabout.  Lord only knows where they'll be tomorrow.

    I wouldn't blame you guys if you thought I was pulling your leg, but I'm not.  We all have too much work to do.

    Wednesday, March 20, 2013 3:36 PM
  • Hi Bill,

    Please try the following action, this issue might occur if the “Auto Arrange Icons” option has been checked.

    1.     Right click on an empty space on the Desktop-> Click on View.

    2.     Uncheck the option “Auto Arrange Icons”.

    3.     Check the option for “Align the icons to grid”.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, March 22, 2013 9:12 AM
  • I doubt that is the issue.  I never keep 'Auto Arrange Icons' checked.  I just looked at it, and it was indeed Unchecked.  'Align Icons to Grid' was Unchecked.  I checked it, and all it did was tweak the spacing on my icons a bit.  Nothing moved to a different location or a different monitor.

    Thanks for thinking of me, though.

    Monday, March 25, 2013 5:02 PM
  • Hi Bill,

    Please check if you have installed the following Windows update, if not, please install it to update Win32k.sys.

    http://support.microsoft.com/kb/2618837

    After that please check if the issue is still there. is your system Windows 7 Enterprise? have you installed SP1 on it?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, March 28, 2013 9:08 AM
  • Hi!  Your reply was quite timely.  Although my system had been behaving for a few days, I just now had to reboot, and the problem came back.

    I looked through my installed patches, and 2618837 did not seem to be there, so I followed your link and requested the hotfix.  The link to download it should be showing up in my email shortly.

    Yes, my machine is Windows 7 Enterprise (x64), and SP1 is installed.  It should be patched up to date.

    I'll be back with a report after I install the hotfix.

    Thanks.

    Friday, March 29, 2013 9:08 PM
  • Sorry for the delay - I thought I had sent this earlier.  I installed that hotfix successfully, but it has not affected the problem.

    Interestingly enough, the behavior has changed slightly.  The hotfix *is* installed, and my taskbar *is* unlocked.  Now, when I select the left monitor as my main display, the taskbar and the icons both show up on the center screen.  If I select the right monitor as the main display - taskbar and icons both show up on center screen.  If I select the center screen as the main display, the taskbar shows up on the center screen, but the icons move to the right screen.

    I would give a cookie to know what's going on deep down inside there.

    At this point, it's more a point of curiosity than an impediment to my work, but I *am* curious.

    Tuesday, April 2, 2013 4:19 PM
  • Some of it sounds like the "hardware" or driver is firing up in different orders, and a monitor item is not "discovered" right away.
    a few things that possibly effect that. in the motherboard BIOS is usually a setting for which comes first the PEG/PCI , if dell allowed that to be adjustable you could set that.  in the video cards (own software) in the display section is sometimes "force" option for monitors and other possiblities via the video cards software.
    Isn't it true that having many icons on the desktop could be on any screen?  even if the "taskbar" is alway on the designated Primary?
    I use a good toolbars system to keep all icons off the desktop always, as i never could control desktop icon messes anyways, even with programs for doing that. toolbars can be organised , ordered and autohide out of the way entirely, even works good with dual monitors.
    • Edited by psycogeec Wednesday, April 3, 2013 7:18 AM
    Wednesday, April 3, 2013 7:14 AM
  • Thanks.  Those are good hints (BIOS, Video Driver S/W).  As for desktop arrangements, different tastes for different folks.  I prefer to have commonly-used icons up on the screen.
    Wednesday, April 3, 2013 4:42 PM
  • Well, I checked the BIOS.  Looks like the 990 has no setting for which video is initialized first.  In fact, the only setting was a single checkbox, 'check to enable Multi-Display' (which I have checked, since I'm using both the on-board video and a plug-in PCIe card).

    As for the video card software, ATI Catalyst Control Center does seem to have a way to set my main screen.  Since my system is actually behaving (for the moment), I'm not going to mess with it.  If / when the problem reoccurs, I will try experimenting with that.  (For the record, I have never touched that setting before.)

    At this point, my interest is mainly curiosity as to what could have been going on behind the scenes, first, to separate the icons and the taskbar like that, and secondly, to have them show up on different screens than the one Windows identifies as the primary.

    Thanks again for your time and your thoughts.

    Thursday, April 4, 2013 3:50 PM
  • Hi Bill,

    Thanks for the information,

    I have a thought, this might be caused by some application, can you please try in the clean boot and see if this issue is still there? Following are the detailed steps about clean boot:

    --------------------------------------



    1. Log on to the computer by
           using an account that has administrator rights.

    2. Click Start, type
           msconfig.exe in the Start Search box, and then press ENTER to start the
           System Configuration Utility.



    1. On the General tab, click
           Selective Startup, and then click to clear the Load startup items check
           box. (The Use Original Boot.ini check box is unavailable.)



    1. On the Services tab, click to
           select the Hide all Microsoft services check box, and then click Disable
           all.



    1. Click OK, Choose Don’t show
           this message again and then click Restart.



    1. Please check if the icons and taskbars are still having the same problem.

     

    If you want to start Windows normally after you do the test, Click Start, type
    msconfig.exe in the Start Search box, and then press ENTER to start the System
    Configuration Utility. On the General tab, click Normal Startup. Click OK,
    Choose Don’t show this message again and then click Restart. Please tell me if
    there is any error message



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by tracycai Friday, May 10, 2013 6:35 AM
    Wednesday, April 17, 2013 3:17 AM
  • Hi Bill,

    How are you?

    Could you please let us know if the issue is still there in clean boot? Thank you


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, April 19, 2013 7:50 AM
  • Hi.

    Please excuse my delay in responding - we're going through a security audit, and it's been busy.

    Lately, my machine has been behaving fine.  Taskbar and icons are where I expect them to be.  Without isolating the cause of this behavior, I suppose it could return.

    Monday, April 29, 2013 6:38 PM
  • That's fine, please feel free to let us know if you have any question.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, May 2, 2013 9:02 AM
  • Hi Bill,

    How is everything going?

    Just want to know if you still experiencing th same issue.

    Thanks


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, May 6, 2013 8:45 AM
  • I know it's been a little over one year, but this issue just happened to me today. A slight difference is that I am only using 2 monitors - my laptop plus one (V7) external monitor. Setting the V7 monitor (monitor 2) on the left, and my laptop  (monitor 1) as primary, I noticed that somehow the desktop icons were showing up only on monitor 2, while my tool bar showed up on monitor 1 (my primary). Normally, the tool bar AND the desktop icons show up on my primary (monitor 1).

    After some amount of setting/re-setting/re-starting and getting nowhere, I decided to just drag all the desktop icons over to monitor 1 from monitor 2. Low-and-behold, this fixed the issue. I did some more setting and re-setting of the monitors as a test, and the desktop icons stayed exactly where I had placed them - right there on monitor 1 (my primary) along with the tool bar.

    The best I can figure is that somehow, maybe while moving a window over to monitor 2, I or some system glitch inadvertently dragged my desktop icons over to monitor 2 as well and Windows 7 must have recorded this somewhere as a preference.  Hence whenever I reset or re-started things and then plugged into monitor 2, it "dutifully remembered" to place my desktop icons over there on monitor 2.

    Hope this can be helpful to anyone scratching their head over this.

     
    Friday, May 23, 2014 6:14 PM
  • Sorry - came into TechNet on another issue, noticed I had two 'unreads', that led me back here.

    Everything has been stable since my last post, but ironically enough, the problem just resurfaced two days ago.  I had remoted in to my PC (with 3 monitors) from home (where I have 2 monitors).  When I came back to the office and logged in, my icons were on the right screen, but my taskbar was still in the center.

    I poked at my display settings (shifting screen positions and selecting other screens as primary, then shifting back), and somewhere along the line, it got straightened out.

    *sigh*  Been on of *those* weeks.

    Thanks for listening, though.

    Thursday, August 21, 2014 10:50 PM