locked
SQL 2014 MP - Not discovering SQL servers RRS feed

  • Question

  • I am running SCOM 2012 R2 on Windows 2012 server. I have few SQL 2014 servers that need to be monitored by SCOM 2012. To achieve that, I imported required SQL MPs . See attached screen capture. Since this is a lab environment, I used the domain account (which is local admin on SQL servers to be discovered and monitored) to install the SCOM agents on the SQL servers. I am unable to discover a single SQL server in the SCOM 2012? Any ideas?

    Monday, September 28, 2015 4:48 PM

Answers

All replies

  • Are the servers being discovered in SCOM? (Check in Discovered Inventory, change the Target Type to Windows Server 2012 Computer). Are the agents healthy?

    "Fear disturbs your concentration"

    Monday, September 28, 2015 5:05 PM
  • No issues for server discovery. I can see all SQL servers in the agent managed device management and the agents are healthy, too!
    Monday, September 28, 2015 6:08 PM
  • That answers that question. Now, the next questions:

    Is the discovery for  "MSSQL 2014: Discover SQL Server 2014 DB Installation Source (seed)" enabled or are there overrides? Do you see any of this class in Discovered Inventory?

    Next check "MSSQL 2014: Discover SQL Server 2014 Database Engines" which is targeted at the seed class. 

    So on and so on....


    "Fear disturbs your concentration"

    Monday, September 28, 2015 7:10 PM
  • For SQL discovery, you need to check the following:

    1. Management Pack is correct. for example, if this server is SQL 2012SP1, check that this Management pack can monitor SQL 2012SP1.
    2. Verify that account used for monitor has permission to monitor SQL "sysadmin".
    3. Check firewall ports.
    4. Check that you add scom files and agent in exception from antivirus.

    Also you can refer below link

    http://blogs.technet.com/b/kevinholman/archive/2014/03/17/sql-mp-6-4-1-0-sql-2012-db-engine-group-does-not-contain-all-sql-servers.aspx


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer"Mai Ali | My blog: Technical | Twitter: Mai Ali

    • Proposed as answer by Elton_Ji Thursday, October 8, 2015 7:46 AM
    • Marked as answer by Elton_Ji Saturday, October 10, 2015 1:10 PM
    Tuesday, September 29, 2015 5:21 PM