locked
How to set a short delay between the screen saver and lock workstation RRS feed

  • Question

  • I asked this in the Group Policy forum (http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/b85162e2-dc37-41eb-b702-1062bb9b87ed) and apparently there's not a group policy setting to configure this, but I'm hoping someone knows of a registry value to do this?

    Our Group Policy is forcing the screensaver enabled with password protection (locking the workstation).  On Windows XP when the screensaver is turned on, if the user is there they have a couple seconds to move the mouse or press a key so the workstation doesn't lock.  On Windows 7 it doesn't seem like there's any delay, the workstation locks before the user has a chance to move the mouse or press a key.

    Anyone know of a registry value or some tweak to give the user 1 or 2 seconds to wake up the screen saver before it locks?

    Thanks!

    Tuesday, July 12, 2011 10:48 PM

Answers

  • Thank you for the info.  That almost works, but the value needs to be REG_SZ not REG_DWORD.

    Also this grace period doesn't work if Group Policy is setting a password protected screen saver but doesn't specify which screensaver.  If the screen saver is set to None the screen blanks but this delay doesn't work.  If the screensaver is set to Blank (or anything) then it works.

    Thanks

     

    • Marked as answer by Steve Lynch 2 Saturday, July 16, 2011 1:30 AM
    Saturday, July 16, 2011 1:30 AM
  • Hi,

     

    Please add the following registry to check the result.

     

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

     

    In the right pane, create a DWORD key: ScreenSaverGracePeriod, value: 0 to 255, the default is 5 seconds.

     

    More information

    http://technet.microsoft.com/en-us/library/cc785331(WS.10).aspx

     

    Here is a similar post for reference.

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/639e88eb-c9c3-4a8e-951e-4c6b5a852b6f/

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Steve Lynch 2 Saturday, July 16, 2011 1:30 AM
    Thursday, July 14, 2011 9:20 AM

All replies

  • Hi,

     

    Please add the following registry to check the result.

     

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

     

    In the right pane, create a DWORD key: ScreenSaverGracePeriod, value: 0 to 255, the default is 5 seconds.

     

    More information

    http://technet.microsoft.com/en-us/library/cc785331(WS.10).aspx

     

    Here is a similar post for reference.

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/639e88eb-c9c3-4a8e-951e-4c6b5a852b6f/

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Steve Lynch 2 Saturday, July 16, 2011 1:30 AM
    Thursday, July 14, 2011 9:20 AM
  • Thank you for the info.  That almost works, but the value needs to be REG_SZ not REG_DWORD.

    Also this grace period doesn't work if Group Policy is setting a password protected screen saver but doesn't specify which screensaver.  If the screen saver is set to None the screen blanks but this delay doesn't work.  If the screensaver is set to Blank (or anything) then it works.

    Thanks

     

    • Marked as answer by Steve Lynch 2 Saturday, July 16, 2011 1:30 AM
    Saturday, July 16, 2011 1:30 AM
  • Thank you for the info.  That almost works, but the value needs to be REG_SZ not REG_DWORD.

    Also this grace period doesn't work if Group Policy is setting a password protected screen saver but doesn't specify which screensaver.  If the screen saver is set to None the screen blanks but this delay doesn't work.  If the screensaver is set to Blank (or anything) then it works.

    Thanks

     


    Hello Steve,

    I have been trying to get this ScreenSaverGracePeriod setup in my enviroment but I have not had any success. Can you please explain your comments to me further?

    The Current GPO Settings in my enviroment:

    Enable Screen saver
    Password Protect the screen saver
    Screen saver timeout - 1200 seconds
    Force Specific screen saver - C:\Windows\System32\Mystify.scr

    If we have have "Force Specific screen saver" set in a GPO, does that mean the ScreenSaverGracePeriod registry setting will not work?

    I thank you in advance for your time.


    Jason
    Wednesday, September 7, 2011 4:21 PM
  • I don't know how else to explain it, this is a bug or side effect that others have noticed, I found it by searching.  If the force specific screen saver is not set, then the workstation control panel will show the screen saver as "None" and the delay doesn't seem to work.  But if I set the force specific screen saver to a valid file name, the delay started working.  Not sure what happens if it's forced to an invalid file, like if "C:\Windows\System32\Mystify.scr" doesn't exist.  You might try another file, or just a file name with no path.
    Wednesday, September 7, 2011 5:01 PM