locked
PAS - cannot login after installation RRS feed

  • Question

  • Hi there, have a frustrating issue here with PAS and not being able to use it after installation.... I have see other similar posts, like http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3064666&SiteID=17, and have followed all the instructions about using local admin, etc. probably 5 or 6 times, but it is still not working.

     

    I actually have 2 installs on different machines, both win2003, one works, one doesn't.  Cannot see any difference between the 2 machines at all, both were installed this week.  The server where it is working was just a test server laying around, so I want to get it working on our proper server.

     

    I am able to connect to the PAS server on the working machine through PAS on the non-working machine, so I know that the software is installed fine.

     

    All I ever see after cancelling the failing login is 'an error occurred retrieving the SDL file :503'.  I have also tried uninstalling IIS and reinstalling several times now, as local admin and domain admin, etc.  It didn't help.

     

    Any other ideas?


    Thanks,

    Craig

     

    Wednesday, April 2, 2008 4:31 AM

Answers

  •  

    There's a potential that the ASP.NET is not properly configured. Check to make sure that the ASP.NET v2.0 is allowed on the web server where PAS resides. You might also be facing an issue with application pool permissions - you might try setting ProClarity's app pool to Local System or a domain admin account with more rights. Yet another possible cause of the SDL error you're seeing could be troubles with ASP: Drop a sample ASP page into a new virtual directory and navigate to it in your browser to find out if ASP is working (an IIS reinstall may be in the next step if you're having ASP troubles).

     

    Regards,

     

    Brian Bishop

    Monday, April 7, 2008 3:27 PM

All replies

  • Hello Craig,

     

    Is the problematic machine a 64-bit OS?  If so you will need to follow these steps in order for the installation to proceed:

     

    (1) Install PAS as the machine's Local Administrator account (not a domain account with Admin rights, but the actual Administrator account for that machine).
    (2) Stop the IIS Admin Service (Administrative Tools / Services) immediately after the installation wizard completes
    (3) Run the following file: Inetpub\wwwroot\PAS\x64Extra\PInitx64.bat
    (4) Reboot and log back in as the machine's Local Administrator to allow necessary scripts to complete.

    This should allow all files and .dlls to register successfully.  Please let me know the outcome of your efforts. If you run into the same problem again please let me know and we'll see what we can figure out.

     

    Kind Regards,
    Amanda Ruffner

     

    Wednesday, April 2, 2008 2:34 PM
  • Hi Amanda, thanks for the reply.  No, it is running on 32bit on both machines.

    Thursday, April 3, 2008 9:24 PM
  •  

    There's a potential that the ASP.NET is not properly configured. Check to make sure that the ASP.NET v2.0 is allowed on the web server where PAS resides. You might also be facing an issue with application pool permissions - you might try setting ProClarity's app pool to Local System or a domain admin account with more rights. Yet another possible cause of the SDL error you're seeing could be troubles with ASP: Drop a sample ASP page into a new virtual directory and navigate to it in your browser to find out if ASP is working (an IIS reinstall may be in the next step if you're having ASP troubles).

     

    Regards,

     

    Brian Bishop

    Monday, April 7, 2008 3:27 PM