locked
RSAT x64 won't install RRS feed

  • Question

  • Hi all..

    I've installed the 64bit version of windows 7 on my system, and we are now also planning to use the Hyper-V virtualistation server.

    To manage this server, I want to install the Hyper-V manager MMC snap-in on my pc. I went and downloaded the correct file (amd64fre_GRMRSATX_MSU.msu) from the website, and tried to install it. The installation "looks" like all goes well, but it doesn't install any new features. You are supposed to get new options in the "turn windows features on/off", but nothing new appears.

    I then installed a x86 version of windows 7 on our spare test system, to see if I also got the problem there, but on this system, the update installed fine, with the expected new features to turn on.

    So, it looks like there is something wrong with the x64 version of the RSAT files...

    Anyone got a solution for this? I really need the x64 version, since my system has more than 4Gb of ram...
    • Moved by Ronnie VernonMVP Monday, October 12, 2009 8:29 AM Focus (From:Windows 7 Miscellaneous)
    Sunday, October 11, 2009 10:00 PM

All replies

  • Nobody else that has this problem? That's really hard to believe
    come on MS, please fix this...
    Monday, October 12, 2009 5:12 PM
  • I haven't seen this problem on Win7 x64 RTM.  Are you using the pre-release or the release version of the RSAT tools?  You can get the release version from: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d#filelist
    -Matt
    Monday, October 12, 2009 7:15 PM
  • That's the version i used...

    maybe another fresh install...
    Monday, October 12, 2009 10:33 PM
  • I suspect that the installation failed to add some components into Registry. Please follow the steps in the download webpage to remove RSAT. Then disable or uninstall the anti-virus and anti-spyware, reinstall RSAT again.
    Arthur Xie - MSFT
    Tuesday, October 13, 2009 8:26 AM
  • Although the installation says its completed, nothing appears, not in the installed updates list, nor in the add / remove windows features list. The event logs also states that the updates are installed correctly...

    Very strange, very strange indeed :)

    edit: reinstalled, but no solution yet... 32 bit only here... damn..
    • Edited by Sonic393 Tuesday, October 13, 2009 11:54 AM tried agian, no solution
    Tuesday, October 13, 2009 9:44 AM
  • Please disable the anti-virus and anti-spyware before installing the update.
    Arthur Xie - MSFT
    Wednesday, October 14, 2009 7:17 AM
  • I am having the same problem on multiple systems all 64bit.  32bit works as the instructions say - but 64 bit is exactly as Sonic states - says it installs successfully, but it doesn't add any features to turn on, nor does it show up in any way to remove it. 

    I also have NO antivirus on this system - fresh install from the technet x64 windows 7 ultimate.

    I too am in dire need to get RSAT on 64bit working.  What's the problem here?
    Thursday, October 15, 2009 3:50 PM
  • Maybe related Registry entries of the “Turn Windows Feature on or off” is corrupt. It should be resolved after you repair the system In-place Upgrade.
    Arthur Xie - MSFT
    Friday, October 16, 2009 9:30 AM
  • any luck with installing? I have the same problem with RSAT
    Monday, October 26, 2009 7:37 PM
  • I think only MS itself can solve this problem...
    Monday, October 26, 2009 8:05 PM
  • I found the solution to my problem.  I reinstalled win7 ontop of itself (using a fresh download of the win7 RTM from technet) and the install worked properly then.  Hope this helps anyone else suffering!
    Monday, October 26, 2009 8:51 PM
  • I doubt you are required to "re-download" the RTM, but I will give the re-install a try
    Monday, October 26, 2009 9:20 PM