none
RCDC Questions RRS feed

  • Question

  • Where to start?

    First, what editor to you use to edit these things?  When I export one out of FIM, then load it into Visual Studio, it's all one line.  So, to get it "pretty" formatted, I copy and paste that into a new XML file.  But, even if I immediately safe the pretty formatted file and try to reload it into FIM, I get an error at bottom of the RCDC page "There's an error in the <resourcetype> display configuration.  Please contact your system administrator".

    If I strip the whitespace and <cr><lf> from the file (turn it back into one line) I can import it and it works.  It FIM so sensitive to white spaces?

    Second, in reviewing the Resource Control Display Configuration XML Reference document, it seems as if modifying these things should be very simple.  All the references and the XSD make sense.  But, it's a crap shoot as to whether the changes are going to be taken by FIM or not.  Even modifying simple attributes like the height of a text box cause the error listed above.  I've had limited success in modifying these things and it's becoming quite frustrating.

    Thanks,

    Greg

    Wednesday, May 20, 2015 5:29 PM

Answers

  • Greg,

    When you export it, it saves it as XML. 

    1. Open with Notepad and you will see it is formatted properly.

    2. Select all and Copy. 

    3. Open visual Studio -> Create new project --> New XML File

    4. Delete the pre-populated text and Paste the text into the new XML

    5. Save the file back as xml, or copy and replace the edited text into the original file you exported

    6. Import XML file back into FIM

    P.S: No one said Notepad interfaces with FIM.  you still need to import back the file in XML format.

    Last, if you need help, loose your ego.  I cannot tell what you know and don't, I am trying to cover all the basics. 


    Nosh Mernacaj, Identity Management Specialist

    Wednesday, May 20, 2015 6:46 PM

All replies

  • 1. Editor, Visual Studio if you have it, Notepad or anything at hand.

    2. When  you export it and load it into Visual Studio, first save is as Notepad with WRAP TEXT option and then copy and paste into Visual Studio

    3. If you make changes you are not sure, it will make your life a living hell.  Yes Spaces matter too, depending where they are.

    4. In order to see the changes, you need to do an IISRESET after any change.


    Nosh Mernacaj, Identity Management Specialist

    Wednesday, May 20, 2015 6:16 PM
  • Nosh,

    I need some clarification on 2.  You're confusing me with "first save is as Notepad" as if that's some buried option in Visual Studio.  I'm using Visual Studio 2012 and working with the file as an XML file. 

    Are you saying to save the file IN notepad with wrap text on, then copy and past that file into Visual Studio?  If I paste the file into a Visual Studio XML file, it's going to format it.   It's that formatting that I think is causing my grief.  What is Notepad doing behind the scenes where that makes a difference.  I'm really curious about that. 

    I've been working with them in Notepad with a great deal of success.  A file saved from Notepad doesn't seem to interfere with FIM, no matter the white space (outside of the tags - i.e. beginning of line) or CRLF issues.

    It's a pain to locate things, but MUCH less painful when importing them.

    And, I'm good with the IISReset thing.

    And, thanks,

    Greg

    Wednesday, May 20, 2015 6:39 PM
  • Greg,

    When you export it, it saves it as XML. 

    1. Open with Notepad and you will see it is formatted properly.

    2. Select all and Copy. 

    3. Open visual Studio -> Create new project --> New XML File

    4. Delete the pre-populated text and Paste the text into the new XML

    5. Save the file back as xml, or copy and replace the edited text into the original file you exported

    6. Import XML file back into FIM

    P.S: No one said Notepad interfaces with FIM.  you still need to import back the file in XML format.

    Last, if you need help, loose your ego.  I cannot tell what you know and don't, I am trying to cover all the basics. 


    Nosh Mernacaj, Identity Management Specialist

    Wednesday, May 20, 2015 6:46 PM
  • Nosh,

    I understand.  I'm pretty good with IDM and the sync rules and such within FIM.  This FIM portal is something I'm not accustomed to.  It's all good.

    What you list out is almost exactly what I've been doing.  I get that error when I import the file that has been touched by VS.  I'm experimenting with that right now, and the XML file saved from VS is 2k larger than the notepad only version. 

    I'm still playing with this.  I hope I can make this work with VS.  I'd rather do that.  It's much easier to look at.  I'll go through your steps, verbatum, in a few minutes.

    Thanks,

    Greg

    Wednesday, May 20, 2015 6:58 PM
  • I know it is hard to spot the errors, because it will simply say you have an error but not point to it.

    Best thing is to start over with the original XML Export again and start from there.

    If you paste the XML here, I can probably see what's wrong.


    Nosh Mernacaj, Identity Management Specialist

    Wednesday, May 20, 2015 7:02 PM
  • Hi Greg, I've always used Visual Studio to modify RCDCs. You can select the one line of XML in VS and hit the Reformat Selection button in the XML Editor toolbar. I also find it useful to load the RCDC XSD schema into VS for IntelliSense support, etc.

    Cheers,

    Tom Houston, UK Identity Management Practice

    Wednesday, May 20, 2015 7:04 PM
  • Hey Nosh,

    I can't seem to make it break like it was before.  That open in Notepad step must be the kicker.  I was opening the XML exported file in VS.  Not sure why that makes a difference, but it does, apparently.

    I think I'm good for now.  Thanks.

    Wednesday, May 20, 2015 7:18 PM
  • Great

    Nosh Mernacaj, Identity Management Specialist

    Wednesday, May 20, 2015 7:19 PM
  • Hi Tom,

    I have the XSD loaded.  I wish it were more complete, but it's a start, I suppose.  I wasn't aware of the "Reformat Selection" option.  I'll have to look at that.  But, right now I'm able to import the RCDC "pretty" formatted without issue.  Has to be the "open in Notepad" option that Nosh mentioned.  Weird!

    Greg

    Wednesday, May 20, 2015 7:24 PM