none
SFTP Adapter does not retain settings, does not delete files RRS feed

  • Question

  • I am using BTS 2016 FP3, CU7 with WinSCP 5.15.9.0 .exe and .dll installed in the BizTalk root installation directory on my server.  The SFTP adapter is not deleting files after download.  I definitely have permissions to do delete files on the SFTP server.

    I have Retain After Download to False, which I understand should delete the file once I have downloaded it.

    Since this was NOT working, I changed Retain After Download to True, and set the Redownload Interval to -1.  Enable Timestamp Comparison remained set to False.  According to the documentation, this should have prevented the file from downloading again.  However, I could never actually test these settings, as the SFTP adapter would NOT retain them.  Of course, I am applying the changes as I should in the BT Admin Console.  I even tried restarting the host instance.  I even tried resetting the default SFTP Receive adapter settings found in Adapter in the Admin Console.  None of these maneuvers get the SFTP adapter configuration to retain the settings I am trying to apply. 

    I did see another post about being unable to delete files with the SFTP adapter, but it is unanswered and stale.

    I would greatly appreciate any help.


    Blankfiend

    Monday, May 25, 2020 9:27 PM

All replies

  • My question has been sitting out here for almost a week unanswered. 

    I have tried to use the latest version of WinSCP, with the appropriate update to the 32 bit config file, per the example at https://docs.microsoft.com/en-us/biztalk/core/sftp-adapter.  This did nothing other than stop all of my SFTP receive locations.  I have a $500 per year n-software subscription that works just fine, but I was hoping to get away from it with the upgrade to BTS 2016.

    Am I wasting my time here?  Is the SFTP adapter with BTS 2016 really just not up to par?  I would love some feedback on this issue, even if you don't have a definitive answer for me.

    Thanks.


    Blankfiend

    Saturday, May 30, 2020 3:14 AM

  • Does it retain the settings if you make changes on ports using other adapters?

    Have you tried setting the Log parameter to see if it logs any useful information?

    Have you run the latest version of BizTalk Health Monitor?   Recently it started making some suggestions about settings you need to change on the host instance that SFTP runs under.

    If all that gets nowhere you may had to raise a support ticket with Microsoft.

    Saturday, May 30, 2020 6:01 AM
  • Thanks for your suggestions Colin.  To answer your questions...

    I can change any parameters on the SFTP adapter configuration except those settings having to do with Polling.  Even there, I can change the Polling interval and the polling interval units.  And when I say change the settings, I really mean change them and have the changes persist.  I can "change" the Enable Timestamp Comparison, the Retain After Download, and the Redownload Interval setttings, the changes "persist" after I hit Apply on the SFTP Transport Properties dialog box, but after I hit either OK or Apply on the parent Receive Location properties box, the settings revert and my changes disappear for ONLY those three parameters.  These exact configuration problems occur for all four of the SFTP receive locations I have set up, which includes three different trading partners and their SFTP servers.

    Nothing to be found in the logs for the SFTP connections.

    BTHM is not giving me any clues either, using v4.3.

    I have updated WinScP to the latest version and made the appropriate changes to redirect bindings in the BTSSvcExe.config file, and that made no difference either.

    Perhaps the strangest thing of all...

    I have two instances of BTS 2016, one on a Windows 10 Pro laptop, developer edition, Feature Pack 3 (with CU7).  On this instance, I can change the SFTP adapter settings for all trading partners/receive locations and have my changes persist.  It is on my other instance, running on Windows Server 2016, enterprise edition, FP3 (with CU7), where I am having the problem. Both are set up with the exact same WinSCP versions and config file changes.  Other than the OS and the developer vs. enterprise edition, the only other difference I can identify is that I apparently have .NET 4.8 on my laptop, which BTHM screams about.  On the 2016 server, I have the 4.72 framework.

    Furthermore, I have another laptop with Windows 10 Pro, set up with BTS 2020 enterprise, the same WinSCP version, and, of course, .NET 4.8.  In this environment I have never had a problem with the configuring the SFTP adapters.

    Got to wonder if this is related to the .NET framework?  Have you heard of people using BTS 2016 successfully with the .Net 4.8 framework installed?

    Thanks again.

    • Edited by John Thay Sunday, May 31, 2020 5:43 PM More info added
    Sunday, May 31, 2020 5:30 PM
  • I've written a blog article BizTalk supported Microsoft .Net Frameworks & August 2019 Windows Updates where I keep track of it, from the various documentation, and Hardware and Software Requirements for BizTalk Server 2016 still has the highest as .NET Framework 4.7 (Starting with CU2)

    Having the wrong .NET version sometimes has absolutely no impact, but in some cases it has caused issues, including causing a Host Instance to crash and restart frequently.


    Tuesday, June 2, 2020 3:26 AM