none
Error on applying CU "Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]"

    Question

  • Hi All, I've been dealing a problem since last week. After i applied the CU it will not complete the upgrade. I always get an error when applying it "Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite].

    I've already done cleanup up the orphaned SQL DB, Webapplication and Alternate access mappings. But still the issue persist. 

    Does anyone encounter this issue?

    03/23/2018 16:20:33  5  WRN            Failed to add the service connection point for this farm
    03/23/2018 16:20:33  5  INF            Entering function StringResourceManager.GetResourceString
    03/23/2018 16:20:33  5  INF              Resource id to be retrieved is ServiceConnectionPointNotCreatedEventLog for language English (United States)
    03/23/2018 16:20:33  5  INF              Resource retrieved id ServiceConnectionPointNotCreatedEventLog is Unable to create a Service Connection Point in the current Active Directory domain. Verify that the SharePoint container exists in the current domain and that you have rights to write to it.
    03/23/2018 16:20:33  5  INF            Leaving function StringResourceManager.GetResourceString
    03/23/2018 16:20:33  5  WRN            Unable to create a Service Connection Point in the current Active Directory domain. Verify that the SharePoint container exists in the current domain and that you have rights to write to it.
    Microsoft.SharePoint.SPException: The object LDAP://CN=Microsoft SharePoint Products,CN=System,DC=as,DC=iom,DC=net doesn't exist in the directory.
       at Microsoft.SharePoint.Administration.SPServiceConnectionPoint.Ensure(String serviceBindingInformation)
       at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
    03/23/2018 16:20:53  5  INF            Entering function TaskCommon.TraceToPsconfigLogAndUpgradeManagerLog
    03/23/2018 16:20:53  5  INF              Not spawning off the upgrade job, but rather running upgrade synchronously by calling SPFarm.Local.Upgrade() for inplace upgrade
    03/23/2018 16:20:53  5  INF            Leaving function TaskCommon.TraceToPsconfigLogAndUpgradeManagerLog
    03/23/2018 16:23:47  5  INF            Entering function StringResourceManager.GetResourceString
    03/23/2018 16:23:47  5  INF              Resource id to be retrieved is UpgradePermLinkLabel for language English (United States)
    03/23/2018 16:23:47  5  INF              Resource retrieved id UpgradePermLinkLabel is Follow this link for more information about how to troubleshoot upgrade failures:
    03/23/2018 16:23:47  5  INF            Leaving function StringResourceManager.GetResourceString
    03/23/2018 16:24:01  5  ERR            Task upgrade has failed with an unknown exception 
    03/23/2018 16:24:01  5  ERR            Exception: Microsoft.SharePoint.Upgrade.SPUpgradeException: 
    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]. (EventID:ajxnf)

    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]. (EventID:ajxnf)

    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]. (EventID:ajxnf)

    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]. (EventID:ajxnf)

    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]. (EventID:ajxnf)

    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Cannot upgrade [Microsoft.SharePoint.Administration.SPIisWebSite]. (EventID:ajxnf)

    CanUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed. (EventID:ajxme)

    Exception: The system cannot find the path specified. (EventID:ajxme)

    (EventID:ajxme)

    Monday, March 26, 2018 3:15 AM

Answers

  • I've finally solved the issue by deleting an missing zones. 

    After i deleted it the upgrade successfully complete without any errors.

    Cheers...

    • Marked as answer by Sakuragi19 Monday, March 26, 2018 5:56 AM
    Monday, March 26, 2018 5:56 AM

All replies

  • I've finally solved the issue by deleting an missing zones. 

    After i deleted it the upgrade successfully complete without any errors.

    Cheers...

    • Marked as answer by Sakuragi19 Monday, March 26, 2018 5:56 AM
    Monday, March 26, 2018 5:56 AM
  • Hi,

    Thanks for your sharing.

    It would be helpful to those who meet the same issue.

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, March 26, 2018 10:18 AM
    Moderator
  • I've finally solved the issue by deleting an missing zones. 

    After i deleted it the upgrade successfully complete without any errors.

    Cheers...

    How do you find what to delete?

    I have the same error, and I can't understand what I must delete for fix this.

    Thursday, December 6, 2018 4:41 PM
  • I finaly find what is that.

    There is one of site in sharepoint, that haven't site in IIS.

    Just see all webapp in Admin center, look for which site in IIS they use, find one no exist  in IIS and delete them.

    Thursday, December 6, 2018 7:31 PM