locked
Adobe Flashplayer has stopped working in IE11 RRS feed

  • Question

  • Hi all,

    My IE11 does not want to Allow Adobe Flashplayer on webpages. I get the announcement on webpages that require Flash that "This web page wants to run the following add-on: 'Adobe Flash Player' from 'Microsoft Windows Third Party Application Compon...'." When I click "Allow" it reloads the page and the message is shown again and the flash still not working. Flash works perfectly in Firefox.

    This started to occur after this update had been installed "Security Update for Windows 8.1 x64-based Systems (KB3011780)".

    I have checked so that the add-on "Shockwave Flash Object" is enabled in the browser and that the Active X filtering is not "checked".

    Saturday, November 22, 2014 9:51 PM

Answers

  • Hi All,

    I find the cause to the issue. It was an application called "BankID" that in some way trash the flash ability in the desktop IE11. The solution to the problem was to go in under "Internet Options - Advanced" and check the "Enable 64-bit processes for Enhanced Protected Mode" setting. Probably has something to do with the encryption in the BankID application (its an app to identify youself on the internet) that corrupts something in the 32-bit flash used in IE11.

    Thanks for you help!

    • Marked as answer by Rangvald86 Monday, December 1, 2014 12:10 PM
    Monday, December 1, 2014 12:10 PM

All replies

  • Hi,

    thats badly programmed web pages. Tools>ActiveX Filtering to toggle ActiveX Filtering (aka. Flash Blocking).

    when asking internet related questions include full links to any website you are having problems with your questions.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    Sunday, November 23, 2014 3:40 AM
  • <EDIT>
    Is Adobe Flash Player v15.0.0.239 for Internet Explorer installed? TEST HERE USING INTERNET EXPLORER ONLY! => http://www.adobe.com/software/flash/about/
    </EDIT>

    Does the behavior persist if you uninstall KB3011780, reboot & then hide it (temporarily, at least)?

       • HOW TO Hide an Update or Restore a Hidden Update [good for Win8, too!]
         http://www.sevenforums.com/tutorials/24376-windows-update-hide-restore-hidden-updates.html

    =========================================
    You will find Consumer-specific support for Internet Explorer 11 in this forum: http://answers.microsoft.com/en-us/ie/forum/ie11-iewindows8_1


    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft



    Sunday, November 23, 2014 6:03 PM
  • Hi Rangvald86,

    Does this issue occur in all website or only single website?

    Do you mean that this issue occur after the update KB3011780?
    Please temporarily uninstall the update and check if this issue still exist.

    Here is a troubleshooter steps for Flash Player:
    1. Enable Flash Player
    2. Disable ActiveX Filtering
    3. Update Internet Explorer to get latest version of Flash Player

    For more information, please refer to the following thread similar to this issue.
    http://answers.microsoft.com/en-us/ie/forum/ie11-iewindows8_1/this-web-page-wants-to-run-the-following-add-on/42f22aa9-5a68-4ff8-a358-776e4174a101

    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support

    Tuesday, November 25, 2014 2:11 AM
  • Hi Chen,

    I have tested everything that has been suggested but it still do not work.

    I have:

    • Uninstalled the updates to see if it was caused by them but it seems to not be the case. But the fact still remains that it was after these updates it stopped working.
    • I have enabled and disabled the flash player.
    • Disabled ActiveX Filtering /Enabled ActiveX Filtering
    • I tried to update Internet Explorer but i says that it has already the newest version.
    • I tried to update through the Adobe site to get the newest flash player but same result as above, its already installed.

    The issue is occuring on any site that need flash to view videos or other content.

    And what happens is the following:

    • The video box is showing that I need to install Flash Player.
    • The message "This web page wants to run the following add-on: 'Adobe Flash Player' from 'Microsoft Windows Third Party Application Compon...'." is showed. And I does not matter if I press allow or allow all, it appears again after that the page has reloaded.

    It's working perfectly in Firefox! I have checed the event log but no luck there either. Any suggestion?

    Wednesday, November 26, 2014 6:16 PM
  • Hello Rangvald86,

    Do you use the Windows 8.1? Based on my test in my environment, I can’t find the same issue.

    Please take the following steps to register the flash.ocx file.
    1. Open the notepad and type regsvr32 c:\windows\system32\macromed\flash\flash.ocx
    2. Save it as flash.bat and run it as an administrator by right clicking on the file and select run as administrator.
    3. Open the website you were unable to open

    For more information, please refer to the following thread similar to this issue.
    http://answers.microsoft.com/en-us/ie/forum/ie11-iewindows8_1/flash-player-isnt-working-in-ie-11-windows-81/d44b2206-9902-4756-88ea-80124f6d756f?page=1


    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support

    Monday, December 1, 2014 8:22 AM
  • Hi All,

    I find the cause to the issue. It was an application called "BankID" that in some way trash the flash ability in the desktop IE11. The solution to the problem was to go in under "Internet Options - Advanced" and check the "Enable 64-bit processes for Enhanced Protected Mode" setting. Probably has something to do with the encryption in the BankID application (its an app to identify youself on the internet) that corrupts something in the 32-bit flash used in IE11.

    Thanks for you help!

    • Marked as answer by Rangvald86 Monday, December 1, 2014 12:10 PM
    Monday, December 1, 2014 12:10 PM
  • The solution to the problem was to go in under "Internet Options - Advanced" and check the "Enable 64-bit processes for Enhanced Protected Mode" setting [then restart the computer]

    cf. http://www.eightforums.com/tutorials/32024-internet-explorer-11-enable-64-bit-tab-processes-epm.html

    Name:  IE11_EPM_tabs-2.jpg
Views: 62531
Size:  102.1 KB


    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Monday, December 1, 2014 8:01 PM