locked
Static web pages causing "Unable to connect publishing custom string handler for output caching" event RRS feed

  • Question

  • Hi

    I have an SP2007 web application on the root of an IIS web site. I have added a new virtual directory of this web site within IIS pointing at a separate path that hosts flat html files. I am getting the error "Unable to connect publishing custom string handler for output caching" in the event log for the html and css files within this virtual directory.

    I have read other suggested solutions to this error but they concern custom web applications where the solution is to modify the web.config within the custom web application. However, in my case there is no web.config to modify.

    Is there an alternative solution to resoolve this event or am I breaching the SharePoint web model by adding a virtual directory in this manner.

    Many thanks

    Steve

    Thursday, September 22, 2011 9:21 AM

Answers

  • Hello,

    The Web.config file is specific to each Web application. Each Web application can have its own web.config file. Any sub directory of a Web application may have its own web.config file; this allows them to override the settings imposed by the parent directories.

    Try manually adding a web.config to the path listed in the Event ID Event ID 5785 most likely and removing the HTTP module info. Please dont change anything in SharePoint Web.config file.

    <httpModules>
    <remove name="PublishingHTTPModule"/>
    </httpModules>


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support
    • Marked as answer by Steven Howard Thursday, September 29, 2011 3:45 PM
    Thursday, September 29, 2011 11:43 AM
    Moderator

All replies

  • Hello,

    The Web.config file is specific to each Web application. Each Web application can have its own web.config file. Any sub directory of a Web application may have its own web.config file; this allows them to override the settings imposed by the parent directories.

    Try manually adding a web.config to the path listed in the Event ID Event ID 5785 most likely and removing the HTTP module info. Please dont change anything in SharePoint Web.config file.

    <httpModules>
    <remove name="PublishingHTTPModule"/>
    </httpModules>


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support
    • Marked as answer by Steven Howard Thursday, September 29, 2011 3:45 PM
    Thursday, September 29, 2011 11:43 AM
    Moderator
  • Hello Nishant.

    Marvellous and thank you. Your suggestion has worked and I am no longer getting those errors.

    Thanks again

    Steve

     

    Thursday, September 29, 2011 3:49 PM