locked
Disable Safe Mode GPO RRS feed

  • Question

  • Hi,

    I just wander, is it possible to disable access to Windows safe mode (for users and administrators) using GPO?

    Wednesday, October 9, 2019 1:41 PM

Answers

  • Fan

    This link is not related to my issue so I'm not sure why you sent it to me. Correct way to fix it is:

    bcdedit /deletevalue {current} recoverysequence
    bcdedit /set {bootmgr} bootems off
    bcdedit /set {bootmgr} advancedoptions off
    bcdedit /set {bootmgr} optionsedit off
    bcdedit /set {bootmgr} recoveryenabled off
    bcdedit /set {current} bootems off
    bcdedit /set {current} advancedoptions off
    bcdedit /set {current} optionsedit off
    bcdedit /set {current} bootstatuspolicy IgnoreAllFailures
    bcdedit /set {current} recoveryenabled off

    • Marked as answer by piotrkow Friday, October 11, 2019 9:36 AM
    Friday, October 11, 2019 9:36 AM

All replies

  • Hi,

    Based on my experience , a logon on script an be considered.

    For your reference:

    https://social.technet.microsoft.com/Forums/en-US/85418889-d518-424c-bc32-85b6a4b59e09/disable-safe-mode-on-all-computers-accross-the-network?forum=winserverGP

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, October 10, 2019 2:32 AM
  • Hi Fan,

    Thank you for your reply.

    The link which you sent me is related to Windows 7 not 10. Is command: bcdedit /set {bootmgr} displaybootmenu no working on Windows 10 as well?

    Thursday, October 10, 2019 7:56 AM
  • Hi,

    Yes , i test it in my environment as following screenshot:

    Did you run the command as administrator?

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, October 10, 2019 8:48 AM
  • Fan,

    It doesn't look this disables Safe Mode, it just prevent F8 key I believe. I've just set this on my laptop, the operation completed successfully but when I restart windows with "Shift" I can still select booting in Safe Mode. 

    Any Idea how to completely disable safe mode?

    Thursday, October 10, 2019 11:34 AM
  • Hi,

    Sorry for that didn't work for you .

    Third-party link for your reference:

    https://www.drivereasy.com/knowledge/how-to-exit-safe-mode-on-windows-10/

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 11, 2019 3:00 AM
  • Fan

    This link is not related to my issue so I'm not sure why you sent it to me. Correct way to fix it is:

    bcdedit /deletevalue {current} recoverysequence
    bcdedit /set {bootmgr} bootems off
    bcdedit /set {bootmgr} advancedoptions off
    bcdedit /set {bootmgr} optionsedit off
    bcdedit /set {bootmgr} recoveryenabled off
    bcdedit /set {current} bootems off
    bcdedit /set {current} advancedoptions off
    bcdedit /set {current} optionsedit off
    bcdedit /set {current} bootstatuspolicy IgnoreAllFailures
    bcdedit /set {current} recoveryenabled off

    • Marked as answer by piotrkow Friday, October 11, 2019 9:36 AM
    Friday, October 11, 2019 9:36 AM