locked
Cannot Access Term Set Using Web Service RRS feed

  • Question

  • Hi all,

    Having a bit of an urgent issue. Client needs this fixed by Monday and I am out of ideas.

    Using a custom Web Part that accesses the SocialDataService web service AddTagByKeyword method I am getting an error in Chrome Dev Tools seen below:

    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <soap:Body>
    <soap:Fault>
    <faultcode>soap:Server</faultcode>
    <faultstring>Server was unable to process request. ---> Keywords Term Set not available</faultstring>
    <detail />
    </soap:Fault>
    </soap:Body>
    </soap:Envelope>

    I have seen this using the same Web Part in other environments and just had to add the app pool account running the Web Application and Managed Metadata Service with Full Control permissions to get it to work. In this environment I tried the same to no avail. I tried adding the account to the Term Store as well, just to be sure, but still nothing. I also checked multiple times that the correct Managed Metadata Service app is being used for this Web Application and that the correct permissions are set.

    The below are also set for the "System" group "Keywords" term set:

    • Available for tagging: True
    • Submission Policy: Open

    Any help would be greatly appreciated!

    Thanks,

    J.

    Thursday, February 25, 2016 6:57 PM

Answers

  • A co-worker figured this one out. Had to do the following:

    • Open Central Admin
    • Go to Manage Service Applications
    • Select the Managed Metadata Service Application Proxy
    • Click "Properties" in the ribbon
    • Check "This service application is the default storage location for keywords."
    • Click "OK"

    Once this was done it immediately started working.

    • Marked as answer by Patrick_Liang Monday, February 29, 2016 2:28 AM
    Friday, February 26, 2016 10:27 PM