SSIS Foreach Loop Container - looping progress frozen after first file RRS feed

  • Question

  • I have an SSIS 2005 package migrated to SSIS 2008 BIDS ; in this package, I have a Foreach loop container, which reads text files from A to E, i.e. 5 files. 

    For some unknown reasons, when I run the package (in development mode, F5), just a black window flashes, and only the first of the files, i.e. file A is read. and the Foreach loop Container is yellow and frozen; and the loop does not proceed to file B or further; on the other hand I do not see any error in the Progress tab, while the package execution is complete! Even file A is not loaded into the final destination, but stops with my transformation (Fuzzy Lookup) inside the Foreach loop Container.

    I am using a Fuzzy Lookup transformation inside the Foreach loop container; I believe this works fine in SSIS 2005 (though haven't tried), but in SSIS 2008, I am not sure.

    For the Foreach loop Container, I have a user variable (MyVariable) whose scope is the SSIS package.  The connection manager for these 5 files, is tied to this variable from the  Connection String property : @[User::MyVariable]

    This is a part of Chapter 5 (Managing Control Flow)  in the Microsoft Press book on SSIS 2005.

    Any suggestion will be greatly appreciated.

    • Edited by sph1777 Friday, April 29, 2016 1:25 PM
    Friday, April 29, 2016 1:07 PM


  • Hi there:

    I think you need to enable logging and see what the step was/doing.

    Perhaps there is an error message behind the windows you do not see that needs to be acknowledged.

    If that does not help Try to remove package parts, use a simpler different file until you find the culprit.




    • Proposed as answer by Eric__Zhang Monday, May 2, 2016 6:35 AM
    • Marked as answer by Eric__Zhang Monday, May 9, 2016 2:22 AM
    Friday, April 29, 2016 3:27 PM