locked
Hyper-v 2012 Backup Essentials on Centos 6.5 RRS feed

  • Question

  • I am running Centos 6.5 (new install).

    I installed the Hyper-V Backup Essentials as below. However when performing an online backup with Symantec System Recovery 2013 on Windows 2012 Standard (NOT R2), the Centos 6.5 VM goes into saved state when running a backup. 

    My understanding is that I should be able to perform a live/online backup of a Centos 6.5 VM with the Hyper-V Backup Essentials installed, is this correct? Am I missing something? Thanks.

    https://github.com/LIS/backupessentials


    • Edited by DSITNYC Sunday, April 6, 2014 2:57 PM
    Sunday, April 6, 2014 2:55 PM

Answers

All replies

  • The live backup functionality requires Hyper-V 2012 R2.   Take a look at the documentation here:  http://technet.microsoft.com/en-us/library/dn531026.aspx.  In the row "Live Virtual Machine Backup" you will see that this is listed as being available only for 2012 R2.

    Michael Kelley, Lead Program Manager, Open Source Technology Center

    Sunday, April 6, 2014 8:07 PM
    Moderator
  • I tried to install the Hyper-V backup essentials on a Linux CentOS 6.5 virtual machine and it says that conflicts with the 6.3 Version of the Hyper-V module, how can i -force the installation to overwrite the file? bellow the error:

    root@virtualmachine [/LIS-backupessentials-4e3121f/hv/hv-rhel6.5/rpm]# ./install.sh -f
    Installing Hyper-v Backup Essentials
    Preparing...                ########################################### [100%]
            file /usr/sbin/hv_vss_daemon from install of microsoft-hyper-v-vss-rhel65.1.0-20140121.x86_64 conflicts with file from package microsoft-hyper-v-rhel63.3.5-20131212.x86_64
    Installing Hyper-V Backup Essentials failed, Exiting.

    Regards,

    Anastasis

    Thursday, August 14, 2014 10:10 AM
  • Did you try to install LIS 3.5 into your CentOS 6.5 Linux? CentOS 6.5 has LIS built-in to it, and you should NOT install LIS 3.5. It looks like maybe there's a leftover component of LIS 3.5 that is conflicting.

    Michael Kelley, Lead Program Manager, Open Source Technology Center

    Thursday, August 14, 2014 4:12 PM
    Moderator