locked
Compatibility view website issue RRS feed

  • Question

  • I have one end user who has two machines, one machine has IE 11 and the other is IE 9. when the end user goes to a certain website it opens that site directly into compatibility view. I have removed all compatibility view settings on the machine, verified that it is not in the browser emulation key but this one website still launches in compatibility view. once more it is on these machines meaning it affects all users who login to these two machines. I have looked in the GPO's and there is not there set to govern this.

    How do I fix these two machines so the website is removed/ no longer opening in compatibility view?

    Thursday, March 17, 2016 3:09 PM

Answers

  • I have one end user who has two machines, one machine has IE 11 and the other is IE 9. when the end user goes to a certain website it opens that site directly into compatibility view.

    Use the Developer Tools, Emulation tab (in IE11) and Network trace for clues.  Otherwise I would use ProcMon to try to understand what was happening.  With two otherwise identical traces it should be straightforward finding distinguishing factors.

    Good luck



    Robert Aldwinckle
    ---

    Thursday, March 17, 2016 7:41 PM
    Answerer
  • As Robert says, you can use the F12 devtools to help find out why it's doing that.

    F12 on Win10/Edge:


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Thursday, March 17, 2016 9:02 PM

All replies

  • I have one end user who has two machines, one machine has IE 11 and the other is IE 9. when the end user goes to a certain website it opens that site directly into compatibility view.

    Use the Developer Tools, Emulation tab (in IE11) and Network trace for clues.  Otherwise I would use ProcMon to try to understand what was happening.  With two otherwise identical traces it should be straightforward finding distinguishing factors.

    Good luck



    Robert Aldwinckle
    ---

    Thursday, March 17, 2016 7:41 PM
    Answerer
  • As Robert says, you can use the F12 devtools to help find out why it's doing that.

    F12 on Win10/Edge:


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Thursday, March 17, 2016 9:02 PM
  • This is it, but when we move the Document mode from 7 to edge it does not stay, how do I save the setting?
    Thursday, March 17, 2016 10:03 PM
  • This is it, but when we move the Document mode from 7 to edge it does not stay, how do I save the setting?

    if the Emulation tab in DevTools is showing "Via X-UA-Compatible HTTP Header", that means that the webserver itself is forcing that to happen, and the webserver sysadmin has control over it, not you. It also means that it wouldn't be limited to one user.

    What is the actual message shown on the Emulation tab for this page/site?


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Friday, March 18, 2016 8:05 AM
  • Everyone else who accesses this one site has the document mode set to edge(default) this one user, and only one, has the document mode set to 7.

    So what are my options for getting this fixed?

    Friday, March 18, 2016 2:35 PM
  • Using the dev tools, Emulation tab, (see the blue text directly under the documentMode dropdown)

    what does it say about HOW the emulation mode was determined...

    If possible post back with a screen shot of their dev tools Emulation tab.

    Regards.


    Rob^_^

    Saturday, March 19, 2016 2:15 AM
  • It says:

    Document Mode: 7 (default)

      Via local compatibility view settings

    Saturday, March 19, 2016 3:16 AM
  •   Via local compatibility view settings

    So try turning that off.  Alt-x b  (including the Microsoft ones)


    Robert Aldwinckle
    ---

    Saturday, March 19, 2016 3:49 AM
    Answerer
  • so when the end user is on the webpage have them use the keyboard keys alt+x+b?
    Saturday, March 19, 2016 4:07 AM
  • so when the end user is on the webpage have them use the keyboard keys alt+x+b?

    Alt+X+B will open up the configuration dialog for Change Compatibility View settings, where you can enable/disable the CV  features.

    (but you may have already tried that?)


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Saturday, March 19, 2016 9:37 AM
  • may have already tried that?

    Or is there a policy which could prevent users from seeing it and which would leave its setting at default, i.e. Microsoft's Compatibility View settings?


    Robert Aldwinckle
    ---

    Saturday, March 19, 2016 1:54 PM
    Answerer
  • I have already tried that and no this end user is not getting any special policy.

    This affects any user on the machine, this is not a user only set, whoever logs into the machine this website goes into this setting.

    Saturday, March 19, 2016 2:56 PM
  • This affects any user on the machine, this is not a user only set, whoever logs into the machine this website goes into this setting.

    So there is probably a global equivalent somehow. Another thing to be looking for using ProcMon. Best if you have two otherwise identical traces to compare to reduce the amount of inferencing that you need to do, e.g. just compare coarsely, look for a divergence in the traces and then find out why that happens.


    Robert Aldwinckle
    ---

    Saturday, March 19, 2016 5:13 PM
    Answerer
  • Or is there a policy which could prevent users from seeing it and which would leave its setting at default, i.e. Microsoft's Compatibility View settings?


    Robert Aldwinckle
    ---

    there are a couple of settings which can influence CV;

    Policy Path : Windows Components\Internet Explorer\Compatibility View
    Policy Setting Name :  Turn off Compatibility View
    Supported On :   At least Internet Explorer 8.0 
    Help Text :  This policy setting controls the Compatibility View feature which allows the user to fix website display problems that he or she may encounter while browsing.
    If you enable this policy setting the user cannot use the Compatibility View button or manage the Compatibility View sites list.
    If you disable or do not configure this policy setting the user can use the Compatibility View button and manage the Compatibility View sites list.

    Machine  Windows Components\Internet Explorer\Compatibility View
    - Registry:  HKLM\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation!DisableSiteListEditing
    User   Windows Components\Internet Explorer\Compatibility View
    - Registry:  HKCU\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation!DisableSiteListEditing


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Saturday, March 19, 2016 9:16 PM
  • Sorry it took me so long to reply, the user had the PC and I had no access... I looked at the registry and the local gpo settings, the registry does not have the browser emulation keys and the local GPO does not have it configured.
    Wednesday, March 23, 2016 3:59 PM