none
autodiscover failed with 0x80040413 RRS feed

  • Question

  • After an otherwise successful clean install of a SBS 2008 server , clients are continually prompted for a password by Outlook.

    What went wrong? When running test connection on the client get : autodiscover failed with 0x80040413

    feel I've tried every "solution" on the web but still happening.  Can anyone help?


    Lord of The Files.
    Tuesday, January 10, 2012 8:20 PM

Answers

  • Hi Justin

    "Certificate name validation failed."
    This is normal, because you are using a self signed certificate. On the Outlook Autodiscover check, you can activate the checkbox "Ignore Trust for SSL"

    "ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method."
    This is not really a problem, because autodiscover first tries to contact the DNS SRV redirect method, if that fails it tries to contact https://smtpdomain/autodiscover/autodiscover.xml and then https://autodiscover.smtpdomain/autodiscover/autodiscover.xml

    Please check http://support.microsoft.com/kb/940881/en-us for more information, and how to create a DNS SRV record.

    In your case I guess it was able to find autodiscover information using https://abc.co.nz/autodiscover/autodiscover.xml, that's the reason why you got the error "Host name abc.co.nz doesn't match any name found on the server certificate"

    What about the other internal url's like webservices and oab?
    On the outlook icon at the bottom right do a "CTRL + right click" and perform a "Test-E-mail AutoConfiguration". What entries do you have for
    - Availibility Service URL
    - OOF URL
    - OAB URL

    You can also check that using "Get-WebServicesVirtualDirectory | fl InternalUrl" and "Get-OabVirtualDirectory | fl InternalUrl"

    Regards
    Pano


    Pano Boschung, PageUp AG
    Friday, January 13, 2012 9:54 AM

All replies

  • Hi

    Please check that: http://technet.microsoft.com/en-us/library/bb232838(EXCHG.80).aspx

     

    Regards
    Pano


    Pano Boschung, PageUp AG
    Wednesday, January 11, 2012 10:56 AM
  • Thursday, January 12, 2012 2:29 AM
    Moderator
  • Pano

    Thanks for your suggestion.

    I followed the link and then on to http://technet.microsoft.com/en-us/library/bb201695(EXCHG.80).aspx

    I then executed the shell commands to configure autodiscover.

     -- the command to enable-outlookanwhere returned: 

    OulookAnywhere : The virtual directory 'Rpc' already exists under ....local/SBS Web Applications'.

     -- the commands for OAB and EWS returned:

    WARNING: The command completed successfully but no settings of ....(SBS Web Applications)' have been modified.

     

    The issue persists

    Justin

     


    Lord of The Files.
    Thursday, January 12, 2012 2:59 AM
  • Hi Justin

    Please check the AutodiscoverServiceInternalUri:
    Get-ClientAccessServer -Identity CAS_Server_Name | fl AutodiscoverServiceInternalUri

    If you get e.g. something like https://server.domain.local/autodiscover/autodiscover.xml, make sure that server.domain.local is part of the SAN of your certificate.

     

    Regards
    Pano 


    Pano Boschung, PageUp AG
    Thursday, January 12, 2012 9:35 AM
  • Try with this https://www.testexchangeconnectivity.com/ and see if you get any wrror.

    What kind of certificate are you using? Chek if your Outlook have got this one checked "only connect to proxy servers....". Uncheck that box and see if it still asks for the password.


    Raj
    Thursday, January 12, 2012 11:20 AM
  • Lisa

    Thanks for the link.  I executed the commands and rebooted the server. 

    first I used the netbios name of the server for the internal links, but then I got a certificate error because the name does not match , so then I used the external name mail.domain.co.nz and the certificate error went away, but the request for password keeps popping up.  

    Justin

     


    Lord of The Files.
    Thursday, January 12, 2012 12:01 PM
  • Pano

     

    yes the Get-ClientAccessServer -Identity CAS_Server_Name | fl AutodiscoverServiceInternalUri gives me exactly what i expect.

     

    Justin


    Lord of The Files.
    Thursday, January 12, 2012 12:02 PM
  • And does the certificate you are using on this website include this url?

    Pano


    Pano Boschung, PageUp AG
    Thursday, January 12, 2012 12:05 PM
  • Pano

    Thanks Again.

    the Get-ClientAccessServer -Identity CAS_Server_Name | fl AutodiscoverServiceInternalUri returns:

    AutoDiscoverServiceInternalUri : https://mail.abc.co.nz/autodiscover/autodiscover.xml 

    The certificate is self issued for mail.abc.co.nz

    the SAN contains

     

    DNS Name=abc.co.nz

    DNS Name=mail.abc.co.nz

    DNS Name=ABCNT8DC01.abc.local

     

    mail.abc.co.nz points to the server's public ip address.

    the internal domain name is abc.local

    an entry in dns for mail.abc.co.nz points to the server abcnt8dc01.abc.local

     

    I have also done the test exchange connectivity test as suggested by Raj.

    one of the results says.

    Validating the certificate name.

      Certificate name validation failed.

      Tell me more about this issue and how to resolve it

      additional Details

      Host name abc.co.nz doesn't match any name found on the server certificate 

    WHY does it say host name abc.co.nz (as in testuser@abc.co.nz) to me abc.co.nz is a domain name and mail.abc.co.nz is the hostname

    and another one:
     Attempting to contact the Autodiscover service using the DNS SRV redirect method.

      ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.

      Test Steps

      Attempting to locate SRV record _autodiscover._tcp.abc.co.nz in DNS.

      The Autodiscover SRV record wasn't found in DNS.

      Tell me more about this issue and how to resolve it

    External webmail and iphones work fine. It's only Outlook used internally which has the pasword problem.
    Justin


    Lord of The Files.
    Friday, January 13, 2012 4:03 AM
  • Hi Justin

    "Certificate name validation failed."
    This is normal, because you are using a self signed certificate. On the Outlook Autodiscover check, you can activate the checkbox "Ignore Trust for SSL"

    "ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method."
    This is not really a problem, because autodiscover first tries to contact the DNS SRV redirect method, if that fails it tries to contact https://smtpdomain/autodiscover/autodiscover.xml and then https://autodiscover.smtpdomain/autodiscover/autodiscover.xml

    Please check http://support.microsoft.com/kb/940881/en-us for more information, and how to create a DNS SRV record.

    In your case I guess it was able to find autodiscover information using https://abc.co.nz/autodiscover/autodiscover.xml, that's the reason why you got the error "Host name abc.co.nz doesn't match any name found on the server certificate"

    What about the other internal url's like webservices and oab?
    On the outlook icon at the bottom right do a "CTRL + right click" and perform a "Test-E-mail AutoConfiguration". What entries do you have for
    - Availibility Service URL
    - OOF URL
    - OAB URL

    You can also check that using "Get-WebServicesVirtualDirectory | fl InternalUrl" and "Get-OabVirtualDirectory | fl InternalUrl"

    Regards
    Pano


    Pano Boschung, PageUp AG
    Friday, January 13, 2012 9:54 AM