locked
skype for business " EWS not deployed" RRS feed

  • Question

  • Hello

    I have SFB 2015 environment with SFB 2016 client and 2010 exchange.  where ews and autodiscover are published through TMG 2010.  we are not using FBA on listener for  TMG and rules are setup as "no delegation but client may authenticate directly)  .  Also autodisover and ews are setup for ntlm first and then negotiate on exchange IIS. But when external user trys to login to sfb client from outside they are getting ews not deployed.  Or if they are logged in to vpn and disconnect they get a authentication prompt.  also sometimes when they are login from outside they also get exchange prompt on sfb client. 

    also internally sfb works fine with ews and autodiscover they don't go through TMG for autodiscover but goes to Load balancer and then exchange directly

    On TMG, I see that 401 unauthorized for autodiscover.xml and autodiscover.svc

    interestingly outlook works fine without vpn via TMG.  so ews is accessible from outside without any issue

    any thoughts.. why externally ews is not working for sfb

     


    • Edited by mod 13 Monday, May 1, 2017 4:04 PM
    Monday, May 1, 2017 4:03 PM

Answers

All replies

  • Hi mod13,

    Based on your description, did you mean when you use SFB client internally, there is no error with EWS, “EWS not deployed” only happen to external access, is that right?
    Did the issue appeared on the specific client or all clients had this issue?

    Please check if you create the autodiscover records for EWS on your external DNS:
    autodiscover.domain.com (CNAME pointing to your Exchange external FQDN)
    _autodiscover._tcp.domain.com (SRV for 443 pointing to your Exchange external FQDN)

    Moreover, the following blog is for your reference
    http://www.b4z.co.uk/lync-2013-ews-with-forefront-tmg-2010-issues.html

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 2, 2017 5:56 AM
  • hello

    yes DNS is setup correctly.  I found following and I  will be adding .svc module on iis.

    https://refikunver.wordpress.com/2014/07/18/solution-http-405-error-lync-client-ews-not-enabled-no-meeting-icon-on-lync-client/


    This fixed my issue.

    • Marked as answer by mod 13 Thursday, May 4, 2017 3:15 PM
    • Edited by mod 13 Thursday, May 4, 2017 3:16 PM
    Tuesday, May 2, 2017 4:05 PM
  • Hi mod,

    Thanks for your response and mark your reply as answer, it will help others who have the similar issue.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 5, 2017 5:51 AM