WS-Management Error during Discovering AIX Agent


  • Hi Team,

    we are in the process of monitoring the AIX Agent thro SCOm R2 and we are getting the below error during the installation.

    It has discoverd the Agent, faild to install the agent on AIX Server.

    WS-Management could not connect to the specified destination: (



    • Moved by Hengzhe Li Wednesday, October 26, 2011 9:00 PM move to new forum (From:Cross Platform Solutions for System Center)
    Wednesday, September 22, 2010 11:55 AM


All replies

  • Interesting, we are having the same issue with few of our servers running Solaris 10.

    Have you installed the CU2 ?



    Wednesday, September 22, 2010 3:03 PM
  • Sorry I think we have missed this thread. Do you still have the issue?

    There are a number of troubleshooting techniques around agents installation detailed in this article (and following ones) that might help you

    • Marked as answer by Robert_Hearn Friday, December 3, 2010 6:10 PM
    Friday, October 22, 2010 3:39 PM
  • Hi Nachiappan M and Mathieu.

    We had the same issue with AIX 6.3.

    Searching we've found a workaround:

    When this KB is applied, it causes the WS-Management connections to UNIX/Linux agents to fail.

    We have followed the registry editing approach but we are not happy to disable a security fix.

    You'll find a lot of information about WS-Management connections issues if you search for this KB (KB2585542).

    I haven't find, however, a definitive solution for this.

    Wednesday, September 25, 2013 1:50 PM
  • Latest update fixes this issue for SCOM 2007 R2 without having to edit the registry to disable the security fix.

    Have you applied it?



    Wednesday, September 25, 2013 2:58 PM
  • Steve,

    We are using SCOM 2012 SP1.

    Is there a fix for this version as well?


    Eduardo Aguiar

    Wednesday, September 25, 2013 4:27 PM
  • Eduardo,

    It was fixed for 2012 SP1 and should not be a problem in that version without any patches.


    Wednesday, September 25, 2013 4:42 PM
  • Hi Steve.

    Unfortunately we are having this issue with SCOM 2012 SP1 and the workaround has worked. As I sad I haven't found any information about a definitive solutuon.

    Here you'll find some other people with a similar issue (it's Linux, not AIX) with SCOM 2012:



    Thanks for your help.

    Eduardo Aguiar

    Wednesday, September 25, 2013 7:16 PM
  • Eduardo,

    Couple things here, both the links you list are for OM 2012 which had the issue and the workaround provided resolved the issue but the latest CUs for OM 2012 fixes the issue as well and does not require the removal of the KB patch or the registry edit. For OM 2012 SP1 this was fixed and worked with the KB patch applied and no registry edits out of the box.

    Having said this, I went ahead and built out a new Windows server 2008 R2 with the latest patches available (KB2585542 included and no modifications to the registry) and installed the RTM version of OM 2012 SP1. I had no issues discovering and managing AIX 5.3, 6.1 or Linux once I installed the management packs.

    For your issue we believe it may have something to do with the ciphers the AIX server is trying to negotiate by default. Did you have other systems discovered and managed prior to applying the registry edit? Can you provide your SCOM environment so I can compare it to what I'm testing with? Do you have the exact error that was generated when it failed to discovery/manage the AIX 6.3 system?



    Thursday, September 26, 2013 6:11 PM
  • Steve, first of all, thanks for your time.

    I've removed the registry entry (i.e. I reactivated the KB) and removed the AIX machine from SCOM.

    When I readded it to the SCOM, the discovery and the agent installation ocurred with no issues.

    Then I added a new AIX machine to the SCOM and the discovery and the agent installation ocurred with no issues as well.

    I can't say why this didn't work at the beginning, but it's working now.

    I'll report any news here if I have other issues about this.


    Eduardo Aguiar

    Tuesday, October 1, 2013 2:58 PM