locked
Page not reflecting using variation RRS feed

  • Question

  • MOSS 2007.

    Hi,

    I have created two sites, one in English and the other in Arabic(Source) using Variations. But whenever I create a page in the Arabic site, it does not reflect in the English Site. I see the following failure message in the Variation logs.

    A new page did not get created under Label English by the variation system for source page http://server1:81/Arabic/AboutUs/Pages/VariationTest.aspx. The formula refers to a column that does not exist. Check the formula for spelling mistakes or change the non-existing column to an existing column.

    Also If I create a publishing subsite inside the Arabic(Source) site, it reflects properly inside the English site. It is only when I am creating the page inside the Arabic site that I get this problem and it does not reflect inside the English site.

    Please advice.

    • Edited by Mike Walsh FIN Tuesday, March 8, 2011 6:38 AM Also paragraph taken from next post from same poster ca one hour later. In such cases where there are no replies EDIT your first post. MOSS 2007 default write in text not title
    • Moved by Mike Walsh FIN Tuesday, March 8, 2011 6:39 AM admin q not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, March 8, 2011 4:47 AM

Answers

  • I had added them manually but was not able to resolve it. But the problem was with the custom columns itself. I think since the site was restored, the custom columns with calculated values was not reflecting properly. Even adding them manually was not fixing the issue. In the end when I deleted these Custom columns from both the Arabic as well as the English site, the pages started to work properly and the variation was not breaking and was able to fix the issue.

    • Marked as answer by Raj190 Thursday, March 10, 2011 11:11 AM
    Thursday, March 10, 2011 11:10 AM

All replies

  • seems like there is a problem with some customizations, because OTB Publishing site is propagated successfully. Do you use custom page layout/page content type when you create you page under Arabic site, or you use OTB page layout and OTB page content type (e.g. Welcome page)? If you use custom content type for the page - check all fields in it and see what columns have calculated type. Check what another fields are referenced from their formulas and ensure that all of them exist on the variation English site (Site settings > Site columns).
    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Tuesday, March 8, 2011 1:31 PM
  • Hi,

    Yes we are using custom page layout/page content type while creating the page under Arabic site and I see a few columns that are present inside a content type on the Arabic site with some calculated values which are not present on the English site. Should I manually add these columns on our English site?

    Also we had this site working on our production environment and we have restored it to our development environment and that is when this issue has come. Do these columns have to be added manually while restoring?

    Thanks.

    Wednesday, March 9, 2011 8:26 AM
  • yes try to add them manually

    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Thursday, March 10, 2011 10:53 AM
  • I had added them manually but was not able to resolve it. But the problem was with the custom columns itself. I think since the site was restored, the custom columns with calculated values was not reflecting properly. Even adding them manually was not fixing the issue. In the end when I deleted these Custom columns from both the Arabic as well as the English site, the pages started to work properly and the variation was not breaking and was able to fix the issue.

    • Marked as answer by Raj190 Thursday, March 10, 2011 11:11 AM
    Thursday, March 10, 2011 11:10 AM