Integration services cannot upgrade HAL RRS feed

  • Question

  • HI,

    We migrated a SBS 2k3 to a virtual machine (host is windows 2k8 sp2 with Hyper-v) using disk2vhd.

    We checked the update hal checkmark, but now we are running into a problem. The disk2vhd placed a virtual server hal in the VHD. As soon as we try to insert the integration services disk it keeps saying it has to update the hal and needs a reboot.

    We say ok, it says it is updateing the Hal, it reboots and then comes again with the same message that it needs to update the hal. So we are in a loop.

    Anyone familiar with this problem?

    I was able to recreate the problem with a windows xp machine too.

    Best regards,


    Tuesday, November 2, 2010 11:05 AM

All replies

  • If you’re running SBS 2003 on Hyper-V then you should be aware that this is not a supported configuratio.

    To change the HAL try the following... Note that you may need to back up the system so that you can restore it if it cannot boot after changing the HAL (the snapshots of virtual machine may be of help).

    1.    Click Device Manager.

    2.    Expand the Computer icon.

    3.    Right click on the value listed under Computer (either ACPI multiprocessor or MPS multiprocessor) and select Properties.

    4.    Click the Driver tab and then Update Driver.

    5.    Follow the wizard by selecting Next and then under "What do you want the Wizard to do?", choose "Display a list of known drivers for this device" and then NEXT.

    6.    Here is the important step:  if you currently have an ACPI Multiprocessor PC, choose ACPI Uniprocessor PC. If you have MPS Multiprocessor PC, choose MPS Uniprocessor PC. This is critical, make certain you choose correctly.

    7.    After selecting the correct HAL, follow the rest of the wizard to install the driver. When prompted to reboot, shut the machine completely down.

    8.    Reboot the computer. Go into Device Manager and see if the correct HAL is loaded.

    • Marked as answer by Vincent Hu Wednesday, November 10, 2010 6:39 AM
    • Unmarked as answer by Button Wednesday, November 17, 2010 4:30 PM
    Tuesday, November 2, 2010 7:42 PM
  • ·         Hi,


    Have you tried the suggestion? I want to see if the information provided was helpful. Your feedback is very useful for the further research. Please feel free to let me know if you have addition questions.



    Best regards,

    Vincent Hu

    Tuesday, November 9, 2010 5:31 AM
  • HI,

    We tried the suggestion, there are no options as mentioned above (just acpi and standard pc) Tried to chnage them, but it does not work.

    Server reboots, integration services tries to change Hal again, but it keeps starting with the virtual server HAL insted of the Hyper-V hal.

    So still no solution.

    Best regards,

    Henry Knoop

    Wednesday, November 10, 2010 2:46 PM
  • Hi henery,

    Please check MS  KB http://support.microsoft.com/kb/309283

    There is a way to manually replace the HAL. See Ben Armstrong's blog: http://blogs.msdn.com/virtual_pc_guy/archive/2004/12/16/316643.aspx


    Also check this thread


    Wednesday, November 10, 2010 3:56 PM
  • Also check


    Friday, November 12, 2010 1:54 PM
  • Hi all,

    None of the solutions is working, i even tried a repair install of the sbs machine (XP doesn't offer the repair option) but no go.

    For you who want to give it a try, it is very easy reproducable.

    Take a xp or SBS machine, no virtualisation services or anything installed.
    Use disk2vhd to make a vhd, and check the box "prepare for use in virtual pc"

    Then mount the vhd, and try to install the hyper-v integration services.

    If you crete the VHD without the box checked, it works like a charm. But i have a production SBS server which a;ready running a couple of weeks, so i can't revert back to the original machine to recreate the vhd.

    A solution would be very welcome as we are impaired in the use of the virtual machine.



    Tuesday, November 16, 2010 3:49 PM
  • Hi everybody. I had the same Problem.

    You need to use msconfig.exe and go to boot.ini. In my case, there were two boot entries of my server2003 installation. The one with disk2vhd at the start was on top. Change it to the normal server2003 boot path and reboot the machine. Now try to install the integration service again reboot and it will work.

    greetings Payne80

    • Proposed as answer by M Fawzi Monday, January 17, 2011 5:41 PM
    Tuesday, December 14, 2010 7:49 AM
  • Payne80 ->  You are a genius.  I experienced the same issue and your fix had me up and running in minutes. 

    Thank you so kindly!

    • Proposed as answer by Anchor Dave Monday, January 16, 2012 2:42 AM
    • Unproposed as answer by Anchor Dave Monday, January 16, 2012 2:42 AM
    Monday, January 17, 2011 5:34 PM
  • Amazing!!! - I searched it everywhere - actually came to this forum but did not read till end - It would be great if the proposed answers are displayed first.. anyway - Thank you so much!!!
    Thursday, February 17, 2011 5:47 PM
  • Same issue.

    I am using Disk2vhd v1.63 which talks about hyper-v on the sysinternals website many times, why does it create Windows 2003 VHD's which dont work without this work around.. very odd.

    Tuesday, October 18, 2011 3:48 PM
  • Great !! It worked for me !!

    Thank you

    Sunday, October 23, 2011 12:35 AM
  • Thanks Payne80 worked for me as well!!


    I actually ended up editing the boot.ini file manually as if I did it through msconfig I always ended up starting up in Selective Startup mode.


    Wednesday, November 2, 2011 5:32 AM
  • Thank's payne80!

    The same issue on Windows XP SP3 it work's....




    Tuesday, December 20, 2011 12:31 AM
  • Payne80 Thank you

    migrated a server 2003 VMware machine to hyper-v using disk2vhd and wasted hours until I found this

    David Jackson MCSE etc etc http://www.anchor-solutions.com
    Monday, January 16, 2012 2:44 AM
  • Thank you!

    It is working!


    Monday, April 23, 2012 3:45 PM
  • Thanks Payne80, this was really helpful.
    Friday, May 25, 2012 2:41 PM
  • Thanks Look everywhere for this answer. 2 hours later. Well Done.

    Saturday, July 14, 2012 6:23 AM
  • Excellent - thanks Payne

    Thursday, September 13, 2012 6:50 PM
  • Hi everybody. I had the same Problem.

    You need to use msconfig.exe and go to boot.ini. In my case, there were two boot entries of my server2003 installation. The one with disk2vhd at the start was on top. Change it to the normal server2003 boot path and reboot the machine. Now try to install the integration service again reboot and it will work.

    greetings Payne80

    Dude youre AWESOME!, this solved my issue thanks a lot!
    Saturday, October 13, 2012 6:22 PM

    I was just testing migrating in an XP SP3 Disk2VHD image to a test Win 8 Pro Hyper-V install - we're finally replacing several XP machines, but peoples' installations are highly customized and will need to have their physical installs converted in this way when the new hardware comes in.  Was seeing the 'install integration services' loop for maybe 30 mins until I stumbled upon this thread...


    Friday, November 16, 2012 8:35 PM
  • Yup.. Did the trick for me also. Saved me 30 min of frustration!

    Just changed it so it defaults to the non disk2vhd system

    Sunday, April 21, 2013 7:41 PM
  • AWESOME StUFF Payne80!! Works like a charm!
    Thursday, August 29, 2013 9:14 AM
  • I just did the disk2vhd method converting a server 2003r2 and same issue; it was playing HAL reboot until I found this solution. Thanks Payne80 for sticking this out there. I do like others find it odd that Diskinternals make the non-functioning boot option the default... oh well ..

    Yours Truly Online, Uli the Maui Tech Guru Helping people with computers in Maui Hawaii.

    Thursday, March 27, 2014 5:13 AM
  • .. there were two boot entries ... The one with disk2vhd at the start was on top. Change it to the normal ..

    This also works for an XP Mode virtual machine moved from Windows 7 to Windows 8.x when you have used Disk2vhd to create a cleaned up VHD to move.

    After the necessary re-registration, go to This Computer, Properties, Advanced, Start/Boot and Restore, and click Settings (above error reporting) to open Start/Boot and Restore.
    Under System Boot, change the selection from "Disk2vhd .. " to "Microsoft Windows XP Professional".

    Gustav Brock

    Monday, May 19, 2014 10:03 AM
  • this issue is  caused by not selecting the original system boot from start-up

    Don't select Disk2VHD Windows 2003 Server

    Just select the normal one below and I find it works fine

    Tuesday, February 17, 2015 2:39 PM
  • Awesome mate Thank you!!!
    Wednesday, April 8, 2015 5:55 PM
  • Hi Payne,

    I have converted a VM from ESXi 6.0 to .VHD and mouse actions were not working.

    Installed Hyper-V integration services and tried booting from "Normal boot path" and rebooted.

    But still the same issue going on. Mouse is not working through "mstsc".

    There is no option HAL option under MSCONFIG. Mine's running Win 2003 server SP2.

    Kindly advice.


    Tuesday, June 30, 2015 8:06 AM
  • Hey buddy, just change the boot order

    control panel, system, advanced tab, <g class="gr_ gr_15 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="15" id="15">starturp</g> and repair click on settings, select the different option of "Disk2VHD" <g class="gr_ gr_16 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="16" id="16">sometting</g> like "Windows 2003" or Windows XP".

    click ok, and restart the VM.



    • Edited by Nathan Elias Wednesday, November 16, 2016 4:56 AM
    Wednesday, November 16, 2016 4:54 AM
  • I love You! After 3 Days of messing with this... IT's WORKING within Minutes.
    Friday, February 3, 2017 11:29 PM