locked
Problems with migrating 4.6 packages to 5.0 RRS feed

  • Question

  • I have lot of 4.6 (SP3) packages which needs to be migrated to 5.0 SP2 platform(SCCM). I tried convert and install 4 different generic packages:

    Paint.net - OK, runs fine
    Chrome OLD - fail (depency to Java)
    Chrome NEW - fail (depency to Java)
    Java - OK, runs fine
    Reader OLD - fail (not compliant to existing OS, probably packaged on XP)

    Problem with Chromes are that shortcuts do not appear anywhere, but the package is installed via SCCM. Reader is failed already during convertion to 5.0 SP2, because Sequencer machine is W7. I converted all packages with Powershell, seems to be the only way.

    Main problem is, that after convertion to 5.0, I tried to open Chrome with Sequencer to delete depency to Java, and sequencer fails to open the converted package. So I´m thinking, should I continue to evaluate packages one By one, and are these problems because of depencies or something else?

    Error while opening converted package with Sequecer: ID 5010, "An Attempt to prepare the package for editing failed, class not registered. HRESULT 0x80040154.


    Thursday, July 3, 2014 7:04 PM

Answers

  • I have not heard of issues opening the packages but either way, I'm not sure deleting the Java files from the package would be the best path forward.

    I believe the conversion tool has been a complaint by many. The consensus seemed to be re-sequencing applications was the most reliable method to use.

    Personally, I'd try converting, test. If it doesn't work I open up my recipe and re-sequence.

    Re: Java, if I was you I'd read this series of posts from Dan: http://packageology.com/2014/02/sequencing-java-the-definitive-guide-part-1/

    My personal preference is to keep the latest version of Java on my build as a local app and sequence an older version only when a specific application requires it. I'd imagine Chrome really doesn't need a virtual Java and could use one that's part of the build


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Thursday, July 3, 2014 9:51 PM
  • It's a stand-alone installer. You first need to uninstall any previous Sequencer version, then  install the 'HF'.

    I admit this is not what you expect from a 'hotfix'


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Friday, August 1, 2014 3:13 PM
    Moderator

All replies

  • I have not heard of issues opening the packages but either way, I'm not sure deleting the Java files from the package would be the best path forward.

    I believe the conversion tool has been a complaint by many. The consensus seemed to be re-sequencing applications was the most reliable method to use.

    Personally, I'd try converting, test. If it doesn't work I open up my recipe and re-sequence.

    Re: Java, if I was you I'd read this series of posts from Dan: http://packageology.com/2014/02/sequencing-java-the-definitive-guide-part-1/

    My personal preference is to keep the latest version of Java on my build as a local app and sequence an older version only when a specific application requires it. I'd imagine Chrome really doesn't need a virtual Java and could use one that's part of the build


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Thursday, July 3, 2014 9:51 PM
  • Just my 2 cents, but we decided for the most part not to convert packages from 4.6.  While there are packages that worked fine, and we still have the conversion tool in our back pocket, we found that in reality converting didn't buy us a lot.  This is ALL from my experience, I don't mean to represent anything other then my own experiences with the conversion.

    Basically it boiled down to packages that were easy enough for us to be OK with converting were also easy enough to re-sequence in 15 mins.
    Either way, we found you still want to function test end to end again, convert scripts, etc.  We also had experiences where the package would work 100%, until you did an update in the sequencer, and then it would just crash and burn.  I have used the tool on packages and been perfectly happy the output, but on a day-to day basis we resequence.

    Friday, July 4, 2014 4:46 AM
  • I believe the conversion tool has been a complaint by many. The consensus seemed to be re-sequencing applications was the most reliable method to use.

    Just want to make sure I get you right, do you mean that there was lot of complaints about conversion tool (powershell)? And By re-sequencing, do you guys mean to sequence the package from binaries from scratch, right?

    Thanks to both of you :)

    Saturday, July 5, 2014 10:16 AM
  • Yes, when we say conversion we mean the powershell tool, and when we say re sequence we mean from scratch, from the source code / binaries. 
    Saturday, July 5, 2014 8:03 PM
  • Hello,

    recommendation would be to use App-V 5.0 SP2 Hotfix 4 sequencer to convert any packages, and deploy onto a SP2 HF4 client aswell.

    http://support.microsoft.com/kb/2956985

    But yes, conversion would require an user acceptance test to verify that it is successfull.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, July 6, 2014 7:13 PM
  • Hello,

    recommendation would be to use App-V 5.0 SP2 Hotfix 4 sequencer to convert any packages, and deploy onto a SP2 HF4 client aswell.

    http://support.microsoft.com/kb/2956985

    But yes, conversion would require an user acceptance test to verify that it is successfull.


    Nicke Källén | The Knack| Twitter: @Znackattack


    I downloaded sequencer installer from MDOP 2014 and hotfix 4 seems already to be applied, could it be so? My sequence version is 5.0.3361.0.
    Thursday, July 31, 2014 3:24 PM
  • Hi,

    probably not.

    5.0.3361.0 is 5.0 SP2 (without any HF).

    HF4 has 5.0.3400.0 as its build number


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Thursday, July 31, 2014 3:46 PM
    Moderator
  • Is the installer of HF4 a stand-alone?

    Because the problem is, that if I install sequencer from MDOP media (5.0.3361.0), and then launch HF4 installer, it keeps telling me that it does not support upgrade or is already installed.

    Friday, August 1, 2014 3:09 PM
  • It's a stand-alone installer. You first need to uninstall any previous Sequencer version, then  install the 'HF'.

    I admit this is not what you expect from a 'hotfix'


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Friday, August 1, 2014 3:13 PM
    Moderator