none
Why did I need to install Google Crome RRS feed

  • Question

  • Because I wanted a modern browser on Windows Server 2008. Microsoft will only allow IE 9 and that browser will not display modern web sites.

    I just don't understand why ... what is the thinking process at Microsoft.

    Let me say it again. I HAD to install Crome.

    Thursday, April 3, 2014 2:58 AM

All replies